Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-19-2012, 06:34 AM
Shadowb1ade7 Shadowb1ade7 is offline
Fear the Blade!!!!!!!!!!!
 
Join Date: Sep 2012
Posts: 41
Default What is wrong?!?!?!?!

Ok, I have no idea what is with the transmission on my ranger! Me and my mom were driving to school (she's been borrowing Wheeljack). As we were driving out of our neighborhood the throttle seemed like it was going to get stuck. When we reached the exit of the neighborhood, we stopped. When we went to drive again, the engine got stuck and would not drive. We shifted into neutral, than back into drive and it drove fine to the school (I live no more than a mile from it) I don't know if it had anymore problems after. BTW the temperature here is 44 degrees. That may have something to do with it. PLEASE HELP ME!!!!!!!!!!!!!!!!!!!!!!!!
__________________
White 2000 Ford Ranger XLT Sport SuperCab 2 door "Wheeljack"
Reply With Quote
  #2  
Old 12-19-2012, 08:59 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,268
Default

Quote:
Originally Posted by Shadowb1ade7
Ok, I have no idea what is with the transmission on my ranger! Me and my mom were driving to school (she's been borrowing Wheeljack). As we were driving out of our neighborhood the throttle seemed like it was going to get stuck. When we reached the exit of the neighborhood, we stopped. When we went to drive again, the engine got stuck and would not drive. We shifted into neutral, than back into drive and it drove fine to the school (I live no more than a mile from it) I don't know if it had anymore problems after. BTW the temperature here is 44 degrees. That may have something to do with it. PLEASE HELP ME!!!!!!!!!!!!!!!!!!!!!!!!
Go buy a scanner and check for codes.

1999, Reg Cab, 2.5, 5 speed, 145k. (Sent from my DROID BIONIC using FRF App)
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Tags
problem, ranger 3.0 flex, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I don't know what I did wrong. But I know I did something wrong. darrell4977 4.0 SOHC / 4.0 OHV Tech 11 02-17-2012 07:29 PM
Not sure what or if anything is wrong greenmachine2000 Drivetrain Tech 6 11-01-2011 06:58 AM
How wrong is it... Kindy General Ford Ranger Discussion 34 02-28-2011 05:33 AM
right or wrong?? RangerLuc Off Topic 11 09-18-2010 06:20 AM
i think this is wrong FordRangerRunner Vehicle Snapshots 5 08-17-2010 11:00 AM