Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-02-2010, 07:54 AM
Tamarack Tamarack is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 1
Default XLT hesitates on acceleration

I just picked up an 06 XLT w/ 4L SOHC and 38K miles. I haven't put alot of miles on it yet but I have two issues/questions.
During light to medium acceleration, first gear seems to hesitate, almost like it's ratcheting into gear. I don't notice this under hard acceleration. All other shifts, up and down, seem fine.
Also, at highway speeds I'm feeling a vibration from the rear, like a tire out of balance. I'm wondering if it could be a U joint causing both problems?
Thanks, Mike
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
98' 3.0L... No acceleration, power, or pep HarveyT1184 3.0 Vulcan Tech 30 12-30-2011 05:42 PM
Dead spot in acceleration from idle? xdoomx 4.0 SOHC / 4.0 OHV Tech 15 12-15-2010 05:37 AM
92 Ranger 2.3L Acceleration Hesitation Tom M 4-Cylinder Tech 2 03-02-2010 07:14 PM
4.0L hesitates until full throttle? 6 months.. still no solution BlakeryBob03 4.0 SOHC / 4.0 OHV Tech 1 10-22-2009 12:16 PM
1999 Ranger 2wd hesitates meairda General Ford Ranger Discussion 0 04-06-2009 02:50 PM