Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-29-2010, 11:38 PM
eclipseguy eclipseguy is offline
Learning to use the forums
Join Date: Jan 2010
Posts: 1
Unhappy 4x4 not working

hello im new to this forum im trying to solve a problem. So i have a 1986 ford ranger stx it has the 2.9 I'm not sure on the transmission the t.c. is a warren 13-50.. but when i got the truck the 4x4 worked. but it out of nowhere just stopped working. then on its own it will start working again. so i will go hit a small trail and i cant get it out of 4x4. and have to wait till it will work again. so i thought it was a bad transfer case motor, so i put on in. still doing the same thing. any one have any ideas? any help would be awesome. the lights on the buttons to to switch in to 4x4 will turn on and off by them self. it scared the crap out of me when the first turned on. i had to slam on the brakes and make sure it did not accidentally shift in to 4 wheel drive.
Reply With Quote
Old 01-30-2010, 02:42 PM
geezmo2001 geezmo2001 is offline
My rangexplodeneer.
Join Date: Aug 2009
Posts: 247

Sounds like faulty wiring. Check wires going into transfer case for insulation deteriation/shorts. Just an idea, 'cause my 2001 had severely corroded wires and had similar symptoms.
2001 Extended cab Edge, 4x4, 4.0, 4.10 gears, 3" PA body lift, Heartthrob dual exhaust, Roush Thunderbolt signal mirrors, 8000k hid head/foglights, Mountaineer leather buckets, Xplorer shorty console, Alpine 9856 receiver, 10" type r sub in ported box, air box mod, throttle cable mod, Rancho R5000 shox, Scangauge II, plus many other things...
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
4x4 not working otwhitty1 Drivetrain Tech 12 02-09-2010 06:01 PM
Working under the Hood of your Ranger 02Edge General Ford Ranger Discussion 21 12-06-2009 06:56 PM
blinkers arent working RangerLuc Electrical Tech 26 11-11-2009 01:53 PM
Turn signals not working Poody86 Electrical Tech 8 10-08-2009 08:52 PM
A/C not working...could it be a/c relay sportscraft205 General Tech 2 07-06-2009 07:44 AM