Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-08-2010, 02:00 PM
ian5001 ian5001 is offline
Learning to use the forums
Join Date: Jan 2010
Posts: 3
Default 2007 4x4 trouble - Help Please!!!

Hi all, I have a 2007 (mk 3) Ranger xlt. Four wheel drive is not engaging / working.
It drives in all gears, all ratios / boxes, but only 2wd physically works.
All dashboard lights working and suggesting that 4x4 is working...
but i've got no front wheel drive in any gear?.
I have checked for the obvious wiring / sensor / damage faults but all seems to be ok.
I have the diagnogstic / engine fault light displayed on the dash, but this has always been on, even before the 4x4 fault. Any clues? Thanks a lot guys, all help appreciated.
Reply With Quote
Old 01-08-2010, 02:55 PM
whippersnapper02 whippersnapper02 is offline
Captain Barboza
Join Date: Sep 2009
Posts: 232
Send a message via AIM to whippersnapper02

Do the 4wd light come on when you shift into 4wd? How do you know you don't have power to the front wheels?
2010 Magnetic Grey Metallic Toyota Tacoma Double Cab TRD offroad 4wd
Originally Posted by RazorsEDGE View Post
A 2wd will go most anywhere a 4x4 will go as long as the ground is flat and dry. And as far as a 2wd rock crawling, well, that ain't rock crawling.
Reply With Quote
Old 01-08-2010, 03:05 PM
FireRanger FireRanger is offline
Blinded by the light
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger

If the t-case wasn't shifting, it would know and the lights wouldn't light up (or they would flash, i forget). But if your getting all the indications of it working properly but you have no power to the front wheels, i would suspect a busted driveline. U-Joint probably.
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Old 01-11-2010, 11:36 AM
ian5001 ian5001 is offline
Learning to use the forums
Join Date: Jan 2010
Posts: 3

Thanks for your replies...
I know that the front wheels are not driving for several reasons! Mainly experience, but we have severe ice here (truck stuck ice) and there is no drive at all from the front end - 4wd selected. The wierd thing is that the flashing 'hubs' locked warning light comes on at 60mph after selecting 4wd low or high and then switching back to 2wd high. (flashing green 'fwb' icon i think) I can turn this icon off via the switch on the dash.
Do you think this fault could be electrical? fuses etc.
I looked at the various sensors on the transmission casings. The small casing on the side of the main transmission casing is connected to the front prop. This small casing has several 'bolt on' parts, one of which, when removed is a small green plastic worm drive spline. Theres a small 1/2 inch gear wheel with a 'worm' drive exxtending from it. I would expect this to move when 4wd is selected to engage something. When I select / deselect 4wd nothing happens to this small drive gear. The wire to this 'worm drive' is good with no flaws. What does this thing do?
thanks, Ian

thanks again...
Reply With Quote
Old 01-11-2010, 01:02 PM
Jay FX4 Jay FX4 is offline
Join Date: Jun 2009
Posts: 2,511

Keep in mind guys that he's in the UK. I know nothing of those trucks, so I'm no going to speculate...
Originally Posted by Ranger Dave (B25) View Post
Our foreign policy is laughable at best. As is the recipient of this years Cracker-Jacks prize for 'peace.'
Originally Posted by Toms984x4 View Post
NOS for teh horse powaz!!!
ɹǝʌo ǝɯ dılɟ
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Ranger on 35s? help/questions fyamoahaxracer Lifted Suspension 18 10-09-2011 07:48 AM
2007 2wd lift kit Alfreado121 Lifted Suspension 1 10-17-2009 12:20 AM
newbee 2007 ranger 4x4 dangerranger757 Introduce Yourself 9 09-26-2009 04:01 PM
lift for a 2007 Ranger Sport 2WD?? madmike16 Lifted Suspension 4 06-23-2009 07:34 AM
My 2007 Ranger TDCi RangerTDCi Vehicle Snapshots 6 05-25-2009 02:42 AM