Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-04-2010, 04:22 PM
derskine2 derskine2 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 2
Default Drivetrain question

2001 Ford Ranger, 3.0, 4wd, auto, 43K miles. In cold weather, the truck sometimes starts out with a sharp bang, like a shot. Reminiscent of a blown front hub on my old Bronco. Mechanics have checked hubs, transmission, drive shaft, and differential and can find nothing wrong. It drives well otherwise. I have about 1K miles left on the used vehicle warranty and would like to resolve this issue before I have to pay for it. Do you have any suggestions? Thank you.
__________________
Dale in PA
2001 XLT 3.0L 4WD
Auto Extended Cab
Stepside
43K miles
Reply With Quote
  #2  
Old 01-04-2010, 04:45 PM
Jay FX4 Jay FX4 is offline
▲▼▲▼▲▼▲▼
 
Join Date: Jun 2009
Posts: 2,511
Default

A common cause of what you describe comes from the rear drum brakes.
__________________
Quote:
Originally Posted by Ranger Dave (B25) View Post
Our foreign policy is laughable at best. As is the recipient of this years Cracker-Jacks prize for 'peace.'
Quote:
Originally Posted by Toms984x4 View Post
NOS for teh horse powaz!!!
ɹǝʌo ǝɯ dılɟ
Reply With Quote
  #3  
Old 01-05-2010, 08:00 AM
derskine2 derskine2 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 2
Default

Thanks. That occurrred to no one. I'll mention it to the dealer.
__________________
Dale in PA
2001 XLT 3.0L 4WD
Auto Extended Cab
Stepside
43K miles
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
drivetrain upgrades to 1996 ford ranger? Bob Drivetrain Tech 1 05-04-2009 03:38 AM