Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-07-2011, 08:54 PM
TashOriginals TashOriginals is offline
Learning to use the forums
 
Join Date: Nov 2011
Posts: 1
Default Drive and Reverse wont work, but Low1 to Low2 to Drive does.

Hey guys, trying to help out my father here. Here's the deal. Automatic trans was slipping really bad, dropped the pan, replaced the gasket and filled it back up, plus a bottle of lucas.

Now, if you drive like a grandma in "Drive" it slips and starts going. If you drive like a normal person is just stays slipping. If you take off in Low 1, shift into Low 2, get going to about 40mph and put it into Drive, you're golden.

Additionally, reverse barely works. My father says that on older transmissions, when you loose First and Reverse, that meant that the front pump went out, however, I decided to come see you guys for more help.

Thanks in advance!
Reply With Quote
Reply

Tags
transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio,CD sound cuts out in reverse, drive - 2004 XLT MikRF Electrical Tech 1 09-10-2011 11:29 AM
truck wont drive Riverranger General Ford Ranger Discussion 4 07-23-2011 04:02 PM
No reverse or drive Darren hill Drivetrain Tech 6 04-03-2011 09:03 PM
TSB Rough engagement into drive/reverse 2007-10 A/T mickblock Drivetrain Tech 0 03-13-2011 09:53 AM
I have a 1991 ford ranger 4x4 automatic. I just lost drive and reverse. ? nonnaleveille Drivetrain Tech 4 01-17-2009 02:33 PM