Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 11-22-2009, 09:00 PM
pmac pmac is offline
Ford Pickup
Join Date: Oct 2009
Posts: 105
Default 4X4 Problems

Today i was out hunting and i was using 4 high and low because of deep snow and it was working fine, but later when i switched it into 4WD there was a loud clicking/banging noise in the front end. It made this sound in both 4 high and 4 low. Does anyone know what this is or how to fix it. Thanks
2003 FX4 Off Road, 4 door, 4.0L, auto, Dee Zee toolbox, Alpine CDA-9886 deck.
Reply With Quote
Old 11-22-2009, 10:39 PM
adam04 adam04 is offline
Learning to use the forums
Join Date: Nov 2009
Posts: 5

i have had a grinding noise coming from the fron of my car for a while now, i paid no attention to it because it wasnt that bad, but after i changed both rotors hubs and calipers, it is still there, the CV joints didnt look or feel bad, and when i went to put it into 4x4, the same thing happened, i have an 04 ranger with the 4.0 V6 auto.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Problems Bear Drivetrain Tech 10 01-26-2010 01:34 AM
Help me 4x4 problems ronald44 Drivetrain Tech 0 11-16-2009 05:52 PM
AC Problems ianbordas General Tech 3 09-24-2009 09:49 PM
03 engine problems trailblazing81 3.0 Vulcan Tech 3 08-13-2009 08:06 PM
Rear End Problems cspeir Drivetrain Tech 4 06-30-2009 07:06 PM