Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 07-29-2011, 01:32 AM
RangerCeo RangerCeo is offline
The Ceo
Join Date: Feb 2011
Posts: 4
Default 4wd will not engage

I have a 97 ranger V6 4wd manual hubs and the 4wd has been giving me problems since last year before the big winter season here in IL. Now the problem is when I turn the selector switch to 4lo it engages most times, then if I try to switch to 4hi from 4lo I get nothing, even if try to switch from 2wd to 4hi nothing, then the 4hi and 4lo lights blink on the dash.

Some of the things ive tried was change 4wd module and it worked for maybe a day untill the same problems started to occur again. Next I checked the shift motor and its connections and it seemed fine. I checked the fuses, nothing there. And the selector switch doesnt seem to be bad. Now ive tried and looked at basically everything I think, Ive read and researched and feel like im at a dead end. I dont know if im missing something but please help!
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
4WD Problem - Blinking 4WD Lights Sailor Jerry Drivetrain Tech 9 02-01-2013 01:59 PM
2007 ranger 4wd won;t engage longarm General Ford Ranger Discussion 6 07-19-2011 08:14 AM
4WD high and 4WD low lights blinking.. WTF! speedfreak87 Drivetrain Tech 2 03-07-2011 04:33 AM
4 Hi doesn't engage dustynjustin Drivetrain Tech 1 08-30-2010 06:17 PM
94 clutch won't engage 94 Splash Drivetrain Tech 0 10-10-2009 03:46 PM