Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > Drivetrain Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 03-28-2011, 04:07 PM
TTB man
 
Join Date: Aug 2010
Posts: 1,923
Default Anyone have an A4ld Auto tranny?

Does it shift hard into drive and reverse? Does it also shift hard while driving and doesnt seem to want to downshift until the gas is let off? Well, this is what mine was doing and I've fixed my problem with about $30. My problem was a vacuum diaphram on the transmission with a vacuum line leading up to the intake manifold. I replaced the vacuum diaphram(be sure to put the little steel needle back in the new diaphram from the old one btw, found that out the hard way...) but really didnt make much difference. I then poked around and found that the little rubber hose leading from the vacuum line to the diaphram was stretched so there was a vacuum leak. I replaced that and installed hose clamps on it so there was no chance of leaks. vwalah! I have more power and smoother shifts than I know what to do with! Just thought I'd share this with anyone else who is having this problem. I thought it was my valve body gasket going bad.
__________________
1993 Ford Ranger Ext. Cab | stepside | 4x4 | 4.0L | Lifted | 35" BFG KM2s | MT Classic IIs | Dana 35/Disc 8.8 with 4.56's | Duals | Etc

RIP JASON
Reply With Quote
  #2  
Old 03-28-2011, 04:28 PM
TRUCK SOLD!
 
Join Date: Feb 2011
Posts: 2,025
Default Re: Anyone have an A4ld Auto tranny?

Thanks for the insight!
I'll keep that in mind on my NEXT tranny.
The first one did what you were saying,
than a couple weeks later...BAM ...Tranny lost reverse!
__________________
1999 Ford Ranger XL
Vulcan V6, K&N 33-2106 Filter, 3:73 Gears,
FRONT 3'' Susp Lift/REAR 3'' susp.+ 3" blocks,06 Mirrors
31"/10.5"-15" BFG on AR-172 Polished Rims,Smitybilt Console
95 Mustang Saleen Seats,Alternating Blinker MOD
Pioneer CD/iPod/GPS,6.5 Polk Audio/6.5 Sub-Woofers,
Stainless Bed Extender,Throttle and Dome Light MOD,
12" Tool Box,Billet Grille,NightShade Tint,Projector Headlamps
6000K H.I.D. so i can see at night! LOL


JESUS is LORD!
Reply With Quote
  #3  
Old 03-28-2011, 05:09 PM
TTB man
 
Join Date: Aug 2010
Posts: 1,923
Default Re: Anyone have an A4ld Auto tranny?

Yea I hope I've saved it in time
__________________
1993 Ford Ranger Ext. Cab | stepside | 4x4 | 4.0L | Lifted | 35" BFG KM2s | MT Classic IIs | Dana 35/Disc 8.8 with 4.56's | Duals | Etc

RIP JASON
Reply With Quote
  #4  
Old 03-28-2011, 05:49 PM
Ford Life.
 
Join Date: Oct 2010
Posts: 6,267
Default Re: Anyone have an A4ld Auto tranny?

A4LD's have always been finisky like that. Small problems make them suck. Glad you got it fixed man!
__________________
Shaun
2003 Ford Ranger Edge
Lifted and stuff.

Quote:
Originally Posted by tylercollins30 View Post
If you disagree well your gayer than a bag of dicks!
Quote:
Originally Posted by weathermaker View Post
truck forums are just a big circle jerk
Reply With Quote
  #5  
Old 04-12-2011, 01:02 AM
Learning to use the forums
 
Join Date: Apr 2011
Posts: 9
Default Re: Anyone have an A4ld Auto tranny?

My Problem seems to be Shifting from 1st to 2nd when its cold..After it warms up, it will shift fine..The fluid looks fine..Just the first mile or so it doesnt want to shift..
__________________
2008 MAzda 6 (silver)

1996 Chevy Excab 3/4 (silver)

1999 Neon (woohoo purple)

1993 Ford Ranger (just Blue)
Reply With Quote
  #6  
Old 04-12-2011, 04:48 AM
TTB man
 
Join Date: Aug 2010
Posts: 1,923
Default Re: Anyone have an A4ld Auto tranny?

Mine still does that when its really cold out. I think this summer I'll drop the pan and change the valve body gaskets and the governor and install a shift kit.
__________________
1993 Ford Ranger Ext. Cab | stepside | 4x4 | 4.0L | Lifted | 35" BFG KM2s | MT Classic IIs | Dana 35/Disc 8.8 with 4.56's | Duals | Etc

RIP JASON
Reply With Quote
  #7  
Old 04-14-2011, 06:30 PM
13mm Guru
 
Join Date: Apr 2011
Posts: 115
Send a message via Skype™ to Huck
Default Re: Anyone have an A4ld Auto tranny?

I've had ONE A4LD... Never again!
__________________
1992 XLT.
2.3 Eight plug w/5 speed
High flow filter with functional scoop.
http://www.fuelly.com/smallsig-us/70702.png
Reply With Quote
Reply

Tags
a4ld, downshift, hard shift, transmission, vacuum diaphram

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 4.0 2WD auto tranny issues ammotiger Drivetrain Tech 0 02-22-2011 11:09 AM
2.5l auto tranny wont shift druwevr Drivetrain Tech 0 08-28-2010 07:42 AM
Rpm's jump 300 with each shift. Why? A4LD auto explorerx101 Drivetrain Tech 0 07-23-2010 11:29 PM
oo 4cy auto 2wd tranny swap question 00dangerranger Drivetrain Tech 0 03-28-2010 10:45 AM
91 2wd ranger, A4LD auto trans problems. stclist111 Drivetrain Tech 2 12-16-2009 04:37 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.