Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-26-2011, 02:52 PM
94rangerx 94rangerx is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 3
Default 3.0 transmission question

today i was driving down the road and all of a sudden it reved up to 5 grand on the tach and wouldnt pick up speed so i pulled over in a driveway to check the fluid and it was fine but when i got back in and put it in reverse and pressed the gas it started going forward put it in nutral and press gas and it still went forward, so i just turned around in the field and got back on road and it wouldnt shift from 1st gear, so im guessing the trans is gone most likly, i was wondering what years transmission will work, ive asked around and everybody sayin that any year will work but i dont think they will, i have a 94 ranger 3.0 auto, was just thinking about puttin a 5spd in it instaed.
Reply With Quote
  #2  
Old 03-26-2011, 03:34 PM
Christianguy Christianguy is offline
TRUCK SOLD!
 
Join Date: Feb 2011
Posts: 2,025
Default Re: 3.0 transmission question

If it's NOT the linkage ,it MIGHT be your tranny.
dunno on your answer...

ANYONE?
__________________
1999 Ford Ranger XL
Vulcan V6, K&N 33-2106 Filter, 3:73 Gears,
FRONT 3'' Susp Lift/REAR 3'' susp.+ 3" blocks,06 Mirrors
31"/10.5"-15" BFG on AR-172 Polished Rims,Smitybilt Console
95 Mustang Saleen Seats,Alternating Blinker MOD
Pioneer CD/iPod/GPS,6.5 Polk Audio/6.5 Sub-Woofers,
Stainless Bed Extender,Throttle and Dome Light MOD,
12" Tool Box,Billet Grille,NightShade Tint,Projector Headlamps
6000K H.I.D. so i can see at night! LOL


JESUS is LORD!
Reply With Quote
  #3  
Old 03-26-2011, 04:20 PM
everclear000 everclear000 is offline
Liking the Ford Ranger Forum
 
Join Date: Mar 2011
Posts: 21
Default Re: 3.0 transmission question

sounds like shes toast? did u smell the fluid.
i would call the dealer on the tranny Q

Last edited by everclear000; 03-26-2011 at 04:24 PM.
Reply With Quote
  #4  
Old 03-27-2011, 05:30 AM
94rangerx 94rangerx is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 3
Default Re: 3.0 transmission question

yea i checked the linkage, im gonna go pull the pan off here in a little while and check it out, but im pretty sure its gone cuz its been slippin between 2 and 3 and i changed the fluid and filter in it bout three weeks ago and there was little metal shavings in it
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission question Tenyears94 Drivetrain Tech 2 03-01-2011 10:52 PM
A question about Automatic transmission kerem General Tech 3 12-25-2010 10:29 AM
transmission question mmmaxwell 3.0 Vulcan Tech 0 08-16-2010 05:21 PM
Transmission question mcblckb Drivetrain Tech 4 07-15-2010 10:44 PM
transmission reverse question EdGein Drivetrain Tech 1 01-09-2010 05:55 PM