Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-05-2011, 09:58 PM
filluptrk filluptrk is offline
Learning to use the forums
Join Date: Mar 2011
Posts: 1
Default New guy, old truck, quick question

I have an 83 2.8 V6 with a clutch question. It was working fine one night next day felt just like before, but no disengage. Figured one of the cylinders so replaced master & slave. Bled them like all the other ones, pedal feels perfect blocked pedal to floor and popped bleeder about 3 or 4 times, no air shot fluid right past real axle each time.

No luck, pedal feels just like it always did, no excess play no softness like with air in it, but will not completely disengage. If you put it in gear and start it up it drags really bad.

I am guessing the release fork has bent. Any ideas, it is not hard to take out, I've done about 6 other cars, my 59 F100 was the easiest, just crawl under and take it right out super easy. Thanks for any help.
83 Long Bed with Gem shell. Supposedly first V6 sold in Santa Clara Valley. It is just a great little truck, no real changes, just keeps me going day in and day out.

Last edited by filluptrk; 03-05-2011 at 09:59 PM. Reason: error
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
quick question needs quick answer mfernandes Electrical Tech 1 02-10-2011 04:38 PM
Quick Question Decepticon Exterior Tech 9 01-18-2011 07:14 AM
Quick question about my stock truck AlxGry Wheels and Tires 4 11-18-2010 02:40 PM
Quick Question Ranger Kid General Ford Ranger Discussion 15 11-11-2010 01:58 AM
Quick question robsranger Wheels and Tires 1 02-10-2010 03:01 PM