Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 02-22-2011, 09:12 PM
kmk7110 kmk7110 is offline
Ford Tough
Join Date: Feb 2011
Posts: 322
Default 4wheel drive problem

I'm having a problem with the 4x4 on my 2003 ranger fx4. It has 67k on it, and a noise from the transfer case area when I turn the switch to 4Hi or 4Lo. In 2wd it has no problems, it engages just fine takes a few feet to start a hum sounding noise, doesnt disengage as fast tho almost have to switch it to reverse to get it to disengage. It wasn't making the noise before, but i recently did the brakes and a caliper bolt came loose and long story short damaged the rim to the point of poking a hole in the backside, not sure of the relevance to that or not. Also when it engages it pulls to the passenger side.

Any other questions just ask. I acquired the truck from my aunt about 600 miles ago.
Reply With Quote

4x4, fx4, noise, transfer case

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Four Wheel Drive Problem Flyman41 Drivetrain Tech 11 02-26-2011 10:46 AM
Four wheel drive problem ArsenalMcnasty Drivetrain Tech 2 01-28-2011 03:09 AM
4wheel drive lights flashing rangerkid53 3.0 Vulcan Tech 1 08-31-2010 10:39 PM
Having issues with the 4wheel drive CSMonte Drivetrain Tech 3 06-03-2010 06:43 PM