Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-16-2011, 05:36 PM
Westiedog Westiedog is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 12
Default Speedo problems need assistance

So you all know check engine came on abs came on no speedo reading..... Ok so the fix for this is a new VSS. I just swapped it out with a new napa Vss it read 1.88k Ohms same as auto zone so i picked it up installed it and what do you know i get nothing.... Which leads me to my next point what do i do now. I know the abs is controlled by that sensor so maybe it could be my #3 Relay or My #7 relay under my hood Because those both deal with the 4WABS. Idk what to do next i want it fixed it doesnt need to be fixed but i would really enjoy that for when i have to sell my truck. Maybe the magnet it reads off of in the Diff housing could have came loose.... Idk im just throwing ideas around....

Any help would be apprieciated thanks all.



EDIT: I looked at the owners manual again turns out relay number 3 is actually a fuse for the 4WABS 50A Then i look under the hood and there isnt even a fuse in that slot. So should i put one in or do i not have 4WABS.

----------

So damn confused i dont even care if my speedo works i just want to get it to work because its giving me so many problems.
__________________
2000 Ford Ranger 2.5l SOHC, 5spd Manual, Cold air intake, 2.25 catless pipes to a flowmaster 40 side exit exhaust, H.I.D.s, 2 10" subs with custom built box that fits perfectly.

WhItE LiGhTnInG

Last edited by Westiedog; 02-16-2011 at 05:34 PM.
Reply With Quote
  #2  
Old 02-16-2011, 05:49 PM
MrO MrO is offline
Like the Forums
 
Join Date: Feb 2011
Posts: 43
Default Re: Speedo problems need assistance

Quote:
Originally Posted by Westiedog View Post


----------

So damn confused i dont even care if my speedo works i just want to get it to work because its giving me so many problems.
Heh... well maybe u should buy a bigger sized speedo. You shouldn't use speedos anyway as they can kill your little rangers... they probably cut off all circulation to the area.
__________________
2002 single cab ranger
2.3l 5speed.
Crappy vinyl interior with bench seats. No power windows or locks. Simplicity.
Reply With Quote
  #3  
Old 02-16-2011, 06:05 PM
Westiedog Westiedog is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 12
Default Re: Speedo problems need assistance

Quote:
Originally Posted by MrO View Post
Heh... well maybe u should buy a bigger sized speedo. You shouldn't use speedos anyway as they can kill your little rangers... they probably cut off all circulation to the area.
Wow dude i came on here for a comedy act and i got it thanks alot bro. I mean i deffinitally didnt come on here for any info or assistance so thanks.
__________________
2000 Ford Ranger 2.5l SOHC, 5spd Manual, Cold air intake, 2.25 catless pipes to a flowmaster 40 side exit exhaust, H.I.D.s, 2 10" subs with custom built box that fits perfectly.

WhItE LiGhTnInG
Reply With Quote
  #4  
Old 02-16-2011, 06:12 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Speedo problems need assistance

There's a good chance that your Ranger has RABS instead of 4WABS - both were available in 2000. If it does have RABS, the signal from the rear axle sensor goes via 2 wires to the GEM module where it is corrected for tire diameter and sent on as a 12v square wave to the speedometer, PCM and speed control, if equipped.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #5  
Old 02-17-2011, 02:04 PM
Westiedog Westiedog is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 12
Default Re: Speedo problems need assistance

Quote:
Originally Posted by rwenzing View Post
There's a good chance that your Ranger has RABS instead of 4WABS - both were available in 2000. If it does have RABS, the signal from the rear axle sensor goes via 2 wires to the GEM module where it is corrected for tire diameter and sent on as a 12v square wave to the speedometer, PCM and speed control, if equipped.
Is there a way to tell specifically whether or not i have 4wabs or rabs. And if it is RABS what should i look for next to fix this problem because my abs light isnt on any more but i still have no speedometer. Thanks for the help.
__________________
2000 Ford Ranger 2.5l SOHC, 5spd Manual, Cold air intake, 2.25 catless pipes to a flowmaster 40 side exit exhaust, H.I.D.s, 2 10" subs with custom built box that fits perfectly.

WhItE LiGhTnInG
Reply With Quote
  #6  
Old 02-17-2011, 06:13 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Speedo problems need assistance

A 4-cylinder truck probably has RABS and the fact the the 4WABS fuse is missing seems to support that. I get the impression that the problem is new and at one time the speedometer was working and the ABS light was off.

You can also look for a wire leading to an ABS sensor at each of the 2 front spindles. 4WABS trucks have them, RABS do not.

Assuming that it is RABS:
  • First off, check fuses 10, 14, 20, 26, 28 and 30 in the dash fuse box.
  • You've already swapped the axle sensor so let's call that good for now.
  • Do continuity checks on the red/pink and light green/black wires between the VSS plug and the GEM plug in the radio cavity in the center of the dash.
  • Do continuity checks on the gray/black between the GEM plug and the speedometer plug and PCM plug and speed control plug.
  • If the fuses and wires are OK, that leaves the speedometer head, the axle sensor and the GEM.

All sensors and modules must be disconnected from the tested wire during continuity checks.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #7  
Old 02-17-2011, 10:06 PM
Westiedog Westiedog is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 12
Default Re: Speedo problems need assistance

I checked those fuses and ill probably be doing those continuity tests this week end. The differential sensor might be bad be cause it reads 1.88k Ohms and i believe the tollorence is 800 Ohms to 1400 Ohms. So im not sure im probably going to be hitting up the junk yard tomarrow to look for like 2 or three other VSS and a older style 2.3l lima header.
__________________
2000 Ford Ranger 2.5l SOHC, 5spd Manual, Cold air intake, 2.25 catless pipes to a flowmaster 40 side exit exhaust, H.I.D.s, 2 10" subs with custom built box that fits perfectly.

WhItE LiGhTnInG
Reply With Quote
  #8  
Old 05-21-2011, 03:03 PM
kevantam kevantam is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 2
Default Re: Speedo problems need assistance

I know I am brand new to the forum but have been running back & forth to advance for parts to repair this @#$*'N speedometer problem and while researching all possibilities for a fix, I ran across alldata site with possible solution to our problems. The GEM/ECM controls most aspects to our symptoms (if not a fuse/wiring/sensor issue) and if you have altered your tire size from stock your GEM needs to be reprogrammed at a dealer unless you have access to software & module programmer.
__________________
kevantam
1997 Ranger SuperCab A/T 4.0 V6 4X4
Reply With Quote
  #9  
Old 05-21-2011, 04:16 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Speedo problems need assistance

Quote:
Originally Posted by kevantam View Post
I know I am brand new to the forum but have been running back & forth to advance for parts to repair this @#$*'N speedometer problem and while researching all possibilities for a fix, I ran across alldata site with possible solution to our problems. The GEM/ECM controls most aspects to our symptoms (if not a fuse/wiring/sensor issue) and if you have altered your tire size from stock your GEM needs to be reprogrammed at a dealer unless you have access to software & module programmer.
Your signature says that you have a 97 Ranger.

In the years 95~97, the GEM and PCM have no control over the calibration of the speedometer. The VSS Signal Generator sends the VSS pulse directly to the speedometer and tire/axle ratio changes can be recalibrated using interchangeable gears that drive the Signal Generator. There is nothing in the GEM or PCM that can be reprogrammed for the speedometer in those 3 model years.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #10  
Old 05-21-2011, 04:35 PM
Christianguy Christianguy is offline
TRUCK SOLD!
 
Join Date: Feb 2011
Posts: 2,025
Default Re: Speedo problems need assistance

Quote:
Originally Posted by rwenzing View Post
Your signature says that you have a 97 Ranger.

In the years 95~97, the GEM and PCM have no control over the calibration of the speedometer. The VSS Signal Generator sends the VSS pulse directly to the speedometer and tire/axle ratio changes can be recalibrated using interchangeable gears that drive the Signal Generator. There is nothing in the GEM or PCM that can be reprogrammed for the speedometer in those 3 model years.
Huh? Your FIRST Sig reads he has a 2000,
But the second one reads 97...which do you have?
__________________
1999 Ford Ranger XL
Vulcan V6, K&N 33-2106 Filter, 3:73 Gears,
FRONT 3'' Susp Lift/REAR 3'' susp.+ 3" blocks,06 Mirrors
31"/10.5"-15" BFG on AR-172 Polished Rims,Smitybilt Console
95 Mustang Saleen Seats,Alternating Blinker MOD
Pioneer CD/iPod/GPS,6.5 Polk Audio/6.5 Sub-Woofers,
Stainless Bed Extender,Throttle and Dome Light MOD,
12" Tool Box,Billet Grille,NightShade Tint,Projector Headlamps
6000K H.I.D. so i can see at night! LOL


JESUS is LORD!
Reply With Quote
  #11  
Old 05-21-2011, 04:39 PM
kevantam kevantam is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 2
Default Re: Speedo problems need assistance

rwenzig i posted in answer 2 westiedog as he has late model not for my own benefit.
__________________
kevantam
1997 Ranger SuperCab A/T 4.0 V6 4X4
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo problems need assistance Westiedog 4-Cylinder Tech 0 02-16-2011 03:57 PM
some assistance please Giangrosso Interior Tech 3 08-20-2010 01:40 PM
erratic speedo problems HELP 4evermodding 3.0 Vulcan Tech 3 07-21-2010 01:07 PM
Speedo Problems bfdast 4-Cylinder Tech 0 06-30-2010 08:33 PM
clutch assistance fiddler90 Drivetrain Tech 1 02-17-2010 09:53 PM