Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 02-15-2011, 07:24 AM
redxlt redxlt is offline
Retired and loving it
Join Date: Dec 2010
Posts: 182
Send a message via MSN to redxlt
Default Shifting issue?/lack of power?

86 XLT automatic. Every morning when I start vehicle everything is fine.I drive about a mile stop at a light and when I start moving the truck bogs down as if the engine is starving for fuel. There is no acceleration. I let off the gas and engine returns to normal and I try it again and same thing. I let off gas and then retry and truck launched forward as if it jumps off the ground. Then it bogs down again. I release gas pedal and then reapply and it runs as if nothing ever happened. It if ok for the rest of the day. Today it stalled as I took off from light but restarted quickly and then the lack of power. It bogged down 2 times and stalled once before returning to normal.
Transmission,Throttle body, or ? Trans mounts are good.
The truck isnt my daily driver so the problem isnt an emergency . But I would like to have it working properly. Thanks for the input
1986 XLT extended cab 51000 miles 2.9 V-6 Automatic. Runs like a dream. 22 MPG

"Life is tough...Its tougher if you are stupid"
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent lack of power and low idle wallabysailor 4.0 SOHC / 4.0 OHV Tech 9 03-22-2011 01:28 AM
manual Shifting issue? if you can call it that. FFSHOKE 4-Cylinder Tech 6 02-13-2011 04:09 PM
2.3L 5 Speed lack of power Deadokie21 4-Cylinder Tech 1 09-20-2010 01:05 AM
Irregular shifting and slight lack of power along with a rattle Am3rican_Rang3r General Tech 5 03-13-2010 01:43 AM
Dimmer (or lack thereof) issue davekellynv Electrical Tech 2 12-23-2009 03:20 PM