Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-12-2011, 09:29 PM
theycallmetex theycallmetex is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Transmission Problems Help!!

First off it's a 2000 Ranger Sport, reg cab, 4 cylinder, automatic.

Today coming home from work the Ranger started having some issues. Accelerating from a stop light the revs shot up as well as the speedo, then the speedo dies, the truck shot forward, and the ABS light came on as well as the O/D light started flashing until i got the truck home. It was shifting hard the rest of the way home.

From what I have gathered, the speedo and O/D light are potentially related to the speed sensor.

My best guess for the ABS light is just an ABS sensor.

Here is the biggie though. After restarting I only have first gear when in "Drive". Will not go into second or any other gear. "Park", "Neutral", and "Reverse" are unaffected. When in "2", it is only second gear and no first gear. So it starts in second gear from a stop when in "2". Position "1" is unaffected.

Any advice?
__________________
2000 Ranger Sport

Green 'n rusty
Auto 4banger
Reply With Quote
  #2  
Old 02-12-2011, 09:35 PM
Twisty Twisty is offline
Ford Tough
 
Join Date: Jun 2009
Posts: 422
Default Re: Transmission Problems Help!!

The fluid level is good?
__________________
2006 4.0 5 spd auto 4x4 Super Cab
BF Goodrich Commercial Traction T/A's
Royal Purple Throughout
Alpine Head Unit with some Infinity Noisy Stuff
NW Oregon
Reply With Quote
  #3  
Old 02-12-2011, 09:36 PM
terryduanemiller terryduanemiller is offline
www.shanewootenband.com
 
Join Date: Oct 2010
Posts: 1,896
Default Re: Transmission Problems Help!!

cant say it will solve your issue, but I have a friend that had same issue on a late model Ram, they serviced the trans (fluid n filter) and is working perfect..
the filter cld be gomed up, or tranny has failure..
__________________
MY BUILD THREAD
1999 MAZDA 2500SE, 2.5L 4-clanger, 5 speed, Green n slow. Rangers as daily drivers since 1988.
ASE Certified Mechanic, Builder of Show Destroying Protouring and Classic cars..
Reply With Quote
  #4  
Old 02-12-2011, 10:27 PM
theycallmetex theycallmetex is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: Transmission Problems Help!!

Trans fluid level is good. Still has good color too.
__________________
2000 Ranger Sport

Green 'n rusty
Auto 4banger
Reply With Quote
  #5  
Old 02-13-2011, 12:26 AM
01B3000 01B3000 is offline
Needs moar chrome....
 
Join Date: Dec 2010
Posts: 1,319
Default Re: Transmission Problems Help!!

Did you test the trans fluid with the truck running, in drive with a friend holding the brake, i remember i didnt do that on my moms edge when i checked it and i ended up overfilling the trans by 2 quarts.
__________________
2001 Mazda B-3000 CabPlus "FX2 Off Road"| 3.0 | 5 SPD | 3 In Spindle Lift | Belltech Shackles | UltraGauge |Alpine Head / 10" Kicker Setup | Air Box Mod | Add-A-Leaf| Thrush Welded B4 Rear Wheel | Kobalt Box | Cobra 19 DX IV | Custom PA Speaker | Front/Rear Tow Receiver | 2X Aux Lights | Hideaway Strobes | Back Rack Safety Rack | Amber LED Strobes | Blue LED Strobes | 265/75/R16 General Grabber AT2's
Quote:
Originally Posted by Clinton View Post
I like little girls...........
RIP Jason
Reply With Quote
  #6  
Old 02-13-2011, 06:09 AM
wvcat wvcat is offline
Ford Ranger Driver
 
Join Date: Jan 2010
Posts: 836
Default Re: Transmission Problems Help!!

I had a truck that wouldn't shift but I'm not positive what fixed it. I dropped the pan and tested all the solinoids. They all ohm'ed out ok so I tested them on the battery. I took a small screw driver and moved the valves in the valve body with it to make sure none were stuck. re-torqued the valve body and installed a new filter. When I put it back together it worked normally. I didn't have an abs light. You might want to clean or replace the speed sensor on the rear axle before you tear into the trans.
__________________
22 and counting...
Reply With Quote
  #7  
Old 02-17-2011, 08:18 PM
theycallmetex theycallmetex is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: Transmission Problems Help!!

Should I start by replacing the rear speed sensor or transmission speed sensor or both?
__________________
2000 Ranger Sport

Green 'n rusty
Auto 4banger
Reply With Quote
  #8  
Old 02-17-2011, 09:21 PM
wvcat wvcat is offline
Ford Ranger Driver
 
Join Date: Jan 2010
Posts: 836
Default Re: Transmission Problems Help!!

You won't have a speed sensor on your trans. I would try the one on the rear axle
__________________
22 and counting...
Reply With Quote
  #9  
Old 02-18-2011, 06:57 AM
darkstar_420 darkstar_420 is offline
Lowered 00
 
Join Date: May 2009
Posts: 765
Default Re: Transmission Problems Help!!

check fuses and relays, i had a buddy whos f150 got stuck in 3rd in drive, od light blinking, took it to ford and it was a fuse
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Problems rupert1027 Drivetrain Tech 2 11-14-2010 04:38 PM
transmission problems dangerranger93 Drivetrain Tech 1 07-11-2010 07:36 AM
help transmission shift problems!! kbiz Drivetrain Tech 14 06-06-2010 11:41 PM
2.3L auto transmission problems LifeofTheParty2 4-Cylinder Tech 11 04-20-2010 06:03 AM
Transmission Problems Bear Drivetrain Tech 10 01-26-2010 02:34 AM