Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-05-2010, 09:26 PM
Mike G Mike G is offline
Learning to use the forums
 
Join Date: Dec 2010
Posts: 1
Default Tranny appears to bind. CV joints?

Folks,

Newby here and need some advice. Have used the search function and may have found the problem. Unsure of solution.

Presently on packed snow and ice all the time in eastern WA. Use 4x4 hi engaged most of the time. After being parked a while, then get in, start truck, engage first, feels like parking brake is on (but not), I really have to let the clutch out, rev engine, then it releases suddenly. No popping noise is heard, it just lets loose quickly. Does not happen when in 2x drive. Have auto hubs.

Then during driving, no issues are had. I have 2x engaged the few times on pavement.

Could this be CV joints? Even if that's the problem, I don't understand why they would bind up then release.

Any comments from you experienced gearheads/

Thanks !!
__________________
Mike G.
2000 4x4 Ext cab, 5MT, V6
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
U-joints for lunch anyone Giangrosso Drivetrain Tech 0 10-28-2010 11:37 PM
ball joints druwevr Suspension Tech 0 10-02-2010 03:37 PM
Ball Joints tunafish25 Suspension Tech 4 06-06-2010 03:53 AM
U Joints calebw15 Drivetrain Tech 3 05-09-2010 03:23 PM
For Sale: Heim Joints bagged89 Suspension Parts 0 04-30-2010 11:28 AM