Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 10-16-2010, 06:43 PM
cudaman cudaman is offline
Learning to use the forums
Join Date: Oct 2010
Posts: 2
Default 7.5 problem??

Hi i hope someone can help me, i am trying to get my son's 94 ranger together for him. It has is a 2wd xlt extended cab 94 version with a 7.5 ring gear. My problem is the rear diff cover rotted out so i replaced it (tough finding one but i did a chrome one) now i can't get the fill plug out. In what order should i try, drilling a hole in cover an welding a nut on the inside to create a rear fill plug, drilling original plug out an attempting an ez out, welding a nut to orig plug an trying to turn it out that way. I have mapp'd gas, PB rust buster, mystery oil, still it defys me. Any help greatly appreciated.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! Chargerondavins General Tech 2 10-02-2010 09:46 AM
Anyone got the same problem 01Ranger01 Exterior Tech 3 06-13-2010 08:34 AM
4 by problem mikertldg Electrical Tech 0 01-26-2010 08:33 PM
what could be the problem? fordguyforever 4.0 SOHC / 4.0 OHV Tech 2 01-12-2010 08:55 PM
got a problem rangerman101 General Tech 0 01-11-2010 10:05 PM