Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-13-2018, 12:46 PM
the_dude the_dude is offline
Learning to use the forums
 
Join Date: Jul 2018
Posts: 2
Default 2004 Ranger 4x2 Tone Ring Rubbing

I have a 2004 Ranger Edge 4x2. I had some bad front wheel bearings, so I decided to replace them. Since they needed replacing, I also replaced the Rotors/pads. I just finished installing the first rotor, but I noticed that when I rotate the rotor, there are a couple places where the Tone ring lightly brushes against what i'm assuming is an ABS sensor. Pictures are below: (Sorry, I searched for the technical term for the part, but couldn't find anything)





I took the rotor off and tried to re-seat it, but i'm still running into the same issue. Is this normal or does it need to be addressed? Any help is greatly appreciated.
Reply With Quote
  #2  
Old 07-14-2018, 01:41 PM
the_dude the_dude is offline
Learning to use the forums
 
Join Date: Jul 2018
Posts: 2
Default Re: 2004 Ranger 4x2 Tone Ring Rubbing

I took the truck for a test drive and everything seems to be working fine. Iíll update this thread if it turns out to be an issue.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
low speed loud rubbing/humming tone oceanhilltender General Tech 12 05-20-2016 06:56 PM
8.8 tone ring !!!!!!!! limited slip rangerjunk Drivetrain Tech 6 01-11-2016 08:53 AM
M5OD-R1 tone ring Nauvoo Drivetrain Tech 0 04-17-2014 06:36 PM
Tone ring DaveQ General Tech 9 11-27-2013 09:21 AM
What is your ring tone? Dcrymes99ranger Off Topic 19 01-06-2011 10:19 AM