Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-20-2016, 07:57 AM
S7S S7S is offline
Learning to use the forums
 
Join Date: Mar 2015
Posts: 11
Default Speed Sensor

03 4 x , 4.0 . Changed hub assemblies, Drivers side sensor won't plug in to female connector. Any thoughts or experiences with this ?
Reply With Quote
  #2  
Old 03-20-2016, 08:20 AM
2004ranger4x4 2004ranger4x4 is offline
Ranger "Tough"
 
Join Date: Mar 2013
Posts: 576
Default

Quote:
Originally Posted by S7S View Post
03 4 x , 4.0 . Changed hub assemblies, Drivers side sensor won't plug in to female connector. Any thoughts or experiences with this ?
not sure... when I did mine it was the correct plug. Maybe go to the parts store and look at a different brand hub, I just went with the cheap drive works one from advance auto.
__________________
2004 ford ranger xlt. Torsion bar crank, AAL in the rear. 265/75/16 hankook dynapro MT's 4.0 liter, 4.10 gears. K&N cold air Intake,K&N performance fuel injectors,throttle cable mod. Herculiner bed liner. Leer truck cap.
Reply With Quote
  #3  
Old 03-20-2016, 10:01 AM
S7S S7S is offline
Learning to use the forums
 
Join Date: Mar 2015
Posts: 11
Default Re: Speed Sensor

Got the hubs from the dealership . My boy and I matched the plugs from the old passenger side hub. Old driver side hub sensor would not go back in.
The ABS light came on a couple weeks before hub change out.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.0L Coolant Temp Sensor & Transmission Speed Sensor apz*jr 4.0 SOHC / 4.0 OHV Tech 2 04-03-2015 05:36 AM
ABS Light - Replaced Diff. Speed Sensor & MC Sensor GlennFord General Tech 27 08-04-2014 05:22 PM
speed sensor kyranger98 Drivetrain Tech 1 12-09-2013 09:55 AM
Speed sensor MCM5595 Drivetrain Tech 0 07-11-2012 08:11 PM
Possible Speed Sensor??? What do you think? Stringer Drivetrain Tech 1 10-08-2010 11:23 AM