Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-13-2015, 08:54 PM
FUzzyBUnny FUzzyBUnny is offline
Ford Rangers
 
Join Date: Nov 2013
Posts: 209
Unhappy 1999 3.0 with the 4r44e O/D issues

The problem I am having with the truck is that it will only go into overdrive if I let off the gas a little. So while going down the road at about 55mph it is running 3000RPM. I let off the pedal a little and it will drop down to 2000 and shift into overdrive.

I have had it to a tranny shop and they say they cant find anything wrong with it. They hook up the scanner and checked all the solenoids. They said the fluid looks fine and does not need to be changed.

It is not giving off any codes and the overdrive light never flashes. Other then the hesitation going into overdrive it drives just fine. If I turn overdrive off on the shift lever and turn it back on it will also engage into overdrive.

So my question is could it just be the o/d band is out of adjustment?. That would explain why there is no codes and the fluid looks fine. I have never adjusted one before so I am not sure of what symptoms I would expect that would tell me for sure it is the bands?.
Reply With Quote
  #2  
Old 01-14-2015, 06:21 PM
FUzzyBUnny FUzzyBUnny is offline
Ford Rangers
 
Join Date: Nov 2013
Posts: 209
Default Re: 1999 3.0 with the 4r44e O/D issues

Bump!!! Has anyone adjusted their overdrive bands???
Reply With Quote
  #3  
Old 01-21-2015, 06:32 PM
FUzzyBUnny FUzzyBUnny is offline
Ford Rangers
 
Join Date: Nov 2013
Posts: 209
Default Re: 1999 3.0 with the 4r44e O/D issues

Little update if some one comes across the same problem. Turns out the ranger uses to temperature monitoring systems. The temperature sending unit is what controls the gauge on the dash and shows you how warm the motor is. The temperature sensor tells the PCM when the engine is up to temp so it will lean out and allow overdrive to kick in and lock up. My sensor was bad and caused all the headaches. It thought the engine was cold all the time so it ran it rich and stopped it from wanting to go into overdrive.
Reply With Quote
  #4  
Old 02-02-2015, 04:50 PM
FUzzyBUnny FUzzyBUnny is offline
Ford Rangers
 
Join Date: Nov 2013
Posts: 209
Default Re: 1999 3.0 with the 4r44e O/D issues

Update it is still doing it. I took it to a second transmission shop and they were the ones that replaced the sensor.

Last week I drove it 500 miles and every time it would not go into overdrive unless I let off the gas.

Any ideas at all guys??? It is driving me nuts!!!!
Reply With Quote
  #5  
Old 04-10-2015, 10:23 AM
Mississippiwhiteboy Mississippiwhiteboy is offline
Learning to use the forums
 
Join Date: Apr 2015
Posts: 1
Default Re: 1999 3.0 with the 4r44e O/D issues

Any luck?

Last edited by Mississippiwhiteboy; 04-10-2015 at 10:27 AM.
Reply With Quote
  #6  
Old 04-10-2015, 11:20 AM
Tyler46 Tyler46 is offline
Ford Ranger Dismantler
 
Join Date: Nov 2014
Posts: 6,992
Default

55mph might be a little too slow for O/D.
Keep going in 4th past that, up to 75-80 and see if it shifts under acceleration in 4th.
__________________
2007 Regular Cab - 2.3 DOHC - 5 Speed Auto - 4.10 Gears - Maxtrac 7" Lift - Fiberwerx 3" Fenders - Bilstein 5100 Series - 15x10 Ultra 164's - 35x12.50x15 Red Letters - Custom dents

Quote:
Originally Posted by guell View Post
People like him make me believe that birth control needs to be put in the public water supply
Reply With Quote
  #7  
Old 04-10-2015, 02:19 PM
Tyler46 Tyler46 is offline
Ford Ranger Dismantler
 
Join Date: Nov 2014
Posts: 6,992
Default

If not, try some Lucas "slip fix" in a round white bottle with a blue cap. $12 at Autozone. You may have some valves that are sticking.
__________________
2007 Regular Cab - 2.3 DOHC - 5 Speed Auto - 4.10 Gears - Maxtrac 7" Lift - Fiberwerx 3" Fenders - Bilstein 5100 Series - 15x10 Ultra 164's - 35x12.50x15 Red Letters - Custom dents

Quote:
Originally Posted by guell View Post
People like him make me believe that birth control needs to be put in the public water supply
Reply With Quote
  #8  
Old 01-09-2016, 03:19 PM
billcare4228 billcare4228 is offline
Learning to use the forums
 
Join Date: Jan 2016
Posts: 7
Default

Mine is doing exactly the same thing! I put a newly rebuilt valve body in from Central Valve Bodies (btw I love the way it shifts now) but won't go into overdrive unless you turn the od switch off then on again and it'll go into od.

Anything new?
__________________
2000 fr ext. cab style side. 3.0 4r55e trans. 203k!
Reply With Quote
  #9  
Old 01-10-2016, 10:58 AM
NoPower NoPower is offline
Ford Ranger Driver
 
Join Date: Apr 2015
Posts: 1,754
Default Re: 1999 3.0 with the 4r44e O/D issues

NoPower does the same thing. Give it a little gas & it kicks out. I think that stinks.
__________________
Myrtle: & Danna
1999 Ranger 4x4 3.0 Stepside Ext Cab XLT
2000 Mustang 4.6 Roush Supercharged ( Show Car )
1984 Elcamino 350 330 HP ( Nick's Show Car )
1959 Wife ( Arm Candy )
Danna passed away 5/26/2016

Last edited by NoPower; 01-10-2016 at 11:04 AM.
Reply With Quote
  #10  
Old 01-10-2016, 11:42 AM
Kealel Kealel is offline
Bringing hell to the city
 
Join Date: Feb 2015
Posts: 2,578
Default Re: 1999 3.0 with the 4r44e O/D issues

That's normal for these trannys, my 02 and 06 both do/did that
__________________
Baby Girl: 2006 White Ranger XL with many memories. R.I.P. 1/26/15
Quote:
Originally Posted by Logan03CO View Post
I knew you were an alright guy!
Quote:
Originally Posted by ford4thot View Post
The only reason it's worn out junk is because you've gone 70k miles without changing the oil.
Reply With Quote
Reply

Tags
1999, 3.0, 4r44e, overdrive, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 4.0 Starting issues Teders.2 Electrical Tech 0 12-16-2014 08:41 AM
4r44e shifting issues 96blueranger Drivetrain Tech 1 08-24-2014 04:20 AM
4R44e Trans issues JDpuller4010 Drivetrain Tech 12 03-17-2013 05:39 PM
4R44E Trans issues! 99RngrXLT Drivetrain Tech 1 06-06-2012 03:06 PM
1999 Ranger performance issues robthaut Exhaust and Mufflers 10 04-08-2011 07:04 AM