Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-10-2010, 04:40 PM
DHEM DHEM is offline
Resident Red
 
Join Date: Dec 2009
Posts: 1,003
Angry alpine head unit not picking up radio

So ive been messing around with it for a while now trying to get a good signal, when i first put it in it got radio, but a few days later it wouldn't, or the audio would be very faint and full of static. Ive tried messing around with the settings but no luck. The only thing i can think of now is that maybe the antenna wire undid itself. I believe its the CDA something btw. And everything else on it works 100%

so does anybody know whats going on?
__________________
'05 2wd Ranger xl with the 3.0

MODS-Alpine head unit, throttle cable mod, Black Rock wheels, FX4 lvl II axle swap, pooleo's camo painted bezel and mustang dome, painted/aftermarket headlights/tails fold-a-cover and over 100 hp in stickers
Reply With Quote
  #2  
Old 03-10-2010, 05:13 PM
MattFetters MattFetters is offline
Ford Tough
 
Join Date: Dec 2009
Posts: 427
Default Re: alpine head unit not picking up radio

pull out the head unit and let us see some pics from behind
__________________
2003 v6 3.0
mods: blinker mod, hella 500ff's behind grille, blacked out grille, k&n intake, throttle body spacer, pioneer headunit and alpine sub w/ JL amp, 3" body lift, flowmaster super 40 dumped, police scanner, Red LED bars under dash
Reply With Quote
  #3  
Old 03-10-2010, 08:53 PM
Ranger01 Ranger01 is offline
Ford Ranger Driver
 
Join Date: Nov 2009
Posts: 2,402
Default Re: alpine head unit not picking up radio

Maybe the antenna came out of the back of the radio? That happened to mine
__________________
2001 3.0 V6 Automatic "Police Interceptor"
4x4 Off-Road
3" Body Lift
Belltech 6400 Shackles
JBA Headers
LOKRITE Locker
COBRA disc conversion
Reply With Quote
  #4  
Old 03-10-2010, 10:44 PM
BigT8600 BigT8600 is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 234
Default Re: alpine head unit not picking up radio

antenna came out is probly the problem. if not, and it is plugged in, you made need a new antenna. let us know what you find behind the radio.
__________________
~-SOLD-~
04' Edge 6 Cyl 3.0 5 Speed Manual 107K Miles
3" Body Lift - 33" All Terrain Tires
Drop In K&N Filter - Flowmaster - XM Commander Satellite Radio
Reply With Quote
  #5  
Old 03-11-2010, 11:06 AM
DHEM DHEM is offline
Resident Red
 
Join Date: Dec 2009
Posts: 1,003
Default Re: alpine head unit not picking up radio

the dash bezel is held in with just 2 screws right?
__________________
'05 2wd Ranger xl with the 3.0

MODS-Alpine head unit, throttle cable mod, Black Rock wheels, FX4 lvl II axle swap, pooleo's camo painted bezel and mustang dome, painted/aftermarket headlights/tails fold-a-cover and over 100 hp in stickers
Reply With Quote
  #6  
Old 03-11-2010, 11:17 AM
silver silver is offline
Ford Motor Co
 
Join Date: Jan 2010
Posts: 162
Default Re: alpine head unit not picking up radio

Quote:
Originally Posted by silver ranger View Post
the dash bezel is held in with just 2 screws right?
yep
Reply With Quote
  #7  
Old 03-11-2010, 11:24 AM
smakes smakes is offline
Banned
 
Join Date: Sep 2009
Posts: 3,005
Default Re: alpine head unit not picking up radio

Quote:
Originally Posted by Ranger01 View Post
Maybe the antenna came out of the back of the radio? That happened to mine
mine aswell.
Reply With Quote
  #8  
Old 03-11-2010, 12:41 PM
js250 js250 is offline
Ford Tough
 
Join Date: Nov 2009
Posts: 318
Default Re: alpine head unit not picking up radio

you might need an atenna adapter you can get one at walmart for like 5 bucks
__________________
1999 2 wd4 cyl2.5l5 spd135k
MODS:5% tint all around Night Shades (Extra Dark)Corners Thrid BrakeTails Air silence removed 2006 Mirrors Flowmaster Super 44 (Weld on & Turn down)
35W 5000K Hids
Reply With Quote
  #9  
Old 03-11-2010, 03:54 PM
DHEM DHEM is offline
Resident Red
 
Join Date: Dec 2009
Posts: 1,003
Default Re: alpine head unit not picking up radio

yep, the wire unplugged itself, so i plugged it back in, it werks
__________________
'05 2wd Ranger xl with the 3.0

MODS-Alpine head unit, throttle cable mod, Black Rock wheels, FX4 lvl II axle swap, pooleo's camo painted bezel and mustang dome, painted/aftermarket headlights/tails fold-a-cover and over 100 hp in stickers
Reply With Quote
  #10  
Old 03-12-2010, 11:02 AM
Ranger01 Ranger01 is offline
Ford Ranger Driver
 
Join Date: Nov 2009
Posts: 2,402
Default Re: alpine head unit not picking up radio

Glad you got it fixed
__________________
2001 3.0 V6 Automatic "Police Interceptor"
4x4 Off-Road
3" Body Lift
Belltech 6400 Shackles
JBA Headers
LOKRITE Locker
COBRA disc conversion
Reply With Quote
  #11  
Old 04-05-2010, 11:32 PM
Ruger Splash Ruger Splash is offline
Ford Ranger Owner
 
Join Date: Apr 2010
Posts: 66
Default Re: alpine head unit not picking up radio

Quote:
Originally Posted by js250 View Post
you might need an atenna adapter you can get one at walmart for like 5 bucks
??? no ranger i have ever worked on has needed an antenna adapter.. I have a 2010 ranger in tomorrow.. Ill check to see what the antenna end is, but to my knowledge it has always been a standard motorolla end.
Reply With Quote
Reply

Tags
head unit ranger

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock Head Unit Question Slobra232 Audio / Video 10 09-20-2010 03:25 AM
Head Unit upgrade jahylton Audio / Video 4 02-01-2010 10:51 PM
Head unit, no power SmokeyMcPot420 Audio / Video 1 11-18-2009 11:19 AM
Got me new head unit. Superlifted06FX4 Audio / Video 3 10-31-2009 12:04 PM
New head unit...Questions. SmokeyMcPot420 Audio / Video 7 10-15-2009 12:31 PM