Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-20-2010, 07:06 PM
VADERRANGER VADERRANGER is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 6
Default new battery messed up stereo

So i got a new battery for my ranger and when i got it hooked up and started the stereo: cd player, mp3, am/fm- all sound is very weird sounding. its kind of hard to explain. I can hear the music but only the background not the main vocals. has anyone ever heard of this?!? it happens with playing cds and mp3s as well. thanks for any suggestions.
__________________
97 Ford ranger XLT, single cab, 2.3L
Reply With Quote
  #2  
Old 02-21-2010, 07:50 AM
BigT8600 BigT8600 is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 234
Default

Is this the factory unit? I've seen/heard similar even on after market units. If somehow there was a surge in power to the unit (if its the factory, it wouldn't take much) you can fry any number or small circuit boards or transistors on the units board. More than likely your speakers are fine. I would just put in an aftermarket head unit and enjoy it.
__________________
~-SOLD-~
04' Edge 6 Cyl 3.0 5 Speed Manual 107K Miles
3" Body Lift - 33" All Terrain Tires
Drop In K&N Filter - Flowmaster - XM Commander Satellite Radio
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo on but no sound? WTF whitedge Audio / Video 19 10-20-2010 05:10 PM
Caught my dad with my gf... wtf do i do? So messed up... caught red-handed. Superlifted06FX4 Laugh Factory 54 09-27-2010 09:13 AM
For Sale: old stereo stuff, SC blueranger789 Interior Parts 8 02-02-2010 03:55 PM
Oops, she messed up with this dude! Steviejay Vehicle Snapshots 2 01-21-2010 09:38 AM
Stereo pmac Audio / Video 5 10-16-2009 11:10 AM