Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Semi-Technical > Audio / Video
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 06-05-2012, 05:20 PM
Learning to use the forums
 
Join Date: May 2012
Posts: 4
Default Radio Doesn't Work:

Factory Mach MP3 Player
2003 3.0
Fuse 29 was popped : Replaced
Nada Fix Mayne.
Suggestions.
Reply With Quote
  #2  
Old 06-06-2012, 09:03 PM
GLH GLH is offline
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 4,903
Default Re: Radio Doesn't Work:

Hard to say what might have blown the fuse. Could be a chaffed wire in the harness touched metal somewhere. Anyone's guess.

Get 1 of these -

http://www.crutchfield.com/App/Produ...0AVIC140&g=300
__________________
'02 Edge SuperCab 5 sp auto 2wd 3.73 L/S fleetside 3.Oh dang it's sooo slow
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Key Doesn't Work in Door... Wingman108 General Tech 4 10-19-2011 05:33 PM
ABS doesn't work JimmyKS General Tech 0 10-17-2011 09:29 AM
4WD doesn't work. Help! CodeRed30 Drivetrain Tech 10 10-06-2011 03:02 PM
Heater and A/C Control doesn't work 01srseagraves Electrical Tech 12 10-20-2010 06:40 AM
Stuff doesn't work - All Fuses OK z145fergie Electrical Tech 3 07-24-2010 11:05 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.