Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Semi-Technical > Audio / Video
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 02-10-2012, 09:22 PM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default AMP Trouble HELP!!!

I got all of my audio stuff installed in my ranger today, but I just cant figure out why my amp is not working. I have all of my wires run, good ground (grounded to the seat bolt) and all new wires, hooked up the right way, but my amp still does not want to work. It is going into "Protection Mode", and my blue light that turns on with the remote wire lights up when I turn the Key on, but then fades away to nothing. Everything is Kenwood, so it is quality stuff. Any Ideas??? Sony Head Unit.
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
  #2  
Old 02-10-2012, 09:28 PM
Almost ******
 
Join Date: Mar 2011
Posts: 7,482
Default Re: AMP Trouble HELP!!!

your remote wire is hooked up right? have you tried a different ground?
__________________
Why does everyone think prerunners just jump stuff?


Please click HERE to watch this video!
Reply With Quote
  #3  
Old 02-10-2012, 09:34 PM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default Re: AMP Trouble HELP!!!

remote wire hooked up, and yes i tried moving my ground around.
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
  #4  
Old 02-10-2012, 09:39 PM
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,767
Default Re: AMP Trouble HELP!!!

first, the seat bolt is a terrible ground, you should go right to the frame. But, the amp should still work.

So, I would start with this. Turn DOWN all the settings on the amp. Un hook your subs. Try the amp. If it does not protect out, look at your subs and determine the 1) the ohms and 2) the watts. Once this is determined, Lets see what you amp is putting out....and at what ohms.

If it is protecting out with out the subs hooked up, you have problems else where

My feeling is that you either have the subs wired wrong, or are wired where they are drawing to much power from the amp, causing it to protect out right away.
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #5  
Old 02-10-2012, 09:54 PM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default Re: AMP Trouble HELP!!!

it is a 1000 watt amp powering a 600 watt 10" sub, so it is not doing much. Would the amp protect out if the RCA cables are not hooked up to the head unit? (I did leave my buddy in charge of hooking that up, but he is very knowledgeable in hooking that stuff up, but we all make mistakes)
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
  #6  
Old 02-10-2012, 10:09 PM
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,767
Default Re: AMP Trouble HELP!!!

what are the specs on the sub/amp?

RCA should not protect the amp
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #7  
Old 02-11-2012, 11:38 AM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default Re: AMP Trouble HELP!!!

Unhooked everything in my truck, put it in my buddys truck and it worked perfect. Put it back into my truck, same problem. I have 12.24 volts from my power cables, and a good ground, I have 10.8 volts off my remote wire. What would cause it to go into protect mode? Could my deck possibly be bad? Or a bad remote wire even though i have 10.8 V back there???
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
  #8  
Old 02-11-2012, 11:44 AM
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,767
Default Re: AMP Trouble HELP!!!

Remove the remote wire and run a quick jumper from the postive to the remote on the amp. If it powers on, I would say problem is in the remote wire. If it protects out, Must be your power or ground.
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #9  
Old 02-11-2012, 12:14 PM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default Re: AMP Trouble HELP!!!

I actually did that, and still nothing, so you think it is bad coming off of the radio? I cant see how the wiring would be bad running to my amp, because i have a full 12.24 volts back there. But anything is possible...
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
  #10  
Old 02-11-2012, 12:19 PM
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,767
Default Re: AMP Trouble HELP!!!

so you removed the remote, jumped from power and it still protected out? I would unlpug everything (RCA's, Speaker, Remote)

If with only the power and ground and a jumper, the amp is still protecting out, you have a problem with your ground or power.
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #11  
Old 02-11-2012, 05:11 PM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default Re: AMP Trouble HELP!!!

yup, I jumped it, and it still protected out, but worked perfectly fine in my buddys truck. Where would you reccommend grounding it out at? I went to the seat bolt because thats where most told me to ground it, and it made a good connection on the volt meter reading a good 12.24 volts back there. But I am no expert either.
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
  #12  
Old 02-11-2012, 05:12 PM
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,767
Default Re: AMP Trouble HELP!!!

I would go right to the frame with the ground.
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #13  
Old 02-11-2012, 05:31 PM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default Re: AMP Trouble HELP!!!

Doesent the seat bolt or the seatbelt bolt go right to the frame? And i jumped my remote wire straight from the battery.
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
  #14  
Old 02-11-2012, 05:33 PM
Ban Survivor. (x2)
 
Join Date: Jun 2010
Posts: 6,767
Default Re: AMP Trouble HELP!!!

Quote:
Originally Posted by COL View Post
Doesent the seat bolt or the seatbelt bolt go right to the frame? And i jumped my remote wire straight from the battery.
no it does not, its just part of the cab. And you should be jumping the remote at the amp, not the wire. Run a wire from the positve on the amp to the remote on the amp. (the terminals)
__________________
1999 | Ext. Cab | 4.0 | 4x4 | 4.10's
Quote:
A Gladiator does not fear death. He embraces it. Caresses it. Fucks it. Each time he enters the arena, he slips his c0ck in the mouth of the beast, and prays to thrust home before the jaws snap shut. - Oenomaus
Ball Joints/Upper A-Arms How To
Replace Door pin/bushing
Repair broken dome light tabs
VIDEO OHC Install
Reply With Quote
  #15  
Old 02-11-2012, 05:37 PM
COL COL is offline
Ford Tough
 
Join Date: Jan 2012
Posts: 307
Default Re: AMP Trouble HELP!!!

Ok, i unhooked the remote wire and ran a wire all the way from the battery to the remote terminal, but wouldent that be basically the same thing as jumping it from the positive terminal to the remote terminal on the amp?
__________________
2000 FORD RANGER XLT 4x4 Extended Cab 3.0L FFV
Flareside Bed
ACCESS Tonneau Cover-LEER Fiberglass Topper-Manik Brush Guard-Pro Series Hitch
Kenwood Amp and Sub-Sony Deck
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ranger trouble, money trouble, is the solution an older Ranger? jcfleck General Ford Ranger Discussion 9 11-23-2011 10:59 AM
Trouble with brakes dragging? Trouble engaging clutch! 96DangerRanger Drivetrain Tech 2 08-16-2011 02:05 PM
4x4 trouble etlawson21 Drivetrain Tech 1 03-15-2011 05:29 PM
4x4 trouble etlawson21 Drivetrain Tech 3 03-11-2011 05:32 PM
MAF trouble 4x4man 4.0 SOHC / 4.0 OHV Tech 17 11-16-2010 06:48 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.