Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 08-01-2011, 05:07 PM
mstipp mstipp is offline
2007 sport
Join Date: Aug 2011
Posts: 1
Default Sound problem

2007 ranger sport with the pioneer 6 disc changer. What it is doing is when i turn it on. there is a pop and no volume. when i crank it to full volume, you can hear a what you are trying to play whether it is cd or fm or satellite but the volume is very load and scratchy. I am wondering if this might be the unit itself or something else. One thing i have been looking for is all the components for this system. i the unit, i have found the satellite module and reading through the forum tonight, i have figured out where the sub and sub amp are. Is there an external amp for the speakers or is it internal. Any help would be much appreciated.
Reply With Quote
Old 08-01-2011, 05:51 PM
reconjb reconjb is offline
Found a Diesel
Join Date: Aug 2010
Posts: 10,681
Default Re: Sound problem

check the wiring I would almost say you have a short in one of the speaker wires or a bad ground or power source to the radio not exactly sure but something to check
Truck: 2000 Ford Ranger XLT 4.0 4x4 ext cab
My Build Thread
Mod Ideas
Don't Forget to:
Create a Signature
Show your system

Mods: Brush guard|Front Hitch|Expo Roof Rack|Train Horn|Door/Dash/step/Hood Leds|2" lift|Rear Tow Points|On-Board Air System| 22" & 40" LED bar|and More!
Reply With Quote
Old 08-03-2011, 02:15 PM
Aftermath Aftermath is offline
Bring Back The Ranger!
Join Date: Jun 2011
Posts: 175
Default Re: Sound problem

Typically when you here a "pop" when you power on the radio it is a grounded out speaker (however you usually cant hear anything). Listen to each speaker (when turning it on) and see which one the pop is coming from. If it comes from all of them and you are not using a 4 ch. amplifier then I would start the diagnosis with the deck.
'04 Sonic Blue Ranger, 2 tone Katzkin leather seats, Custom Ford script spray in liner, Spyder LED tails, 8000k Morimoto HID's, LED 3rd brake light + signal mirrors, 06 badges, grille, corners, K&N intake, Magnaflow exhaust, AR Shelby series 17x8 chrome wheels, Pioneer P4300DVD, Hybrid Audio Technologies Imagine 6.5 components up front and Pioneer TS-D681R's in rear, Alpine PDX-V9 5 channel Amp, Image Dynamics IDQ 12" sub. Optima Red Top, "Painted to match" interior pieces
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Popping Sound, and then the sound of a shredded belt.. ..tick tick tick tick... four2x4 4-Cylinder Tech 3 03-09-2011 05:37 PM
Rough starting problem as well as high/low idle problem Ins4nity 4-Cylinder Tech 7 02-16-2011 05:10 AM
Does this sound right Giangrosso Interior Tech 3 12-28-2010 10:25 PM
What part is this? (pic) Blower problem, this the problem? stuck on vent! Chargerondavins General Tech 2 10-02-2010 09:46 AM
Holy shit sound picking out my sound system is overwhelming! Fordranger2001 Audio / Video 20 09-22-2010 01:19 PM