Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-30-2011, 01:43 PM
griffinpunk griffinpunk is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 24
Default i think i shorted out my head unit during install?

so i've used some of the threads here very successfully in the past (thank you!), but i suck when it comes to anything electrical. i was reinstalling my jvc head unit and i must not have wrapped the wires thoroughly, 'cause i got a small spark and blew the radio fuse. i replaced the fuse and everything else still works (lights, windows, signals, etc.) but no radio.

i put the factory unit in to check and it lights up when i turn on the lights, but that's it. no radio.

any (constructive) advice?

thanks in advance!
__________________
2003 4x4 4.0 FX4. BLACK.
Reply With Quote
  #2  
Old 06-30-2011, 01:46 PM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: i think i shorted out my head unit during install?

Check the fuses on the left side of the dash.
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #3  
Old 06-30-2011, 01:48 PM
doyouquaxu doyouquaxu is offline
Almost ******
 
Join Date: Mar 2011
Posts: 7,480
Default Re: i think i shorted out my head unit during install?

no radio like, no sound? did you re-connect the antenna?
__________________
Why does everyone think prerunners just jump stuff?


Please click HERE to watch this video!
Reply With Quote
  #4  
Old 06-30-2011, 01:51 PM
2004xlmiller 2004xlmiller is offline
Ford Ranger Driver
 
Join Date: Jun 2010
Posts: 12,689
Default Re: i think i shorted out my head unit during install?

its probably just another fuse.
Reply With Quote
  #5  
Old 06-30-2011, 01:55 PM
Rangernator Rangernator is offline
<--- Go Colts
 
Join Date: May 2011
Posts: 334
Default Re: i think i shorted out my head unit during install?

ALWAYS unhook your car battery WHENEVER you work on ELECTRICAL things on your cars man. I learned that the hard way.

What you will have to do is test all your fuses on the left side of your dash one by one and find the one you blew out and replace it. and yeah make sure your antenna is plugged in.
__________________
2003 4.0L V6 Ford Ranger Regular cab

Modifications----> 20% side windows, 5%% Tinted rear window and front windsheild strip, , Diamond plated bed extender, Explorer sport Dome Light, Sony headunit, White Face Explorer Gauge Cluster.
Reply With Quote
  #6  
Old 06-30-2011, 01:58 PM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: i think i shorted out my head unit during install?

^ You don't have to "test" it. Just get a flash light and look at all of them. Takes like 5 minutes.
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #7  
Old 06-30-2011, 02:08 PM
Rangernator Rangernator is offline
<--- Go Colts
 
Join Date: May 2011
Posts: 334
Default Re: i think i shorted out my head unit during install?

thats what I meant but lemme rephrase you will have to "CHECK" each one and find the one that is no longer functioning and replace it
__________________
2003 4.0L V6 Ford Ranger Regular cab

Modifications----> 20% side windows, 5%% Tinted rear window and front windsheild strip, , Diamond plated bed extender, Explorer sport Dome Light, Sony headunit, White Face Explorer Gauge Cluster.
Reply With Quote
  #8  
Old 06-30-2011, 02:20 PM
Jimmeh Jimmeh is offline
I am THE Hank Hill.
 
Join Date: Sep 2009
Posts: 1,085
Send a message via AIM to Jimmeh
Default Re: i think i shorted out my head unit during install?

Quote:
Originally Posted by Rangernator View Post
thats what I meant but lemme rephrase you will have to "CHECK" each one and find the one that is no longer functioning and replace it
THE ONES! Don't stop after you found one blown fuse, just to be sure that there aren't any other ones that may need replaced.
__________________
92 Ford Ranger Supercab XLT 4X4.
Not a ton done to it, but it's nowhere near finished
05 Chevy Silverado 1500 W/T 4X4
Way too much done to list and it's also not even close to done

"The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."
Reply With Quote
  #9  
Old 06-30-2011, 02:44 PM
kmk7110 kmk7110 is offline
Ford Tough
 
Join Date: Feb 2011
Posts: 322
Default Re: i think i shorted out my head unit during install?

Also sometimes aftermarket radios have fuses in the back of them as well. Possibly check that also.
__________________
2003 Ford Ranger FX4 in Red
Line-X Bedliner, Access Laredo Tonneau Cover
OHC, Mustang Dome Mod, Cargo Light Mod
DDM 4500K High/Low Heads & Fogs
Pioneer AVH-P2300DVD HU (Backup Camera/DVD Bypass
Rockford Fosgate 500-2 Amp, 1 10in Pioneer Sub
Working On the BL and 33 12.5 15 on Eagle Allow 10.5 wide rims
Reply With Quote
  #10  
Old 06-30-2011, 03:13 PM
griffinpunk griffinpunk is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 24
Default Re: i think i shorted out my head unit during install?

thanks for the tips so far, but i checked all the fuses in the fuse panel and even looked in the module under the hood and replaced the blown one (#20). still nothing from the radio...no sound, no motor function on the cd player, nada.

is it possible i did something to the radio unit, like fried it? there wasn't any smoke or burned smell or anything. or is there something in the wiring somewhere in the truck that i might've broken? i.e. what's the next thing it could be after the fuses?
__________________
2003 4x4 4.0 FX4. BLACK.
Reply With Quote
  #11  
Old 06-30-2011, 09:07 PM
kmk7110 kmk7110 is offline
Ford Tough
 
Join Date: Feb 2011
Posts: 322
Default Re: i think i shorted out my head unit during install?

did you verify that the wires are all still connected properly to the radio? Like everything is wired as it should?
__________________
2003 Ford Ranger FX4 in Red
Line-X Bedliner, Access Laredo Tonneau Cover
OHC, Mustang Dome Mod, Cargo Light Mod
DDM 4500K High/Low Heads & Fogs
Pioneer AVH-P2300DVD HU (Backup Camera/DVD Bypass
Rockford Fosgate 500-2 Amp, 1 10in Pioneer Sub
Working On the BL and 33 12.5 15 on Eagle Allow 10.5 wide rims
Reply With Quote
  #12  
Old 07-01-2011, 05:39 AM
MazdaDS MazdaDS is offline
Workin on the Truck
 
Join Date: Jun 2011
Posts: 290
Default Re: i think i shorted out my head unit during install?

Hey i had the same thing happen to me a few days ago...i had a blown fuse in my fuse panel..
__________________
'03 Mazda B3000 Dual Sport 3.0L V6
Installed:
Blue L.E.D.'s | 12" Punch Stage 1 Sub | JVC headunit | 760w Pioneer Amp | Procaps Bed rail caps | AVS Bugshield | Cherry Bomb Glasspack | Throttle Cable Mod | Air Box Mod | Extang Tonneau Cover

Future: 3" lift | bigger tires | Dual exhaust
Reply With Quote
  #13  
Old 07-05-2011, 01:29 PM
Aftermath Aftermath is offline
Bring Back The Ranger!
 
Join Date: Jun 2011
Posts: 175
Default Re: i think i shorted out my head unit during install?

Use a meter or a test light and check the switched wire (aftermarket color: red) and the constant wire (aftermarket color: yellow) and see if they still have 12 volts. The switched wire should only have 12 volts when the key is on and the constant wire should constantly have 12 volts. If so, and its grounded properly, then its not a wiring or fuse problem as to why it wont turn on. Its the radio itself. Hope that helps man. Not having a radio sucks!
__________________
'04 Sonic Blue Ranger, 2 tone Katzkin leather seats, Custom Ford script spray in liner, Spyder LED tails, 8000k Morimoto HID's, LED 3rd brake light + signal mirrors, 06 badges, grille, corners, K&N intake, Magnaflow exhaust, AR Shelby series 17x8 chrome wheels, Pioneer P4300DVD, Hybrid Audio Technologies Imagine 6.5 components up front and Pioneer TS-D681R's in rear, Alpine PDX-V9 5 channel Amp, Image Dynamics IDQ 12" sub. Optima Red Top, "Painted to match" interior pieces
Reply With Quote
  #14  
Old 07-08-2011, 12:30 AM
huskerman16 huskerman16 is offline
DFWM
 
Join Date: Apr 2011
Posts: 522
Default Re: i think i shorted out my head unit during install?

Quote:
Originally Posted by Aftermath View Post
Use a meter or a test light and check the switched wire (aftermarket color: red) and the constant wire (aftermarket color: yellow) and see if they still have 12 volts. The switched wire should only have 12 volts when the key is on and the constant wire should constantly have 12 volts. If so, and its grounded properly, then its not a wiring or fuse problem as to why it wont turn on. Its the radio itself. Hope that helps man. Not having a radio sucks!
If this doesn't show you what's wrong take it to an audio shop who does repairs they're are some internal fuses and resistors you might've fried they can tell you if your fuses and wires are good

----------

there**
__________________
2000 Ford Ranger Sport 4.0 4x4
Custom Black Body Lines
Nice Little Sound System
Light Bar Bull Bar 4 Hella 500's
Lots Of Mods Coming Stay Tuned
Reply With Quote
  #15  
Old 07-10-2011, 07:58 AM
Rangernator Rangernator is offline
<--- Go Colts
 
Join Date: May 2011
Posts: 334
Default Re: i think i shorted out my head unit during install?

Did you use butt connecters?
__________________
2003 4.0L V6 Ford Ranger Regular cab

Modifications----> 20% side windows, 5%% Tinted rear window and front windsheild strip, , Diamond plated bed extender, Explorer sport Dome Light, Sony headunit, White Face Explorer Gauge Cluster.
Reply With Quote
Reply

Tags
electrical, fuse, radio, short, wiring

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Head unit install trouble.... DiabloBlanco Audio / Video 15 05-06-2011 09:41 AM
Head unit install. Mrbreeze Audio / Video 8 05-06-2011 09:18 AM
Is it a hard to install a new head unit in a newer (05) ranger with factory sub? fairlaneguy Audio / Video 3 04-16-2011 08:12 AM
Head unit install duvaltom Interior Tech 1 02-05-2011 02:59 PM
head unit.... cdawall Audio / Video 4 01-16-2011 03:05 PM