Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-23-2011, 04:29 PM
RedLineRanger RedLineRanger is offline
Im Winning.. are you?
 
Join Date: Feb 2011
Posts: 613
Default My set up... Ground?

I have a 4 door and i took out the seat behind me and places a sub and amp... but its not working im thinking its a ground wire problem? Cause thats the only real reason... where is a good place to ground my amp? I treis the bolt for the seat belt unscrewed it then but my ground on it and screwed back in.. Not working i geuss...?
__________________
2003 Blue Fx-4 ranger.
Mustang dome light, blue/silver painted interior, Kenwood head deck and kenwood 6x8 speakers= Custom built 8 inch sub box with a 8 inch mtx rs, kenwood 160 rms amp. , Line-x bed liner,custom vinyl center console lid. Silver grill and fender flares. Personal Air box mod with drop in k&n filter, Dynomax Ultra Flo cat-back exhaust system. Working on exterior valance next than hood scoop silver and 4.0 stickers. This spring a full interior redo with seats. More to come.
Reply With Quote
  #2  
Old 06-23-2011, 04:30 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: My set up... Ground?

route it to the metal under the seats and use a self tapping screw.
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #3  
Old 06-23-2011, 04:43 PM
geezmo2001 geezmo2001 is offline
My rangexplodeneer.
 
Join Date: Aug 2009
Posts: 247
Default Re: My set up... Ground?

Also make sure ALL paint is removed, i.e bare metal.
__________________
2001 Extended cab Edge, 4x4, 4.0, 4.10 gears, 3" PA body lift, Heartthrob dual exhaust, Roush Thunderbolt signal mirrors, 8000k hid head/foglights, Mountaineer leather buckets, Xplorer shorty console, Alpine 9856 receiver, 10" type r sub in ported box, air box mod, throttle cable mod, Rancho R5000 shox, Scangauge II, plus many other things...
Reply With Quote
  #4  
Old 06-23-2011, 04:56 PM
2003 XLT FX4 2003 XLT FX4 is offline
No Money = No Mods :(
 
Join Date: Jan 2011
Posts: 98
Default Re: My set up... Ground?

I used the rear jump seat behind the divers seat bolt as a ground, i just cleaned the coating off the bolt, and cleaned about a 1/2" around the bolt hole, and it works great.
__________________
2003 Ranger FX4, Alpine 10" type R, alpine deck,amp, and speakers, Fog light mod, Hella's behind the grill with dual fog switches in bezel.
Reply With Quote
  #5  
Old 06-23-2011, 05:10 PM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: My set up... Ground?

There's a bolt for the jump seat that is closest to the jack/jack cover. That's the one I used and I didn't sand any paint off or anything. Are you sure you have everything hooked up correctly? Does the amp turn on? What amp is it?
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #6  
Old 06-23-2011, 07:20 PM
OvaZ OvaZ is offline
Breathe.
 
Join Date: Apr 2011
Posts: 95
Default Re: My set up... Ground?

Remote Wire hooked up?
Reply With Quote
  #7  
Old 06-24-2011, 02:09 AM
RedLineRanger RedLineRanger is offline
Im Winning.. are you?
 
Join Date: Feb 2011
Posts: 613
Default Re: My set up... Ground?

yeah the amp goes on and everything.. but no sound from my sub..which im geussing means my ground
__________________
2003 Blue Fx-4 ranger.
Mustang dome light, blue/silver painted interior, Kenwood head deck and kenwood 6x8 speakers= Custom built 8 inch sub box with a 8 inch mtx rs, kenwood 160 rms amp. , Line-x bed liner,custom vinyl center console lid. Silver grill and fender flares. Personal Air box mod with drop in k&n filter, Dynomax Ultra Flo cat-back exhaust system. Working on exterior valance next than hood scoop silver and 4.0 stickers. This spring a full interior redo with seats. More to come.
Reply With Quote
  #8  
Old 06-24-2011, 07:13 AM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: My set up... Ground?

Quote:
Originally Posted by Hitman1490 View Post
yeah the amp goes on and everything.. but no sound from my sub..which im geussing means my ground
Wrong. If the amp powers up fine then it's something either wrong with the way you have the sub hooked up or there's something wrong with your RCA's. Or you might not have the "Subwoofer" setting turned on on your headunit.
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #9  
Old 06-24-2011, 08:59 AM
trcothorn trcothorn is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 238
Default Re: My set up... Ground?

is it a used sub? if you bought it from somebody maybe it was blown and they ripped you off
__________________
2004 ford ranger 2.3 2wd. flowmaster 40. sony xplode head unit. 30x9.50x15 turbostar ATs. stock jeep wrangler wheels, painted black. ebay taillights. few more cosmetic upgrades
Reply With Quote
  #10  
Old 06-24-2011, 10:48 AM
RedLineRanger RedLineRanger is offline
Im Winning.. are you?
 
Join Date: Feb 2011
Posts: 613
Default Re: My set up... Ground?

Quote:
Originally Posted by trcothorn View Post
is it a used sub? if you bought it from somebody maybe it was blown and they ripped you off
Yeah thats problly it.
__________________
2003 Blue Fx-4 ranger.
Mustang dome light, blue/silver painted interior, Kenwood head deck and kenwood 6x8 speakers= Custom built 8 inch sub box with a 8 inch mtx rs, kenwood 160 rms amp. , Line-x bed liner,custom vinyl center console lid. Silver grill and fender flares. Personal Air box mod with drop in k&n filter, Dynomax Ultra Flo cat-back exhaust system. Working on exterior valance next than hood scoop silver and 4.0 stickers. This spring a full interior redo with seats. More to come.
Reply With Quote
  #11  
Old 06-24-2011, 11:06 AM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: My set up... Ground?

Post pics of all your wiring. I'm willing to bet that's NOT what it is.
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #12  
Old 06-24-2011, 05:13 PM
RedLineRanger RedLineRanger is offline
Im Winning.. are you?
 
Join Date: Feb 2011
Posts: 613
Default Re: My set up... Ground?

Ok i will...
__________________
2003 Blue Fx-4 ranger.
Mustang dome light, blue/silver painted interior, Kenwood head deck and kenwood 6x8 speakers= Custom built 8 inch sub box with a 8 inch mtx rs, kenwood 160 rms amp. , Line-x bed liner,custom vinyl center console lid. Silver grill and fender flares. Personal Air box mod with drop in k&n filter, Dynomax Ultra Flo cat-back exhaust system. Working on exterior valance next than hood scoop silver and 4.0 stickers. This spring a full interior redo with seats. More to come.
Reply With Quote
  #13  
Old 06-25-2011, 06:22 AM
RedLineRanger RedLineRanger is offline
Im Winning.. are you?
 
Join Date: Feb 2011
Posts: 613
Default Re: My set up... Ground?

OKay here we go..

My ground

Amp hook up

back of sub

rca to amp
__________________
2003 Blue Fx-4 ranger.
Mustang dome light, blue/silver painted interior, Kenwood head deck and kenwood 6x8 speakers= Custom built 8 inch sub box with a 8 inch mtx rs, kenwood 160 rms amp. , Line-x bed liner,custom vinyl center console lid. Silver grill and fender flares. Personal Air box mod with drop in k&n filter, Dynomax Ultra Flo cat-back exhaust system. Working on exterior valance next than hood scoop silver and 4.0 stickers. This spring a full interior redo with seats. More to come.
Reply With Quote
  #14  
Old 06-25-2011, 06:40 AM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: My set up... Ground?

That ground doesn't look too good. Does your amp have a "high level" input? I see you have your RCA's in the low input RCA's.
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #15  
Old 06-25-2011, 08:22 AM
2003 XLT FX4 2003 XLT FX4 is offline
No Money = No Mods :(
 
Join Date: Jan 2011
Posts: 98
Default Re: My set up... Ground?

I would try a different ground. I'm not sure if I have a pic you can see of where mine is, since we both have 03 FX4's it should be the same. If you look at my pictures, theres one of my amp rack/amp, the bolt that I used for the ground is the one closest the center window, and the back wall of the cab (back left corner of amp rack).
__________________
2003 Ranger FX4, Alpine 10" type R, alpine deck,amp, and speakers, Fog light mod, Hella's behind the grill with dual fog switches in bezel.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
help with wiring --- signal ground vs chassis ground.... 2010 Audio / Video 6 06-16-2011 03:59 PM
What color is the ground wire in my 93? Monster Mule Deer Audio / Video 2 05-03-2011 07:09 PM
frame and ground love 01DangerRanger Vehicle Snapshots 19 01-08-2011 09:38 AM
Good Deck Ground Heliguy Audio / Video 4 12-24-2010 11:00 PM
ignition syst. ground on distributorless 3.0? deranger Electrical Tech 1 04-11-2010 09:41 PM