Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 06-25-2011, 04:35 PM
RedLineRanger RedLineRanger is offline
Im Winning.. are you?
Join Date: Feb 2011
Posts: 613
Default Re: My set up... Ground?

Yes it has a high but idk what goes in there
2003 Blue Fx-4 ranger.
Mustang dome light, blue/silver painted interior, Kenwood head deck and kenwood 6x8 speakers= Custom built 8 inch sub box with a 8 inch mtx rs, kenwood 160 rms amp. , Line-x bed liner,custom vinyl center console lid. Silver grill and fender flares. Personal Air box mod with drop in k&n filter, Dynomax Ultra Flo cat-back exhaust system. Working on exterior valance next than hood scoop silver and 4.0 stickers. This spring a full interior redo with seats. More to come.
Reply With Quote
Old 06-25-2011, 06:28 PM
ranger101 ranger101 is offline
Ford Ranger Driver
Join Date: Dec 2009
Posts: 2,571
Default Re: My set up... Ground?

Plug the RCA's into the "high output level" side.
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
Old 06-25-2011, 10:19 PM
mitch5669 mitch5669 is offline
Like the Forums
Join Date: Apr 2010
Posts: 36
Default Re: My set up... Ground?

the "high level" input is for connecting the amp if you dont have an after-market head unit and dont have a line out-put converter, so your able to connect the amp to a stock head unit with out using the converter.

if the amp turns on first check the head unit setting make sure the "sub" setting is on, then check the rca cables by your head unit and by the amp, then check the speaker wires going from the amp to the sub box, then check the wires inside the box going from the box to the speaker.

and looking at the pic you have your x-over set on high pass, set it to low-pass, set the gain to half way for now and set the crossover to bout 80hz for now. if every thing is working now set every thing by following this guide

Last edited by mitch5669; 06-25-2011 at 10:40 PM.
Reply With Quote
Old 06-25-2011, 10:37 PM
dirttrackracer dirttrackracer is offline
no regrets
Join Date: Sep 2010
Posts: 530
Default Re: My set up... Ground?

you dont have color coded wires and guessing this is your first system install, you might have reversed the wires. check that the postive output is going to the postive in the box! sounds stupid but i have seen it happen before
sold-91' extra cab 4.0 auto went from 3in lowered to 11in of lift.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
help with wiring --- signal ground vs chassis ground.... 2010 Audio / Video 6 06-16-2011 03:59 PM
What color is the ground wire in my 93? Monster Mule Deer Audio / Video 2 05-03-2011 07:09 PM
frame and ground love 01DangerRanger Vehicle Snapshots 19 01-08-2011 08:38 AM
Good Deck Ground Heliguy Audio / Video 4 12-24-2010 10:00 PM
ignition syst. ground on distributorless 3.0? deranger Electrical Tech 1 04-11-2010 09:41 PM