Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 05-12-2011, 11:46 AM
gfj17 gfj17 is offline
Ford Ranger Owner
 
Join Date: Mar 2010
Posts: 73
Default Re: two amps with one spark... wtf happened?

Quote:
Originally Posted by FireRanger View Post
I already did.

DUDE. u say that the spark had no effect but the spark is the only thing that shut my amps down. Really dude? Really

Anyway the things are working but my sub started Bottoming out so I sold it back and I'm lookin for another one
Reply With Quote
  #17  
Old 05-12-2011, 12:39 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: two amps with one spark... wtf happened?

Quote:
Originally Posted by gfj17 View Post
DUDE. u say that the spark had no effect but the spark is the only thing that shut my amps down. Really dude? Really

Anyway the things are working but my sub started Bottoming out so I sold it back and I'm lookin for another one
Dude. Yes. Really. No, really for real. No matter what you think, the over-current from the short circuit never entered your amps and therefore did not damage anything inside your amps. It is physically impossible. So the reality is, either your amps have internal defects or your wiring and connections have defects.

You asked for help on this. I'm telling you how electricity works as it relates to what you described. I'm sorry you do not like the answer I'm giving you, but that is how electricity works.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #18  
Old 05-12-2011, 11:35 PM
2010 2010 is offline
Ford Ranger Driver
 
Join Date: Sep 2010
Posts: 1,196
Default Re: two amps with one spark... wtf happened?

in simple terms the battery is what shorted out. current flow never went ''through the amp" its impossible. the guy that started this thread does not know much electronics. the only thing I can think of that might of possibly remotely messed up the amp is the heat that might have been created by YOU shorting out the power cable with the ground cable. did the fuse blow at the cable by the battery??
__________________
2010 Ranger XL Reg. Cab 4 cyl... 5 speed manual... W/reverse.

Mods: 5% tint on rear window, JVC KDHDR40 Headunit, Kicker KS-68 speakers, Kicker TCVT102 (10TCVT102) Sub, JVC DRVN KSAX3102 Amp, JVC DRVN KSAX3101D mono amp, Ford black rubber mat, White LED license plate lights. Added 6000k HID Fogs, 6000k Digital HID Heads.

This isn't gramhar skool so dont cry and whine about spelling.
Reply With Quote
  #19  
Old 05-13-2011, 02:46 PM
gfj17 gfj17 is offline
Ford Ranger Owner
 
Join Date: Mar 2010
Posts: 73
Default Re: two amps with one spark... wtf happened?

Lol, honestly i dont know everything there is to know, but it doesnt make sense to me that the spark shut down both my amps for a day, nothing blew, and everything is working fine now. It doesnt make sense to me that with out going through my amps, they both got shut down. And yea thanks for trying to help, really .
Reply With Quote
  #20  
Old 05-13-2011, 03:46 PM
hwhmobile hwhmobile is offline
94 Ranger XLT 2.3 engine
 
Join Date: Apr 2011
Posts: 129
Default Re: two amps with one spark... wtf happened?

Two things: 1) Are your two amps connected to each other at any point other than the battery?
2) Follow all your wires and see if one of them is touching your metal frame. when you had "the spark" you could have fried one of the casings and now it is open and grounding out on the frame. Let me know if that helps.
Reply With Quote
  #21  
Old 05-13-2011, 07:56 PM
gfj17 gfj17 is offline
Ford Ranger Owner
 
Join Date: Mar 2010
Posts: 73
Default Re: two amps with one spark... wtf happened?

Quote:
Originally Posted by hwhmobile View Post
Two things: 1) Are your two amps connected to each other at any point other than the battery?
2) Follow all your wires and see if one of them is touching your metal frame. when you had "the spark" you could have fried one of the casings and now it is open and grounding out on the frame. Let me know if that helps.
Naw, only points they could be considered connected are battery, remote wire (just past the radio), and the ground, but the ground points are on opposite sides of the truck, bit i figured since its still the truck metal that its kinda the same.

And I haven't looked to see if any wire has got exposed yet, since it all seems to be working, but I have my in line fuse taken out, cuz I don't have a sub anymore!


But I still wanna know why it happened anyway
Reply With Quote
  #22  
Old 05-13-2011, 08:01 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: two amps with one spark... wtf happened?

So you didn't replace or redo anything since the short and everything is working fine now? If so, just go with it and pretend it never happened
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #23  
Old 05-13-2011, 08:26 PM
gfj17 gfj17 is offline
Ford Ranger Owner
 
Join Date: Mar 2010
Posts: 73
Default Re: two amps with one spark... wtf happened?

Quote:
Originally Posted by FireRanger View Post
So you didn't replace or redo anything since the short and everything is working fine now? If so, just go with it and pretend it never happened
I am lol unless it messes up again, and then ill look at the wires and stuff. But still outta curiosity I want to know wtf happened. :P

----------

Oh and no I didn't mess with anything and the next day it slowly came to life

----------

Oh and no I didn't mess with anything and the next day it slowly came to life
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound ordance amps More_Cowbell Audio / Video 3 02-08-2011 02:28 AM
Subs and amps help please! 96FR1060 Audio / Video 9 01-30-2011 07:52 PM
WTF happened to ebay?!!!! Clinton Off Topic 35 11-30-2010 08:43 PM
boss amps?? any good or they suck? silverskoundrel Audio / Video 5 10-04-2010 08:53 AM
What happened: Spark plug and wires changed and now engine sounds rough lcb90 4.0 SOHC / 4.0 OHV Tech 7 05-04-2010 06:26 PM