Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-08-2011, 08:56 PM
Monster Mule Deer Monster Mule Deer is offline
Wish I had an FX4
 
Join Date: Mar 2011
Posts: 156
Exclamation Head unit not turning on

Okay so after many strenuous hours and awkward positions, I finally got all my wires hooked up, and hooked up RIGHT. I clicked in my head unit and my neck pain instantly went away, only to come back when it didn't turn on. There is nothing wrong with the head unit itself and I think its my ground. I don't have a continuity tester to see which wire inside my dash was the ground wire so I was going to use the ground wire off of my head units harness directly, however it seems like EVERYTHING INSIDE OF MY FREAKING DASH IS PLASTIC. So I got a random 9 gauge Scosche power/ground wire and stripped off a ton of insulation and wrapped it all around the ring terminal on the end of the ground wire. First of all is it okay that I spliced a 9 gauge to a 16 gauge? and would that even work for a ground because it didn't work when I did that so I cut off the ring terminal and twisted the wires together and it still didn't work. I have a feeling the ring terminal on the end of my 9 gauge is just old and all bent up and the spot where I grounded it (the bolt that holds my seat to the floor) is just filthy.

Gah why did I say all that? I dunno. If you have any tips help please. I have spent more hours on this fricken ghetto rigged dash than I have on everything else.
__________________
1993 Ford Ranger XLT 4x4 4.0L 5 Speed
Mods: 3" Body Lift, 2" Leveling Kit, 32x11.5's, Prothane Body Mounts, Bed Lined Bumper, SA-8


SOLD
Reply With Quote
  #2  
Old 05-08-2011, 09:12 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Head unit not turning on

Did you check the fuse? Also try grounding it to the screws behind the glove box
Reply With Quote
  #3  
Old 05-08-2011, 09:48 PM
Monster Mule Deer Monster Mule Deer is offline
Wish I had an FX4
 
Join Date: Mar 2011
Posts: 156
Default Re: Head unit not turning on

Quote:
Originally Posted by Clinton View Post
Did you check the fuse? Also try grounding it to the screws behind the glove box
Hmm no I didn't check the fuse. I will try that spot in the morning.
__________________
1993 Ford Ranger XLT 4x4 4.0L 5 Speed
Mods: 3" Body Lift, 2" Leveling Kit, 32x11.5's, Prothane Body Mounts, Bed Lined Bumper, SA-8


SOLD
Reply With Quote
  #4  
Old 05-10-2011, 09:11 PM
Monster Mule Deer Monster Mule Deer is offline
Wish I had an FX4
 
Join Date: Mar 2011
Posts: 156
Default Re: Head unit not turning on

Fuse. Hehe..
__________________
1993 Ford Ranger XLT 4x4 4.0L 5 Speed
Mods: 3" Body Lift, 2" Leveling Kit, 32x11.5's, Prothane Body Mounts, Bed Lined Bumper, SA-8


SOLD
Reply With Quote
  #5  
Old 05-11-2011, 05:55 AM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: Head unit not turning on

LOL Fuses screw up everything. They're pesky little things. Try that spot though that Clinton suggested. There's a metal brace on the right side of the headunit behind the dash. That's where mine is grounded to.
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #6  
Old 05-11-2011, 10:20 AM
Monster Mule Deer Monster Mule Deer is offline
Wish I had an FX4
 
Join Date: Mar 2011
Posts: 156
Default Re: Head unit not turning on

Quote:
Originally Posted by ranger101 View Post
LOL Fuses screw up everything. They're pesky little things. Try that spot though that Clinton suggested. There's a metal brace on the right side of the headunit behind the dash. That's where mine is grounded to.
Yea my ground was fine so I just left it. haha. Stupid fuses. My neighbor just opened his window a house down and yelled at me because my sub was too loud hehehehe
__________________
1993 Ford Ranger XLT 4x4 4.0L 5 Speed
Mods: 3" Body Lift, 2" Leveling Kit, 32x11.5's, Prothane Body Mounts, Bed Lined Bumper, SA-8


SOLD
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
head unit.... cdawall Audio / Video 4 01-16-2011 03:05 PM
Need help with head unit CLJ99ranger Audio / Video 12 12-23-2010 05:35 PM
Want to Buy: head unit DangaRanger Interior Parts 2 07-20-2010 09:09 AM
best head unit? Ranger009 Audio / Video 32 05-10-2010 08:31 PM
Got me new head unit. Superlifted06FX4 Audio / Video 3 10-31-2009 12:04 PM