Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 05-05-2011, 06:28 PM
zman7125 zman7125 is offline
"Give Her the Biscuits"
Join Date: Jun 2010
Posts: 410
Default New Speakers & Headunit...crackling sound?

Alpine Type S and Pioneer DEH6200BT, speakers crackle when volume is higher than say 20? Only happens sometimes & only comes from rear speakers. Had the guy who professionally installed it run a new ground for the headunit as well. Could these speakers just be shot outta the box? Scratching my head on this one, thanks in advanced.

Sent from iPhone 4
SOLD: 1997 Ford Ranger STX 4x4

Current:LIFTED 1995 Ford F150 351W 4x4

Reply With Quote
Old 05-05-2011, 07:25 PM
OvaZ OvaZ is offline
Join Date: Apr 2011
Posts: 95
Default Re: New Speakers & Headunit...crackling sound?

I'd say a faulty connection of the speakers? If not take the speakers out and test them.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
headunit overheating or bad amp? canaranger Audio / Video 3 03-07-2011 08:18 PM
For Sale: Alpine Double Din headunit and Infinity kappa Speakers CLD Interior Parts 6 09-10-2010 10:22 PM
/Speakers, maybe sub and amp? hotshower10 Audio / Video 13 07-26-2010 06:11 PM
No SOUND from Speakers - HELP mcleod13 Audio / Video 8 06-15-2010 07:55 PM
headunit install. premium sound question batousi Audio / Video 44 01-22-2010 03:59 PM