Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-11-2011, 07:21 PM
power ranger power ranger is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2010
Posts: 17
Default backwards jump = dead radio

Well a couple of weeks ago I was having one of those days where I cant seem to do anything right. I start by leaving my lights on so I had a friend jump start me. The cables where old and hard to tell red from black but it was still my fault that I hooked them up backwards. They instantly started steaming and I immediately took them off and put them on properly. Then I started my truck and all seemed normal until I tried to turn on the radio. Nothing, it wont light up the clock doesn't work it does nothing at all. So I checked all the fuses with the ohm meter on my volt meter and even looked up the radio fuse and pulled it out to confirm it was good and checked the fuses under the hood. So I thought I blew the radio itself and I ordered a new one. Plugged it up today and same story. If anybody has any idea what could be wrong please help me out before I pay for a professional to fix it. Thanks in advance.
Reply With Quote
  #2  
Old 04-11-2011, 07:25 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: backwards jump = dead radio

Is this the factory stereo? Use your voltmeter and check power at the radio itself.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #3  
Old 04-11-2011, 07:35 PM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: backwards jump = dead radio

first things first...put red tape on the postive terminal wire
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #4  
Old 04-11-2011, 07:49 PM
Doctor Wily Doctor Wily is offline
Science!
 
Join Date: Feb 2011
Posts: 369
Default Re: backwards jump = dead radio

i second what fireranger says. check and see if there is power getting to the radio. then use a wiring diagram to trace back from there. Are there any other systems not working that you are aware of?

Also take a moment to create a signature with the specs of your ride so we know what you are rolling.


Cheerz!
Wily
__________________
Current: 2000 Ford Explorer XLS 4x4 Automatic 4.0L SOHC

Gone but not forgotten ~ "Ghetto Blue" my 1994 Mazda B2300 5 Speed Standard Cab 4x2.
Reply With Quote
  #5  
Old 04-11-2011, 07:57 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: backwards jump = dead radio

When you post up a question it makes it really simple for those answering your question if we have some information about your ride. The simplest thing is to create a signature and list the specs of your truck. Year, trim, drivetrain, engine, current mods plus anything else you would like to add. This way we are not asking for more information or blindly answering your questions. To create a signature click on User CP in the upper left and on that page, about the 10th option down on the left is the Edit Signature, go there fill out your info and save.
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #6  
Old 04-11-2011, 09:06 PM
power ranger power ranger is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2010
Posts: 17
Default Re: backwards jump = dead radio

OK I think I have the signature figured out and yes it is the stock radio and I will check the voltage asap.
__________________
2003 stock ranger xlt 4x4 super cab 4.0 automatic
Reply With Quote
  #7  
Old 04-12-2011, 08:10 PM
Doctor Wily Doctor Wily is offline
Science!
 
Join Date: Feb 2011
Posts: 369
Default Re: backwards jump = dead radio

did you find anything out yet?
__________________
Current: 2000 Ford Explorer XLS 4x4 Automatic 4.0L SOHC

Gone but not forgotten ~ "Ghetto Blue" my 1994 Mazda B2300 5 Speed Standard Cab 4x2.
Reply With Quote
  #8  
Old 04-16-2011, 06:20 PM
power ranger power ranger is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2010
Posts: 17
Default Re: backwards jump = dead radio

Quote:
Originally Posted by Doctor Wily View Post
did you find anything out yet?
No I tried the volt meter but I couldn't seem to find any current and I examined the wires as far as I could under the dash and it seems fine.
__________________
2003 stock ranger xlt 4x4 super cab 4.0 automatic
Reply With Quote
  #9  
Old 04-16-2011, 06:46 PM
Doctor Wily Doctor Wily is offline
Science!
 
Join Date: Feb 2011
Posts: 369
Default Re: backwards jump = dead radio

check fuses 20, 28, and 29. pull them out and test them with an ohmmeter
__________________
Current: 2000 Ford Explorer XLS 4x4 Automatic 4.0L SOHC

Gone but not forgotten ~ "Ghetto Blue" my 1994 Mazda B2300 5 Speed Standard Cab 4x2.
Reply With Quote
  #10  
Old 04-17-2011, 07:55 PM
power ranger power ranger is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2010
Posts: 17
Default Re: backwards jump = dead radio

Quote:
Originally Posted by Doctor Wily View Post
check fuses 20, 28, and 29. pull them out and test them with an ohmmeter
Thank you so much it was number 29. That was not the fuse labeled for the radio in the manual so I didn't pull that one out. I checked it with the ohm meter by touching the two metal tabs on the side of the fuse with the number and I forgot the radio was plugged in and the current went through it around the element so I thought it was good
__________________
2003 stock ranger xlt 4x4 super cab 4.0 automatic
Reply With Quote
  #11  
Old 04-17-2011, 07:59 PM
Doctor Wily Doctor Wily is offline
Science!
 
Join Date: Feb 2011
Posts: 369
Default Re: backwards jump = dead radio

Quote:
Originally Posted by Doctor Wily View Post
check fuses 20, 28, and 29. pull them out and test them with an ohmmeter
hence why I said to pull them out, lol.

Glad you got it working man. Also glad I was able to help you get it up and running!

Cheerz!
Wily
__________________
Current: 2000 Ford Explorer XLS 4x4 Automatic 4.0L SOHC

Gone but not forgotten ~ "Ghetto Blue" my 1994 Mazda B2300 5 Speed Standard Cab 4x2.
Reply With Quote
  #12  
Old 05-26-2011, 06:00 PM
Carpenter Carpenter is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 1
Default Re: backwards jump = dead radio

check your "Audio" fuse - #29 in my 1996 Ranger. I thought my radio was fried since the "radio" fuse was fine, but the radio didn't work. I happened across a mention of the "Audio" fuse, changed it, and had my radio back. This reply is probably too late for you, but might help others.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install Radio in a radio delete Ranger dch29 Audio / Video 1 03-31-2011 05:19 PM
Electrical BACKWARDS? Gumcrew2 General Ford Ranger Discussion 14 03-13-2011 01:19 PM
Craigslist / eBay Find: Some one with a 4.0, jump on this!! 2004xlmiller Engine & Drivetrain Parts 3 01-29-2011 10:46 PM
For Sale: Radio Bezel - Mustang dome - radio plugs - 4x4 switch pooleo Interior Parts 9 12-17-2010 10:41 AM
You know, if you watch 'Fight Club' backwards... Tom Music/Movies/Computers/etc. 9 05-07-2010 01:11 PM