Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-01-2011, 04:06 PM
95fordman 95fordman is offline
Ford Truck Driver
 
Join Date: Jan 2011
Posts: 97
Default got my subs. and a problem

ok guys i got my kicker cvx's today installed with a hifonics 1500 watt class d and the beat HARD!!!!! but when i crank the volume my head unit skips i have a backing plate and i also put foam from a old boat seat cusion underneath it and on top of it but still skips when i turn the volume up. thanks guys
__________________
1999 ford ranger x cab 4x4 flow masters 3" rear blocks 31x10.50 bfg ats. 2 12" kicker cvx's, 6.22 cubic foot ported box, hifonics 1500 watt class d mono wired 1ohm
Reply With Quote
  #2  
Old 04-01-2011, 04:32 PM
ranger101 ranger101 is offline
Ford Ranger Driver
 
Join Date: Dec 2009
Posts: 2,571
Default Re: got my subs. and a problem

Does it skip when you are playing CD's? Or does it do it even when you have an iPod hooked up?
__________________
2002 XLT 4X4
Auto 4.0L SOHC
8.8 w/ 4.10 L/S

Mods: Xcal 2, K&N Drop-In, Line-X, DSG Heads/Corners, 6000k Hi/Low HID's, 6K HID Fogs, Foglight Mod, Throttle Cable Mod, 6.5" Digital Designs, Rockford P400.4, 2 Sundown SA-15's, MB Quart DSC 2000.1d, Cranked T-Bars, 285/75/R16 Nitto Terra Grapplers
Reply With Quote
  #3  
Old 04-01-2011, 05:51 PM
95fordman 95fordman is offline
Ford Truck Driver
 
Join Date: Jan 2011
Posts: 97
Default Re: got my subs. and a problem

just cds my current head unit doesnt have a ipod of mp3 hook up im saving fore a kenwood double din. i had a pineer head unit in there that was older than dirt i thought maybe it was the unit so i took the unit out of my parts truck with is a sony its old to but it will get me by for a few months is there any way i can stop it from skipping? thanks
__________________
1999 ford ranger x cab 4x4 flow masters 3" rear blocks 31x10.50 bfg ats. 2 12" kicker cvx's, 6.22 cubic foot ported box, hifonics 1500 watt class d mono wired 1ohm
Reply With Quote
  #4  
Old 04-02-2011, 12:02 AM
Dirt Nasty Dirt Nasty is offline
Like the Forums
 
Join Date: Nov 2010
Posts: 40
Default Re: got my subs. and a problem

Time to upgrade your head unit. Either that or you can go the true DB comp route and make a mobile head unit station for outside of the truck.
Reply With Quote
  #5  
Old 04-02-2011, 12:03 AM
MTman777 MTman777 is offline
Back in black (kinda)
 
Join Date: Jan 2011
Posts: 1,276
Default Re: got my subs. and a problem

i think thats about the best problem to have when it comes to systems.. lol
__________________
00 Ford F-250...5.4L with some goodies, 4x4, Auto out of a 7.3 powerstroke w/ stage 2 TC , Crew Cab, Burnt orange, 35x12.5 MT Baja ATZ's on 20x10 Motometals, Pioneer Deck, Scanguage, Magnaflow exhaust, LED signal tow mirrors, and a Hidden hitch gooseneck
Reply With Quote
  #6  
Old 04-02-2011, 06:46 AM
95fordman 95fordman is offline
Ford Truck Driver
 
Join Date: Jan 2011
Posts: 97
Default Re: got my subs. and a problem

the bad thing is the volume is just on 15 if i turn it past that it will skip.
do you think a krnwood double din would still skip???
__________________
1999 ford ranger x cab 4x4 flow masters 3" rear blocks 31x10.50 bfg ats. 2 12" kicker cvx's, 6.22 cubic foot ported box, hifonics 1500 watt class d mono wired 1ohm
Reply With Quote
  #7  
Old 04-02-2011, 07:01 AM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: got my subs. and a problem

get out of the cave and use your ipod? lol
Reply With Quote
  #8  
Old 04-02-2011, 08:02 AM
95fordman 95fordman is offline
Ford Truck Driver
 
Join Date: Jan 2011
Posts: 97
Default Re: got my subs. and a problem

if you didny read befor i said my head unit doesnt have the hook up. an im saving my money for kenwood double din for like 700 bucks this unit i have is just to get me by for a few months. thanks
__________________
1999 ford ranger x cab 4x4 flow masters 3" rear blocks 31x10.50 bfg ats. 2 12" kicker cvx's, 6.22 cubic foot ported box, hifonics 1500 watt class d mono wired 1ohm
Reply With Quote
  #9  
Old 04-02-2011, 10:27 AM
MTman777 MTman777 is offline
Back in black (kinda)
 
Join Date: Jan 2011
Posts: 1,276
Default Re: got my subs. and a problem

i dont think the double din would skip...
__________________
00 Ford F-250...5.4L with some goodies, 4x4, Auto out of a 7.3 powerstroke w/ stage 2 TC , Crew Cab, Burnt orange, 35x12.5 MT Baja ATZ's on 20x10 Motometals, Pioneer Deck, Scanguage, Magnaflow exhaust, LED signal tow mirrors, and a Hidden hitch gooseneck
Reply With Quote
  #10  
Old 04-02-2011, 02:03 PM
DangerRanger379 DangerRanger379 is offline
B. A. M. F.
 
Join Date: Dec 2009
Posts: 483
Default Re: got my subs. and a problem

they make head units that are much better at not skipping. the old ones suck because not everyone and their brother had subs so it wasnt a big issue. the dd kenwood will be fine. ive got 2 12's behind the drivers seat and ive maxed the stereo out and still no skipping on a $200.00 alpine deck (blew one of my 12's too, but its since been replaced and no more going passed volume number 20 lol).
__________________
2003 | XLT | Extended Cab | V6 | 4x4 | 4.0L SOHC | 3 Inch Body Lift | Cranked T-Bars | TJM Wench Bumper | Blacked Out Heads | Fog Light Mod | Surround Delete Mod | Blinker Mod | Custom Center Console | OHC | Pacer Bullet Rims | 33x12.5 All Terrains | 1 Inch Wheel Spacers
Reply With Quote
  #11  
Old 04-02-2011, 02:07 PM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: got my subs. and a problem

i was only kidding man
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rattle problem fix with subs Ranger009 Audio / Video 14 01-01-2011 12:10 AM
Need some help with subs and amp speedy7722 Audio / Video 6 08-05-2010 11:13 AM
may have blown my subs. rangerdanger745 Audio / Video 11 07-16-2010 04:47 PM
2 12 Subs tcmills3 Audio / Video 3 04-12-2010 10:39 PM
Help with amp/subs !!! TheDangerRanger Audio / Video 10 02-06-2010 07:53 PM