Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-26-2011, 01:38 PM
kwaynepotter kwaynepotter is offline
Doctor Dan
 
Join Date: Feb 2011
Posts: 33
Question amp good or bad?

i have a clarion power system 400.4apx amp that i have no clue about, i ran all the wires an everything hooked it up an nothing it has a green power light that has to come on but its not, pretty sure i have a good ground, the fuse doesnt appear to be blown, an when i turn the key on an the stereo comes on you can hear it start to die down it keeps killing my battery! the amp is not appearing to turn on at all, any suggestions?
__________________
1996 Ranger 5 speed standard cab
Reply With Quote
  #2  
Old 03-26-2011, 06:26 PM
Thomaswildchild Thomaswildchild is offline
vimeo.com/thomaswildchild
 
Join Date: Dec 2010
Posts: 14
Default Re: amp good or bad?

do you have it wired to the ignition switch? That could explain the battery problem!

If you have it wired in correctly and there is sound coming out of it you should be set up right and may just need to play with some settings in either the radio or the amp itself.

where did you buy/ have install your amp?
__________________
2007 XLT Supercab 3.0 V6.
Alpine x-305s Head unit, Alpine head unit power pack, Infinity Component speakers, Alpine Sub- Coming soon!

2010 Giant Reign X1 RIP
2011 Giant Reign X0
Reply With Quote
  #3  
Old 03-26-2011, 08:22 PM
kwaynepotter kwaynepotter is offline
Doctor Dan
 
Join Date: Feb 2011
Posts: 33
Default Re: amp good or bad?

i hope i dont have it wired to the ignition switch haha, i got the amp off a guy i know, my brother ran all the wires, ive got a 6ga power wire with a fuse on it to the possitive battery cable, the rca cables ran to the amp + stereo, the ground... took the seat bolt out an sandpaperd the bracket then put the wire there under the washer for the bolt, have the remote wire ran to a blue/white wire on the stereo... took the amp an put the ground wire on the negative battery an the power wire on the positive an still got no light i think everythings wireed correct

----------

no sound
__________________
1996 Ranger 5 speed standard cab
Reply With Quote
  #4  
Old 03-26-2011, 08:36 PM
Thomaswildchild Thomaswildchild is offline
vimeo.com/thomaswildchild
 
Join Date: Dec 2010
Posts: 14
Default Re: amp good or bad?

Sounds like its not wired right. Running the cabin speakers or just a sub? Do you have the patch cables conneced correctly? Is the fuse in your power wire good? The one in the amp?
__________________
2007 XLT Supercab 3.0 V6.
Alpine x-305s Head unit, Alpine head unit power pack, Infinity Component speakers, Alpine Sub- Coming soon!

2010 Giant Reign X1 RIP
2011 Giant Reign X0
Reply With Quote
  #5  
Old 03-26-2011, 08:44 PM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: amp good or bad?

Try taking a piece of wire and jumping it from your remote turn on lead to the 12v constant lead. I think your remote turn on may be wrong.
Reply With Quote
  #6  
Old 03-27-2011, 10:40 AM
kwaynepotter kwaynepotter is offline
Doctor Dan
 
Join Date: Feb 2011
Posts: 33
Default Re: amp good or bad?

im just running the sub, im not sure any details you could throw me to make sure i do have them correct? both fuses appear to be alright ( not broken in the middle) but i mite go ahead and replace them? any ideas are greatly appreciated!
__________________
1996 Ranger 5 speed standard cab
Reply With Quote
  #7  
Old 03-27-2011, 10:42 AM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: amp good or bad?

have you tried what i suggested?
Reply With Quote
  #8  
Old 03-27-2011, 10:42 AM
kwaynepotter kwaynepotter is offline
Doctor Dan
 
Join Date: Feb 2011
Posts: 33
Default Re: amp good or bad?

Quote:
Originally Posted by AlxGry View Post
Try taking a piece of wire and jumping it from your remote turn on lead to the 12v constant lead. I think your remote turn on may be wrong.
could you explain detail how to do this, im a little new at the subs an amp stuff haha
__________________
1996 Ranger 5 speed standard cab
Reply With Quote
  #9  
Old 03-27-2011, 10:45 AM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: amp good or bad?

Sure! On your amp there should be three terminals. One for the power (red wire on battery) one for the ground, and one for your remote turn on lead. Take a small piece of wire and touch it from the power to the turn on terminal and see if the light comes on.

Once my amp stopped working and wouldnt turn on, but i knew i had power, all fuses ok etc. What had happened was my remote turn on wire got severed cause i ran it poorly.

What the turn on wire does is get signal from when the radio turns on, and allows the amp to be turned on, because without that youd be getting a constant 12v to the amp whether truck was on or off, draining your battery.

also, be sure that youre getting a good connection from power to turn on terminal, dont just touch wire from screw to screw, make sure its on the plate that both wires touch.
Reply With Quote
  #10  
Old 03-27-2011, 10:50 AM
kwaynepotter kwaynepotter is offline
Doctor Dan
 
Join Date: Feb 2011
Posts: 33
Default Re: amp good or bad?

this makes great sense man! alright im all with you here, im going the take a piece of wire put it in the remote terminal screw it down take the other end an put it in the power terminal, do i need the actual power wire in the power termial too?
__________________
1996 Ranger 5 speed standard cab
Reply With Quote
  #11  
Old 03-27-2011, 10:52 AM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: amp good or bad?

yeah you do. good luck i hope it fixes it i almost cried when i thought my amp was broke lol
Reply With Quote
  #12  
Old 03-27-2011, 10:55 AM
kwaynepotter kwaynepotter is offline
Doctor Dan
 
Join Date: Feb 2011
Posts: 33
Default Re: amp good or bad?

thanks for all this! i hope it does too, oh your not alone i havent really done the wireing an stuff a whole lot but i love subs an amp, all ive wanted an this cannot happen lol
__________________
1996 Ranger 5 speed standard cab
Reply With Quote
  #13  
Old 03-27-2011, 10:57 AM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: amp good or bad?

Haha right, i blew an amp cause i got stuck and my cab flooded, luckily picked one up at a yard sale super cheap to replace it and the n i thought it went bad and this was all withing a few days of eachother. I was like nooooo fkn way haha. But yeah let us know how it goes.
Reply With Quote
  #14  
Old 03-27-2011, 12:13 PM
kwaynepotter kwaynepotter is offline
Doctor Dan
 
Join Date: Feb 2011
Posts: 33
Default Re: amp good or bad?

dude... in a no homo kind of way... i fckin love you! alright i wired her up, the cuttt a small remote wire put it in its screw, then took the other end an put it in the power terminal also an BAM! power light comes on
should i just run the remote wire from the blue an white wire off the stereo to the amp now?
__________________
1996 Ranger 5 speed standard cab
Reply With Quote
  #15  
Old 03-27-2011, 12:22 PM
AlxGry AlxGry is offline
Get gnarly!
 
Join Date: Jun 2010
Posts: 670
Default Re: amp good or bad?

It has to be from the remote turn on lead from the head unit, what model head unit do you have?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ford escape good or bad 2003fordranger Off Topic 13 03-09-2011 07:23 AM
1997 ranger, good or bad? nrois02 General Ford Ranger Discussion 21 01-18-2011 04:53 PM
Rear Axle....Good or Bad? Kingoverace Drivetrain Tech 9 03-24-2010 01:40 PM
Body lift good or bad? jsquier91 Lifted Suspension 20 02-22-2010 07:50 PM
t-bar keys. good or bad? big green Suspension Tech 5 10-26-2009 01:25 PM