Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-03-2011, 05:38 AM
ArcticRANGER4X4 ArcticRANGER4X4 is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 6
Default Complete power loss in head unit need help immediatly!

ok i have a slighty similar slightly different problem. i have a 2003 ford ranger Sport 4.0l with 4x4 and i just installed a clarion deck. (had it in my old truck and it worked perfect) and i have 2 10"xenon subs hooked up to the truck with a 4g wiring kit with 2000w amp. i was driving down the road and all of a sudden the head unit turned off. i tried restarting the truck but it did nothing it still will not turn on. ive checked the fuses both in dash and under hood. they are perfectly fine i checked my wiring and its all good no shorts (that i could see) any suggestions? could it be the deck internals? tommorow i think i will put in a different deck to see if it works. please let me know on any ideas you have. i hope its not anything to do with the wiring harness. thanks, if you could post a fuse diagram or send me a like it would be much appreciated.
__________________
2000 RANGER 4x4 sport with arctic package. new paint (white) 31" kelly safari TSR tires, 2 10" xenon subs with 2000w amp. clarion head unit
Reply With Quote
  #2  
Old 02-03-2011, 07:57 AM
scarbucket scarbucket is offline
scarbucket
 
Join Date: Oct 2010
Posts: 85
Default Re: Complete power loss in head unit need help immediatly!

i think its probobly the deck if the fuses are bad the other way you can make sure its not the wires is to run a power wire off the battary and see if it turns on thatway also.
__________________
shut up, buckle your seat belt and hold on for dear life I wanna try somthing!
Reply With Quote
  #3  
Old 02-03-2011, 09:57 AM
ArcticRANGER4X4 ArcticRANGER4X4 is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 6
Default Re: Complete power loss in head unit need help immediatly!

so if i get a new deck what can i do to stop this from happening again?
__________________
2000 RANGER 4x4 sport with arctic package. new paint (white) 31" kelly safari TSR tires, 2 10" xenon subs with 2000w amp. clarion head unit
Reply With Quote
  #4  
Old 02-03-2011, 10:00 AM
edgeman4.0 edgeman4.0 is offline
THE COMPLAINT DEPARTMENT
 
Join Date: Nov 2009
Posts: 3,962
Default Re: Complete power loss in head unit need help immediatly!

^pray?

my first step would be to get a multimeter and read the voltage on your wiring behind the deck..
__________________
2001 Ford Ranger Supercab (4dr), Oxford White, 4.0 Sohc, 4x4, Manual trans (hurst equipped), 4:10's, 3" body lift.
Quote:
Originally Posted by Demon-FX4 View Post
The Edgeman sees his prey and strikes out from the darkness.
Quote:
Originally Posted by Rango88 View Post
Dont f+ck with Ch+ck
Reply With Quote
  #5  
Old 02-03-2011, 03:09 PM
2003 XLT FX4 2003 XLT FX4 is offline
No Money = No Mods :(
 
Join Date: Jan 2011
Posts: 98
Default Re: Complete power loss in head unit need help immediatly!

Yeah like edgeman said, check to see if you have proper power going to your head units wiring harness, and also maybe check the ground?
__________________
2003 Ranger FX4, Alpine 10" type R, alpine deck,amp, and speakers, Fog light mod, Hella's behind the grill with dual fog switches in bezel.
Reply With Quote
  #6  
Old 02-03-2011, 04:16 PM
DangerRanger2000 DangerRanger2000 is offline
Twist It Back!
 
Join Date: Dec 2010
Posts: 772
Default Re: Complete power loss in head unit need help immediatly!

Is there a fuse on the deck? My pioneer has a fuse right by the plug in, idk if clarions do but you should check.
__________________
2000 XLT 4x4 EXT. CAB 4.0/Auto Trans/3.73 gears/
31x10.50 BFG Rugged Terrains on MB Motoring Wheels/Pioneer Head Unit/JBL 12"/Camo Interior/'03 black and grey 60/40 seats/ green LED's Under Dash/T-Bar Crank/Windows-20% on the front, 5% on the back/Mustang Dome Light/06 Tails/
Reply With Quote
  #7  
Old 02-03-2011, 04:47 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Complete power loss in head unit need help immediatly!

You've checked the fuses and positive power wires. What about the ground wires. It takes both to work. How is the head unit's ground wire connected to ground? Through the truck's existing ground wire or it's new one? Check that before you ditch it.

Also, there must be an ignition controlled wire to tell it to turn on when the key is on. So trace that from the head unit back to where it is connected to the truck's existing wires. If that wire is broken off somewhere or it's fuse is blow, then the HU will not turn on.

If you have main power, ignition power, and ground, then the HU is probably toast. The best way to prevent that from happening is, as already stated, prey.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #8  
Old 02-04-2011, 05:42 AM
ArcticRANGER4X4 ArcticRANGER4X4 is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 6
Default Re: Complete power loss in head unit need help immediatly!

ok thanks i on this deck i have a fuse on my power wire going from the HU into the plug in what color wire is the ignition wire? and i will be checking my ground tonight. i was told by a mechanic that for putting out more power and quality i should run seperate power and ground cables. not through the existing wireing harness. any thoughts on that? thanks for you help... ah and btw this happend yesterday. somehow when i was wiring up the deck it blew 3 different fuses which control how it starts. it would not even start. i had to tow it to my uncles shop behind my buddys truck..... kinda embarrassing if you no what i mean.
__________________
2000 RANGER 4x4 sport with arctic package. new paint (white) 31" kelly safari TSR tires, 2 10" xenon subs with 2000w amp. clarion head unit
Reply With Quote
  #9  
Old 02-04-2011, 07:18 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Complete power loss in head unit need help immediatly!

Without knowing how you wired it, it's impossible to diagnose. You have to detail what you've connected things too now.

Wiring the main power to the battery is probably unneccessary. The stock wiring can handle it just fine. The HU is not pumping out a lot of juice. The amp is doing most of the work.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #10  
Old 02-08-2011, 06:00 AM
ArcticRANGER4X4 ArcticRANGER4X4 is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 6
Default Re: Complete power loss in head unit need help immediatly!

well i got it figured out i had to run a new power and ground wire to the HU the old power and ground wire must have been struggling cause they were just melted away. but yeah. after i did that its been working perfect. i did change the 15amp cylinder fuse to a 15amp pronged fuse though. thanks for all your imput guys hope to talk to you all soon.
__________________
2000 RANGER 4x4 sport with arctic package. new paint (white) 31" kelly safari TSR tires, 2 10" xenon subs with 2000w amp. clarion head unit
Reply With Quote
  #11  
Old 02-08-2011, 09:33 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Complete power loss in head unit need help immediatly!

You melted the factory power wires?????????????
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #12  
Old 03-21-2011, 07:52 AM
ArcticRANGER4X4 ArcticRANGER4X4 is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 6
Default Re: Complete power loss in head unit need help immediatly!

yup the power and ground wires had melted. i replaced them with new ones along with a 15 fuse.. works awesome now.... btw looking for 6" pre runner flares any clue where to get them for a decent price?
__________________
2000 RANGER 4x4 sport with arctic package. new paint (white) 31" kelly safari TSR tires, 2 10" xenon subs with 2000w amp. clarion head unit
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
head unit.... cdawall Audio / Video 4 01-16-2011 03:05 PM
Need help with head unit CLJ99ranger Audio / Video 12 12-23-2010 05:35 PM
Want to Buy: head unit DangaRanger Interior Parts 2 07-20-2010 09:09 AM
best head unit? Ranger009 Audio / Video 32 05-10-2010 08:31 PM
Head unit, no power SmokeyMcPot420 Audio / Video 1 11-18-2009 11:19 AM