Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 11-04-2010, 11:38 AM
drtrunr4 drtrunr4 is offline
Learning to use the forums
Join Date: Jul 2010
Posts: 2
Default Amp

All of a sudden my amp stopped working. All of the fuses are good and all the conections seem correct and the green light on the amp is lit. but my sub isn't pounding or producing any noise. Could it be my sub that is out or is my amp done for?
Reply With Quote
Old 11-04-2010, 05:01 PM
Bighomedog11 Bighomedog11 is offline
Ford Ranger Driver
Join Date: Sep 2009
Posts: 610
Default Re: Amp

Could be the amp is blown but again you said the amp is on. So it could be the sub. I would try a door speaker and set the amp settings to low and see if you get sound..

Could be the sub or amp just got to test them both out.
97"Ford Ranger 2.3L

Mods: Headlights 8k HIDs, Green Fogs HIDs, FlowMaster 40 Series, Tails lights, Shaved Tail gate,Roll pan, 5/6 lowered, Ibeams, 2in coils, Flip kit, Honda Metallic Paint

Reply With Quote
Old 11-05-2010, 11:31 AM
nvr_done nvr_done is offline
Like the Forums
Join Date: Apr 2010
Posts: 45
Default Re: Amp

Or you could ohm your sub... would probably be easier and quicker
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: MTX Thunder 5302 Amp & Kinetik HC 1800 Audio Battery Brandon22685 Interior Parts 2 09-07-2010 04:10 PM
Want to Buy: Sub and amp calebw15 Misc Items 4 08-27-2010 12:34 AM
adding Amp & sub to stock HU stables Audio / Video 2 07-19-2010 07:34 PM
[SOLD] Full Length Console with Enclosed Sub & Amp (TX) icthusrulz Interior Parts 3 03-22-2010 08:35 AM
Amp/Sub Help GeorgiaRanger Audio / Video 14 01-23-2010 08:23 PM