Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-19-2010, 10:08 AM
ridder1705 ridder1705 is offline
Ford Ranger Owner
 
Join Date: Oct 2010
Posts: 69
Default AM not working

I was curious what would make my AM radio not work, but my FM and CD works fine.
When i switch from FM to AM I get nothing but fuzz...
Is something not hooked up right?
I thought the FM and AM were in one wire?
__________________
99' Ford Ranger Sport
2wd
Fiberglass tonneau cover
Reply With Quote
  #2  
Old 10-19-2010, 10:10 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: AM not working

could just be you have no close local am radio stations in your area....but why the hell do you want am anyway?
Reply With Quote
  #3  
Old 10-19-2010, 10:20 AM
ridder1705 ridder1705 is offline
Ford Ranger Owner
 
Join Date: Oct 2010
Posts: 69
Default Re: AM not working

I have tons close, but no reception.....
I listen to talk radio in the morning on the way to my job site.
Don't even.... haha
__________________
99' Ford Ranger Sport
2wd
Fiberglass tonneau cover
Reply With Quote
  #4  
Old 10-19-2010, 10:23 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: AM not working

haha!! That is a weird one though. You would think if you get fm, am should work too
Reply With Quote
  #5  
Old 10-19-2010, 12:08 PM
ridder1705 ridder1705 is offline
Ford Ranger Owner
 
Join Date: Oct 2010
Posts: 69
Default Re: AM not working

Yeah, that's what i figured too.
Maybe it's something with my aftermarket head.
I'm putting a stock Mazda one back in( if I can get the right harness), so maybe that'll clear it up.
Hopefully...
__________________
99' Ford Ranger Sport
2wd
Fiberglass tonneau cover
Reply With Quote
  #6  
Old 10-19-2010, 01:35 PM
nvr_done nvr_done is offline
Like the Forums
 
Join Date: Apr 2010
Posts: 45
Default Re: AM not working

Your antenna ground is bad most likely. Check that and the radio ground. AM requires a good ground FM not so much
Reply With Quote
  #7  
Old 10-19-2010, 03:50 PM
ridder1705 ridder1705 is offline
Ford Ranger Owner
 
Join Date: Oct 2010
Posts: 69
Default Re: AM not working

Where exactly is my antenna ground at?

Thanks!
__________________
99' Ford Ranger Sport
2wd
Fiberglass tonneau cover
Reply With Quote
  #8  
Old 10-19-2010, 04:17 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: AM not working

What about trying to clean the screw connection on the antenna?
I have no recommendation on how to clean the female threaded part. I believe it bottoms out, but that's why it can hold moisture. Gotta tap and die set?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #9  
Old 10-20-2010, 06:28 AM
nvr_done nvr_done is offline
Like the Forums
 
Join Date: Apr 2010
Posts: 45
Default Re: AM not working

I'm not 100% sure as I've never looked at the antenna on the ranger but if it is a screw on then the base should be able to be removed. Otherwise a tap and die set would work, also make sure that someone didn't teflon tape it on.
Reply With Quote
  #10  
Old 10-22-2010, 10:01 PM
INebre8ted INebre8ted is offline
Old Man
 
Join Date: Oct 2009
Posts: 8
Default Re: AM not working

aftermarket radios are made for sound quality, AM, on its best day cant do that, therefore aftermarket companys put no $ in makin it work. if you notice almost all aftermarket radios dont have as good of FM either, but it sounds so much better noone cares.almost all factory radios are a mono signal on radio, sounds like s#@t but gets great reception.
Reply With Quote
  #11  
Old 10-25-2010, 10:39 PM
demon54 demon54 is offline
Liking the Ford Ranger Forum
 
Join Date: Oct 2010
Posts: 27
Default Re: AM not working

Probably the first RF amplifier in the am receiver circuit has been blown. This can be caused by static electricity generated by the vehicle passing through the air.

It happens all the time....
Reply With Quote
  #12  
Old 10-31-2010, 07:58 AM
ridder1705 ridder1705 is offline
Ford Ranger Owner
 
Join Date: Oct 2010
Posts: 69
Default Re: AM not working

Does anyone know how to get to the bottom of the antenna to look and make sure the wire is connected okay?
I can't figure out how to get to it from underneath??
__________________
99' Ford Ranger Sport
2wd
Fiberglass tonneau cover
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn not working 94GT50 Electrical Tech 7 11-23-2013 04:00 PM
speedometer not working ngant17 Drivetrain Tech 0 05-30-2010 06:55 AM
radio working sometimes jpimen9760 Audio / Video 4 03-18-2010 07:16 AM
4x4 not working otwhitty1 Drivetrain Tech 12 02-09-2010 07:01 PM
A/C not working...could it be a/c relay sportscraft205 General Tech 2 07-06-2009 07:44 AM