Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #616  
Old 03-25-2012, 03:36 PM
KyrosFactor KyrosFactor is offline
o_O
 
Join Date: Jan 2012
Posts: 531
Default

So my sub stopped working on the way home last night. Took it out of the box and connected it straight to the wires from the amp. Nothing. Connected the wires to my pos pioneer and it works. Pretty sure the sub blew. I got it used so serves me right huh.
__________________
98 Ford Ranger XLT 2WD
Cragar Soft 8's | BFGoodrich All Terrain T/A KO 31x10.5x15 | Kenwood KDC-X595 Headunit | K&N Air Filter | Mustang Dome Light | 5% Tint | Nightshaded Tails and Front Turns | 4x4 Valance | 35W 6K HIDs | Herculiner Bed liner |


www.conqueringcloth.com
Reply With Quote
  #617  
Old 03-25-2012, 06:36 PM
GLH GLH is offline
Ford Ranger Driver
 
Join Date: Oct 2011
Posts: 8,818
Thumbs up Re: Show Your System

Quote:
Originally Posted by Casper View Post
I'll get a picture of the birth sheet, its actual power is 104x4 and 400x1
Nice !

I would get a DMM and be sure the gain is set for 400 watts output ! If it is a 2 ohm sub, you should read 28 VAC or a hair more at the sub output terminals on the amp. If it is a 4 ohm sub, it should be 40 VAC.
Reply With Quote
  #618  
Old 03-25-2012, 06:59 PM
Casper Casper is offline
Adam's > Everything else
 
Join Date: Dec 2009
Posts: 1,621
Default Re: Show Your System

Here's the birthsheet


I'll have to look into the gain on the amp and see how much I'm running. I need to get a better head unit with 3 pre-outs so I can hook up the other 4 channels. Right now I only have 2 but I'm looking at a Kenwood or Alpine with 3 and 4volts. When I have some more money it's getting Hertz components in the front stage and I have a set of new alpine 5x7's to go in the back. Oh and a sealed 10" sounds perfect to me anyways it's a real tight clean sound with Rock and it'll get low if need be on the 4 or 5 rap songs I like LOL
__________________
98 Ranger some stuff done

PNW Crew

Last edited by Casper; 03-25-2012 at 07:02 PM.
Reply With Quote
  #619  
Old 03-25-2012, 08:50 PM
MisterGrubbs MisterGrubbs is offline
Ford Ranger Owner
 
Join Date: Jan 2011
Posts: 74
Send a message via AIM to MisterGrubbs
Default Re: Show Your System

Glad to see this thread is still alive and kicking.

By the way, there is some horrible information in this thread. Also, GLH, I'm glad you're helping folks out, but you're not stating the entire truth. There are alternatives to some of the shit you're spraying.

And you don't have to buy everything online. Perhaps if every now and then you'd spend money at the local audio store, they all wouldn't be closing down
Reply With Quote
  #620  
Old 03-25-2012, 08:52 PM
Yeller Yeller is offline
Wow.So cobra.Very Ranger.
 
Join Date: Mar 2011
Posts: 5,699
Default Re: Show Your System

Quote:
Originally Posted by MisterGrubbs View Post
Glad to see this thread is still alive and kicking.

By the way, there is some horrible information in this thread. Also, GLH, I'm glad you're helping folks out, but you're not stating the entire truth. There are alternatives to some of the shit you're spraying.

And you don't have to buy everything online. Perhaps if every now and then you'd spend money at the local audio store, they all wouldn't be closing down

I like the way you think
__________________
Chrome Yellow 2001 Ranger Edge 3.0L V6/5spd
Reply With Quote
  #621  
Old 03-25-2012, 08:53 PM
Tickle Monster Tickle Monster is offline
I <3 Bass
 
Join Date: Mar 2012
Posts: 347
Default

Agreed. My local shops are idiots but I do support the smaller company's.

Sent from my SAMSUNG-SGH-I777 using Tapatalk
__________________
1993 Ranger 2.3L-4.11 8.8"
Toyo ATs 235/75/r15-6000k HIDs-Cut Cab
Team Sundown Audio
Reply With Quote
  #622  
Old 03-25-2012, 08:54 PM
727Designs 727Designs is offline
Car Audio N00b
 
Join Date: Mar 2012
Posts: 469
Default Re: Show Your System

Quote:
Originally Posted by MisterGrubbs View Post
Glad to see this thread is still alive and kicking.

By the way, there is some horrible information in this thread. Also, GLH, I'm glad you're helping folks out, but you're not stating the entire truth. There are alternatives to some of the shit you're spraying.

And you don't have to buy everything online. Perhaps if every now and then you'd spend money at the local audio store, they all wouldn't be closing down

Very true in all aspects.
__________________
-Zach/727Designs-
2012 USACi SPL Mod 0-1000 GA State Record Holder
1988 Honda CRX Si - IASCA Stock Hatchback/Wagon 2
2000 Ford Expedition - IASCA Adv3/Heavyweight 160dB+ -SOLD-
Reply With Quote
  #623  
Old 03-25-2012, 09:10 PM
BoyRanger BoyRanger is offline
Higher Than Most
 
Join Date: Jan 2012
Posts: 1,939
Default Re: Show Your System

hey guys. so I just got a ranger, and it has 2 12" subs (W3s by JL Audio) and 2 amps (one is a JL Audio 500/1 and the other is a Almani PA-800.4) I do seam to be getting anything out of either of them. the JL Audio DOES NOT have the power bulb lit up, so I figured that was the main problem, but I have no clue why its not getting power, everything looks like its all plugged in correctly, but I have next to no experience with audio set ups like this, any help would be great. Ill get pics up later.
__________________
2006 Ford Ranger
V6 3.AWESOME 5 Speed
3" Fabtech spindle lift
32" Falken Wild Peak A/T

Quote:
Originally Posted by 2004xlmiller View Post
"Cant tell if gay or cali member"
Reply With Quote
  #624  
Old 03-25-2012, 09:12 PM
MisterGrubbs MisterGrubbs is offline
Ford Ranger Owner
 
Join Date: Jan 2011
Posts: 74
Send a message via AIM to MisterGrubbs
Default Re: Show Your System

BoyRanger - with your level of knowledge, I honestly think you should take it to a shop.

While we're on the note, are there any fuses under the hood, and are they in there?
Reply With Quote
  #625  
Old 03-25-2012, 09:17 PM
727Designs 727Designs is offline
Car Audio N00b
 
Join Date: Mar 2012
Posts: 469
Default Re: Show Your System

Quote:
Originally Posted by BoyRanger View Post
hey guys. so I just got a ranger, and it has 2 12" subs (W3s by JL Audio) and 2 amps (one is a JL Audio 500/1 and the other is a Almani PA-800.4) I do seam to be getting anything out of either of them. the JL Audio DOES NOT have the power bulb lit up, so I figured that was the main problem, but I have no clue why its not getting power, everything looks like its all plugged in correctly, but I have next to no experience with audio set ups like this, any help would be great. Ill get pics up later.
Start simple, check your power wire fuse. If that's not it follow your ground wire and make sure it's tight. If that's not it check the fuses on the amp... if still no go, take it to some one with more experience.
__________________
-Zach/727Designs-
2012 USACi SPL Mod 0-1000 GA State Record Holder
1988 Honda CRX Si - IASCA Stock Hatchback/Wagon 2
2000 Ford Expedition - IASCA Adv3/Heavyweight 160dB+ -SOLD-
Reply With Quote
  #626  
Old 03-25-2012, 09:19 PM
BoyRanger BoyRanger is offline
Higher Than Most
 
Join Date: Jan 2012
Posts: 1,939
Default Re: Show Your System

Quote:
Originally Posted by MisterGrubbs View Post
BoyRanger - with your level of knowledge, I honestly think you should take it to a shop.

While we're on the note, are there any fuses under the hood, and are they in there?
I figured Id probably have to do that, and I know a decent shop so I might bring it there, I just figured Id try to figure it out myself.

Ill check that in the morning, it was raining all today, so I wasnt able to look at it that closely.
__________________
2006 Ford Ranger
V6 3.AWESOME 5 Speed
3" Fabtech spindle lift
32" Falken Wild Peak A/T

Quote:
Originally Posted by 2004xlmiller View Post
"Cant tell if gay or cali member"
Reply With Quote
  #627  
Old 03-25-2012, 09:19 PM
Yeller Yeller is offline
Wow.So cobra.Very Ranger.
 
Join Date: Mar 2011
Posts: 5,699
Default

Quote:
Originally Posted by 727Designs View Post
Start simple, check your power wire fuse. If that's not it follow your ground wire and make sure it's tight. If that's not it check the fuses on the amp... if still no go, take it to some one with more experience.
This. Make sure your ground is a good ground that is on pure metal. No paint. Sand any paint down. Thats what I did


Sent from my iPhone 4 using Tapatalk
__________________
Chrome Yellow 2001 Ranger Edge 3.0L V6/5spd
Reply With Quote
  #628  
Old 03-25-2012, 09:22 PM
MisterGrubbs MisterGrubbs is offline
Ford Ranger Owner
 
Join Date: Jan 2011
Posts: 74
Send a message via AIM to MisterGrubbs
Default Re: Show Your System

BoyRanger - can I make a suggestion? If you know a local shop - - - go up there and talk to them! I learned in the backyard by blowing up my own shit, and then reading until I figured out why - and asking other folks questions.

Approach the shop and tell them whats going on - - - see IF they'll let you sit in while they're looking over it, and they might even go through some extra things and get you on the right path to being started.

This is, assuming, it's a decent shop.
Reply With Quote
  #629  
Old 03-25-2012, 09:26 PM
BoyRanger BoyRanger is offline
Higher Than Most
 
Join Date: Jan 2012
Posts: 1,939
Default Re: Show Your System

Quote:
Originally Posted by OlYeller View Post
This. Make sure your ground is a good ground that is on pure metal. No paint. Sand any paint down. Thats what I did


Sent from my iPhone 4 using Tapatalk
ok Ill check this out tomorrow.

Quote:
Originally Posted by MisterGrubbs View Post
BoyRanger - can I make a suggestion? If you know a local shop - - - go up there and talk to them! I learned in the backyard by blowing up my own shit, and then reading until I figured out why - and asking other folks questions.

Approach the shop and tell them whats going on - - - see IF they'll let you sit in while they're looking over it, and they might even go through some extra things and get you on the right path to being started.

This is, assuming, it's a decent shop.
Ill have to try and see, I know some people that have done business with them in the past, I dont know if they will let me watch though, thanks for the suggestion though, Ill have to try.
__________________
2006 Ford Ranger
V6 3.AWESOME 5 Speed
3" Fabtech spindle lift
32" Falken Wild Peak A/T

Quote:
Originally Posted by 2004xlmiller View Post
"Cant tell if gay or cali member"
Reply With Quote
  #630  
Old 03-25-2012, 09:28 PM
MisterGrubbs MisterGrubbs is offline
Ford Ranger Owner
 
Join Date: Jan 2011
Posts: 74
Send a message via AIM to MisterGrubbs
Default Re: Show Your System

Just remember before you go jumping in head first - - - electrical fires are NOT something you want to screw with. If you're clueless, that's fine, but you need to learn to swim before you swim. If you drop a newborn in a pool, they're going to drown.

I tell you this speaking from experience - over 10 blown Alpine Type E 10"ers and two Memphis amps in my young days, haha.

And yes, that was with 1/0 ran through the doorjam, booyah!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Show off that INK!!! FX4 Off Topic 790 11-26-2014 07:38 AM
The show pics mikesturbo94 Vehicle Snapshots 9 07-17-2010 11:49 AM
Car Show - 05/01/10 DisturbedESV Vehicle Snapshots 8 05-04-2010 07:33 PM
tonneau who has them and show them off blueovelboy Exterior Tech 20 03-12-2010 01:34 PM
Show My Posts GaryCN Site Announcements, Comments and Suggestions 6 10-21-2009 06:23 AM