Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #5761  
Old 10-13-2016, 07:54 AM
sole sole is offline
Ford Ranger Driver
 
Join Date: Jan 2012
Posts: 6,276
Default Re: Show Your System

Quote:
Originally Posted by southernboy94 View Post
You guys always say that about the sundowns so I'm going to give them a shot and try something different than JL. definitely gonna do 2 12s and get box as close to spec as possible. I'm quite excited for it to be honest lol and also gonna try a ported box vs enclosed like I have now


Could just buy my 2 sundown x12's


Sent from my iPhone using Tapatalk
__________________
Black 2008 ranger sport 4.0 SOHC SAS'd and converted to 4x4 riding on a Dana 50 up front and a sterling 10.50 in the rear regeared with 5.13's, mickey thompson classic 3's rapped in 37x12.50 maxxis creepy crawlers
Reply With Quote
  #5762  
Old 10-13-2016, 09:35 PM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,133
Default

Quote:
Originally Posted by southernboy94 View Post
You guys always say that about the sundowns so I'm going to give them a shot and try something different than JL. definitely gonna do 2 12s and get box as close to spec as possible. I'm quite excited for it to be honest lol and also gonna try a ported box vs enclosed like I have now
You will be happy with your decision. I have two jl w3v3s in my car. If they go out will probably replace them with sundown.
Reply With Quote
  #5763  
Old 11-02-2016, 02:04 PM
casey.mikl casey.mikl is offline
Ford Ranger Driver
 
Join Date: Mar 2012
Posts: 9,658
Default Re: Show Your System

Okay.. well my kenwood head unit has been having issues with the Bluetooth. It would loose connection or would freak out and I would have to reconnect on my phone. Kenwood came out with an update for the head unit, sweet! Download the update, follow kenwoods instructions by the book. Have the USB plugged in, it's updating. Update is done. Says turn off headunit, turn it off. Guess what! Will not turn back on. I have the red triangle lighting up. Nothing else won't do a freaking thing. I called kenwood. He told me to take the unit out and bench test it. Said the 12v accessory wire isn't working. I said yes it is because when I turn the key off, red triangle shuts off, when I turn it on, it comes on. He goes oh well you'll have to take it to a shop, I can't help you any farther. Emailed the guy I got it from and it's got a 2 year warrenty. Told me to go over the wiring and if it's all good and not working to send it back. So needless to say.. I'm out of music for a while. Sucks! I hate it! Maybe someone will have any help?


Sent from my iPhone using Tapatalk
__________________
1997 B2300 reg cab 2.3 Lima, 15x8.5 Mickey Thompson classic 2, 31x10.50 cooper discover at3, 7.5 open 4.10 rear, dynomax super turbo catback, alpine iva-w200 w/ nav, kicker 6x8s, alpine type R 8, alpine 250W mono amp, power bass 400.4, tool box & camper shell, compustar alarm/remote start.
1956 Ford F100 rust bucket with big plans!
Reply With Quote
  #5764  
Old 11-02-2016, 02:37 PM
AmericanPride! AmericanPride! is offline
Ford Ranger Driver
 
Join Date: Nov 2012
Posts: 6,674
Default Re: Show Your System

Quote:
Originally Posted by casey.mikl View Post
Okay.. well my kenwood head unit has been having issues with the Bluetooth. It would loose connection or would freak out and I would have to reconnect on my phone. Kenwood came out with an update for the head unit, sweet! Download the update, follow kenwoods instructions by the book. Have the USB plugged in, it's updating. Update is done. Says turn off headunit, turn it off. Guess what! Will not turn back on. I have the red triangle lighting up. Nothing else won't do a freaking thing. I called kenwood. He told me to take the unit out and bench test it. Said the 12v accessory wire isn't working. I said yes it is because when I turn the key off, red triangle shuts off, when I turn it on, it comes on. He goes oh well you'll have to take it to a shop, I can't help you any farther. Emailed the guy I got it from and it's got a 2 year warrenty. Told me to go over the wiring and if it's all good and not working to send it back. So needless to say.. I'm out of music for a while. Sucks! I hate it! Maybe someone will have any help?


Sent from my iPhone using Tapatalk
Yeah, buy a deck at a local shop and they would swap it over the counter
Reply With Quote
  #5765  
Old 11-02-2016, 07:02 PM
casey.mikl casey.mikl is offline
Ford Ranger Driver
 
Join Date: Mar 2012
Posts: 9,658
Default Re: Show Your System

Yeah I know. Got a better deal online. I gotta wait to mess with it till I get my truck back from the glass shop.


Sent from my iPhone using Tapatalk
__________________
1997 B2300 reg cab 2.3 Lima, 15x8.5 Mickey Thompson classic 2, 31x10.50 cooper discover at3, 7.5 open 4.10 rear, dynomax super turbo catback, alpine iva-w200 w/ nav, kicker 6x8s, alpine type R 8, alpine 250W mono amp, power bass 400.4, tool box & camper shell, compustar alarm/remote start.
1956 Ford F100 rust bucket with big plans!
Reply With Quote
  #5766  
Old 11-02-2016, 08:10 PM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,133
Default

Quote:
Originally Posted by AmericanPride! View Post
Yeah, buy a deck at a local shop and they would swap it over the counter
Maybe the local shop by him don't do that.
Reply With Quote
  #5767  
Old 11-02-2016, 08:12 PM
casey.mikl casey.mikl is offline
Ford Ranger Driver
 
Join Date: Mar 2012
Posts: 9,658
Default Re: Show Your System

They may. But I don't like dealing much with the local shops. I bought my subs from the local shop.


Sent from my iPhone using Tapatalk
__________________
1997 B2300 reg cab 2.3 Lima, 15x8.5 Mickey Thompson classic 2, 31x10.50 cooper discover at3, 7.5 open 4.10 rear, dynomax super turbo catback, alpine iva-w200 w/ nav, kicker 6x8s, alpine type R 8, alpine 250W mono amp, power bass 400.4, tool box & camper shell, compustar alarm/remote start.
1956 Ford F100 rust bucket with big plans!
Reply With Quote
  #5768  
Old 11-11-2016, 07:02 AM
Big 4.0 power Big 4.0 power is offline
Ford Ranger Driver
 
Join Date: Sep 2015
Posts: 1,658
Default

image-2849031787.jpg 've been looking at subs and found these two. Should I got for the 10" or 8"? I'd like to keep as possible room in the cab. image-1749875818.jpgDamn iPhone 7 spelling lol. Since I can't edit my post without it crashing
__________________
2002 xlt 4x4 Hines ward edition
Reply With Quote
  #5769  
Old 11-11-2016, 10:23 AM
FORD4LIFE9876 FORD4LIFE9876 is offline
Ford Ranger Driver
 
Join Date: May 2014
Posts: 956
Default Re: Show Your System

If you want the most room then the 8. Or look into a 6.5


Sent from my iPhone using Tapatalk
__________________
2000 ford ranger trailhead. 1985 k10 blazer 4x4
3.0 v6. 11" lift
2wd 40" tires
After market radio. 20" XD series rims!
Roll bar and toolbox
Offroad lights
Reply With Quote
  #5770  
Old 11-11-2016, 01:43 PM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,133
Default

Quote:
Originally Posted by Big 4.0 power View Post
've been looking at subs and found these two. Should I got for the 10" or 8"? I'd like to keep as possible room in the cab. Damn iPhone 7 spelling lol. Since I can't edit my post without it crashing
Look at the sundown E8. I have one in a custom box and it is great. Barely lost any room
Reply With Quote
  #5771  
Old 11-11-2016, 03:48 PM
FORD4LIFE9876 FORD4LIFE9876 is offline
Ford Ranger Driver
 
Join Date: May 2014
Posts: 956
Default Re: Show Your System

The sd8 is a little more expensive but is the shallow mount version and is better suited for a sealed box. Or look into the sundown x6.5 or soundqubed hds6.5.


Sent from my iPhone using Tapatalk
__________________
2000 ford ranger trailhead. 1985 k10 blazer 4x4
3.0 v6. 11" lift
2wd 40" tires
After market radio. 20" XD series rims!
Roll bar and toolbox
Offroad lights
Reply With Quote
  #5772  
Old 11-13-2016, 02:24 PM
bigfisher bigfisher is offline
F150 FX4 Owner
 
Join Date: Mar 2012
Posts: 13,975
Default Re: Show Your System

Main fuse already went out. Took it out and nothing looks blown but theres no continuity.
__________________
2013 F150 FX4 5.0
-2.5" Auto Spring Leveling Kit, Roush CAI, Black Widow Race Venom Exhaust, 35x12.5R18 KO2s, 20" Light Bar
Ranger Free Since 12/1/15
2001 Mustang Bullitt - Sold
2005 Level II - Sold
2001 Integra GSR - Sold
1999 XLT - May 2013 TOTM - Totaled
Quote:
Originally Posted by 2004 fx4 level II
fuckin Nissan shhhiitttttttttt!!!!!!!!!!!!!!!!!!
Reply With Quote
  #5773  
Old 11-13-2016, 04:50 PM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,133
Default

Quote:
Originally Posted by bigfisher View Post
Main fuse already went out. Took it out and nothing looks blown but theres no continuity.
What ya got going on?
Reply With Quote
  #5774  
Old 11-13-2016, 11:14 PM
bigfisher bigfisher is offline
F150 FX4 Owner
 
Join Date: Mar 2012
Posts: 13,975
Default

Quote:
Originally Posted by 63merc View Post
What ya got going on?
Not sure honestly. Noticed I had no bass friday. Started testing voltage at different places. No voltage at the amp, none after the fuse but up to the fuse I get 12V. Tested continuity and nothing. Hoping its just a one time thing and I don't keep blowing fuses.

Also my passenger side speakers aren't operative. Didn't even realize it. Buddy pointed it out to me. Gotta pull the panels off tomorrow.
__________________
2013 F150 FX4 5.0
-2.5" Auto Spring Leveling Kit, Roush CAI, Black Widow Race Venom Exhaust, 35x12.5R18 KO2s, 20" Light Bar
Ranger Free Since 12/1/15
2001 Mustang Bullitt - Sold
2005 Level II - Sold
2001 Integra GSR - Sold
1999 XLT - May 2013 TOTM - Totaled
Quote:
Originally Posted by 2004 fx4 level II
fuckin Nissan shhhiitttttttttt!!!!!!!!!!!!!!!!!!
Reply With Quote
  #5775  
Old 11-14-2016, 06:58 PM
63merc 63merc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,133
Default

Quote:
Originally Posted by bigfisher View Post
Not sure honestly. Noticed I had no bass friday. Started testing voltage at different places. No voltage at the amp, none after the fuse but up to the fuse I get 12V. Tested continuity and nothing. Hoping its just a one time thing and I don't keep blowing fuses.

Also my passenger side speakers aren't operative. Didn't even realize it. Buddy pointed it out to me. Gotta pull the panels off tomorrow.
Usually grounds or running ohms to low cause fuse issues assuming your power wire is good and big enough

I would check the amp first assuming it's a four channel before taking panels off. I have seen one side go out before
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Show off that INK!!! FX4 Off Topic 790 11-26-2014 07:38 AM
The show pics mikesturbo94 Vehicle Snapshots 9 07-17-2010 11:49 AM
Car Show - 05/01/10 DisturbedESV Vehicle Snapshots 8 05-04-2010 07:33 PM
tonneau who has them and show them off blueovelboy Exterior Tech 20 03-12-2010 01:34 PM
Show My Posts GaryCN Site Announcements, Comments and Suggestions 6 10-21-2009 06:23 AM