Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-12-2010, 08:57 PM
Cstalls Cstalls is offline
Ford Pickup
 
Join Date: Jul 2010
Posts: 100
Default Whole sterio stopped working..

I have. '99 ford ranger, with extended cab. I put a 10'' punch sub with a 200 watt jensen amp. (I know...it's cheap.) I also have a Clarion Deck. Anyway, my brother was driving it and said he was listening to a song when all of a sudden everything stopped, even the speakers and sub. The deck and amp are however still on.
The grounder appears to be fine, and I don't think I've blown a fuse, because the amp and deck are still on. So ya any hElp here would be loved!
Reply With Quote
  #2  
Old 07-12-2010, 09:54 PM
rangerdanger745 rangerdanger745 is offline
2010: Deer-2 / Ranger-0
 
Join Date: May 2010
Posts: 185
Default Re: Whole sterio stopped working..

still check your fuses and connections first. then we'll go from there
__________________
05 Edge: Westin step bars, Westin Brushguard, UWS tool box, Class IV Towing Hitch, 2 Rockford Fosgate 12" p2s,Pioneer headunit,8k HIDs in Heads, 35% Tint, Fog Light Mod, and Blinker Mod.
Next:New speakers all around and Flowmaster super 40 w/stock pipes.
Drive an EDGE? Join here: http://www.fordrangerforum.com/groups/edge+rangers.html
Reply With Quote
  #3  
Old 08-01-2010, 09:36 AM
kotchulookin kotchulookin is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 37
Default Re: Whole sterio stopped working..

i had a unit long ago that had a separate harness for output in the back, and it came loose and I lost all sound until I found the problem. If the head unit and amp still have power, it doesn't sound like a fuse or a ground wire. check rca cables or speaker lines in back of unit or make sure the rca cable wasn't severed somewhere due to friction or wear, and make sure you don't have one of those pesky mute buttons on the front of the head unit, that maybe your driver accidenally hit, without realizing it. Sounds stupid, but I know it's happened to people before.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signals and Hazards stopped working all of the sudden. Suggestions? holyriverjordan Electrical Tech 7 12-24-2016 11:19 AM
Cruise Control Stopped Working gradystebbins 3.0 Vulcan Tech 5 05-23-2012 06:03 PM
1999 Power windows stopped working Greg Electrical Tech 1 03-14-2010 09:47 PM
Radio and heater on 98 ranger stopped working troyfab Electrical Tech 6 11-23-2009 04:50 AM
Odometer Stopped working! swat784 Interior Tech 15 10-05-2009 01:55 PM