Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-29-2018, 05:49 PM
HDUE HDUE is offline
Learning to use the forums
 
Join Date: May 2018
Posts: 3
Default Premium stock radio question

stock radio didn't come on a couple of weeks ago. radio fuses were ok. I read some guy unhooked the battery for an hour so I tried that. The radio came on for about 10 seconds then went blank again. I read some guy say check ALL the fuses so I did that ,ALL ok..Since then I pulled the radio and checked the continuity of the ground wires on the 8 pin plug, good...checked power wires, good also. Now the truck sat over the weekend the radio came on for about a minute and hasn't come on since. My question (finally) is could the amp cause this or is it the head unit?

If it's the amp I'll probably do the after market route.(need suggestions)

If it's the head unit, I might just replace it.
__________________
1995 STX 4x4 Ext. Cab 3.0 auto
Reply With Quote
  #2  
Old 05-29-2018, 06:30 PM
casey.mikl casey.mikl is offline
Ford Ranger Driver
 
Join Date: Mar 2012
Posts: 9,686
Default Re: Premium stock radio question

The headunit itself doesnít turn on? Or it turns on but no sound? Total blank and get nothing would be headunit, no sound would be amp.


Sent from my iPhone using Tapatalk

----------

If itís factory it shouldnít have a separate amp, unless I believe you have the upgraded factory pioneer system with the factory amp. Itís been a while since Iíve talked about ranger stuff so my memory is a little dusty.


Sent from my iPhone using Tapatalk
__________________
1997 B2300 reg cab 2.3 Lima, 15x8.5 Mickey Thompson classic 2, 31x10.50 cooper discover at3, 7.5 open 4.10 rear, dynomax super turbo catback, alpine iva-w200 w/ nav, kicker 6x8s, alpine type R 8, alpine 250W mono amp, power bass 400.4, tool box & camper shell, compustar alarm/remote start.
1956 Ford F100 rust bucket with big plans!
Reply With Quote
  #3  
Old 05-31-2018, 02:16 PM
Mike69 Mike69 is offline
Another old fart
 
Join Date: Oct 2013
Posts: 6,996
Default Re: Premium stock radio question

Which radio do you have?.
__________________
2000 Ranger Extd Cab XLT, 4X4 Off Road, 4.0L, Auto, 8.8 - 4.10's (My DD)
Build thread http://www.fordrangerforum.com/proje...oad-build.html
69 Mustang(project) 5.0, T-5, 9" rear.
Build thread http://1969stang.com/forum/index.php...9-coupe-build/
99 Explorer Sport, 4.0 SOHC, Auto, 8.8 - 4.10's, PW, PL, PM, Cruise, Tilt. (Wife's DD)
Build thread http://www.explorerforum.com/forums/...=429940&page=4
Reply With Quote
  #4  
Old 05-31-2018, 07:34 PM
HDUE HDUE is offline
Learning to use the forums
 
Join Date: May 2018
Posts: 3
Default Re: Premium stock radio question

my radio is F57F-19B165-AE...funny thing, last night I got home and just checked the fuses again cause it hasn't come on for a few days..fuses were ok. turned key to accessory and it worked fine. set the clock and stations and listen to it about an hour . turned key off then back and blank again.

thanks for respnding
__________________
1995 STX 4x4 Ext. Cab 3.0 auto
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 premium radio aftermarket install issues 95DangeRanger Audio / Video 7 12-30-2013 02:29 PM
Premium gas question.. dangerranger94 Off Topic 26 12-08-2013 07:29 PM
For Sale: Factory Premium sound radio and amp spring794 Interior Parts 3 02-04-2013 08:38 PM
Ford Premium radio buttons onlyme Audio / Video 10 02-07-2012 01:40 PM
ford radio with premium sound blueovalhawkeyefan Electrical Tech 4 07-27-2009 05:42 PM