Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-30-2016, 04:37 PM
DangerFX4Ranger DangerFX4Ranger is offline
Like the Forums
 
Join Date: Feb 2016
Posts: 41
Default Radio only working in park and neutral

So this one right here is strange as can be. Driving to work today my radio worked fine. When I left work and turned on the radio, I had so sound. Everything else about the radio worked fine just no sound. It kept working here and there in spurts, but now it's not putting out any sound at all.

If I shift from drive to neutral, I have sound, and it goes right back out when I go back to drive. Any help would be appreciated. Some people said checking a fuse on the interior fuse box, others say it could be a bad neutral safety switch. If it is that, maybe replacing that will also cure my stiff shifting through the gears (automatic). Thanks in advance.
Reply With Quote
  #2  
Old 05-30-2016, 08:33 PM
Mike In Bama Mike In Bama is offline
Electronics Tech
 
Join Date: Mar 2013
Posts: 1,194
Default

There are a lot of unanswered items here (it may be because my phone app isn't showing them).

What year truck?

Stock radio?

Other details?

I'm sorry if my phone is keeping from seeing this information.
__________________
2005 2.3L XL 5SOD 3.73 K&N
KYB Shocks Husky Toolbox
Alpine / Rockford Fosgate Sound

"Ask me about my AC Vent fix!"
Reply With Quote
  #3  
Old 05-31-2016, 06:10 PM
rangergambler rangergambler is offline
Ford Ranger Driver
 
Join Date: Aug 2014
Posts: 790
Default

Help us help you.

How long u had the truck?

Recent work in dash area?

Need more info.
__________________
2010 2.3 Stick Reg Cab XL - Maxtrac 2 inch coils - Bilstein 5100 front shocks - Bilstein yellow rear shocks
Reply With Quote
  #4  
Old 06-01-2016, 11:59 AM
DangerFX4Ranger DangerFX4Ranger is offline
Like the Forums
 
Join Date: Feb 2016
Posts: 41
Default Re: Radio only working in park and neutral

06 FX4, stock radio. I've had it a few months, and no recent dash work as far as I know. Strangely enough, the radio is now working fine. But before it went back to normal, it would be on the fritz when the motion of the truck would change, like coming to a stop, taking off and going over bumps. It makes me think that it's probably something that has a so-so connection so sometimes it will break that circuit. It doesn't seem like it would be a short to ground because I'm pretty sure if it was, I'd have a blown fuse and it wouldn't work at all. So IF it is a continuity issue, it's probably most likely a short to power. Anyone got the wiring diagram for the radio circuit?
Reply With Quote
  #5  
Old 06-01-2016, 12:08 PM
Birdhunter1 Birdhunter1 is offline
Ford Motor Co
 
Join Date: Jul 2011
Posts: 172
Default Re: Radio only working in park and neutral

I had the same issue last week:
Radio has no sound in Drive ir Reverse

After a couple starts and stops it fixed itself ans has worked fine ever since. I kinda attributed my issue to possibly the truck was hit by lightning as we had a heck of a lightning show at work that day and we had network systems having some issues. I had the issue another time about 3 or 4 years ago driving home at night in a severe lightning storm, it hit close to me on the road and the radio quit for a while.


Have you had lightning in your area lately?
__________________
Alcohol, Tobacco and Firearms belong on a grocery list not a government agenda!
2007 Ranger reg cab, white, 6' bed, 4wd, 3.0 auto
1997 F 250 HD reg cab 4wd 351 auto
Reply With Quote
  #6  
Old 06-01-2016, 12:10 PM
rob3837 rob3837 is offline
'08 Ranger Sport 4x4, 4.0
 
Join Date: Feb 2016
Posts: 111
Default Re: Radio only working in park and neutral

If I'm reading this correctly, everything works as normal, but you don't get sound. so the radio is on, the display works and all that? If that's the case, I don't think it's a power issue, it sounds more like the wiring to your speakers might be shorting out. If that was the case you wouldn't be blowing any fuses, just losing sound.
Reply With Quote
  #7  
Old 06-02-2016, 08:04 PM
DangerFX4Ranger DangerFX4Ranger is offline
Like the Forums
 
Join Date: Feb 2016
Posts: 41
Default Re: Radio only working in park and neutral

Everything works fine but the big question is, when it was giving me issues, why would the radio work properly only in park and neutral? Only in those gears would i have sound.
Reply With Quote
  #8  
Old 07-05-2016, 09:35 AM
Birdhunter1 Birdhunter1 is offline
Ford Motor Co
 
Join Date: Jul 2011
Posts: 172
Default Re: Radio only working in park and neutral

Quote:
Originally Posted by DangerFX4Ranger View Post
Everything works fine but the big question is, when it was giving me issues, why would the radio work properly only in park and neutral? Only in those gears would i have sound.
Same weird thing happened top me, and when describing it people look at you like you're crazy.

I still think mine had been hit by lightning that day.
__________________
Alcohol, Tobacco and Firearms belong on a grocery list not a government agenda!
2007 Ranger reg cab, white, 6' bed, 4wd, 3.0 auto
1997 F 250 HD reg cab 4wd 351 auto
Reply With Quote
  #9  
Old 07-24-2017, 06:48 PM
Chevy_Country Chevy_Country is offline
Ford Tough
 
Join Date: Sep 2016
Posts: 278
Default Re: Radio only working in park and neutral

I just had this issue with my 04 xlt 4.0 4x4 stock radio and speakers, did we ever find a cause or solution!?


Sent from my iPad using Tapatalk
Reply With Quote
  #10  
Old 07-24-2017, 09:49 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: Radio only working in park and neutral

I'd swear the guy posted on another forum that the problem changed a bit, and the only time the radio worked was while the vehicle was floored and the tranny had downshifted from either 3-2 or 3-1. Crickets at all other times.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #11  
Old 07-25-2017, 03:48 AM
Chevy_Country Chevy_Country is offline
Ford Tough
 
Join Date: Sep 2016
Posts: 278
Default Re: Radio only working in park and neutral

Quote:
Originally Posted by cowboybilly9mile View Post
I'd swear the guy posted on another forum that the problem changed a bit, and the only time the radio worked was while the vehicle was floored and the tranny had downshifted from either 3-2 or 3-1. Crickets at all other times.


The rain had stopped, and as the day went on for me the radio would work so long as I wasn't hitting the gas, but coastin, then on he last trip home worked without a problem, even if I never have this problem again I want answers dammit lol

I'm confident this is a quick symptom because all threads in this die quickly with no answers lol


Sent from my iPad using Tapatalk
Reply With Quote
  #12  
Old 08-15-2017, 08:14 AM
hrhoward hrhoward is offline
Wilson is it's name
 
Join Date: Jan 2012
Posts: 66
Default Re: Radio only working in park and neutral

Answered in other thread but I'll stick it here as well.

I had this problem for over a year. Truck running and not in gear I had sound. In gear no sound. I finally found the circuit and bypassed it.

It is the red/black (red w/ black stripe at position 3 in C209A)) wire that I cut. Removed the terminal from the connector on the back of the radio and put a wirenut on the wire in the harness. That was over a year ago if memory serves. Never gave me a problem again.
Attached Images
File Type: jpg Ranger Speakers Not Working In Drive (2).jpg (80.6 KB, 4 views)
File Type: jpg Ranger Speakers Not Working In Drive (1).jpg (87.2 KB, 4 views)
Attached Files
File Type: pdf 2005_Ranger_Radio_Wiring_WithoutAudiophile.pdf (48.8 KB, 0 views)
__________________
2005 XLT 4.0 4x4 Automatic 5R55E 4 door
Avg. mpg: 18.2 Best mpg: 19.76
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Revs high in park and neutral? dented95ranger General Tech 3 10-20-2014 01:01 PM
stalling in neutral/park daytonaranger 4.0 SOHC / 4.0 OHV Tech 3 02-25-2014 06:42 PM
Why does it rev limit at 3k in park and neutral? Dye Guardian 4.0 SOHC / 4.0 OHV Tech 16 08-21-2013 08:26 PM
Transmission only has park and neutral djbrenson Drivetrain Tech 2 03-21-2013 05:52 AM
Ticking in Park and Neutral. danderson 4.0 SOHC / 4.0 OHV Tech 13 12-04-2012 01:51 PM