Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-29-2014, 04:33 AM
MustangLouver MustangLouver is offline
Learning to use the forums
 
Join Date: Sep 2014
Posts: 5
Default "Call" Displayed on Radio

I recently installed an explorer radio in my ranger to fill the hole in the dash from not having the correct radio for the truck. It seems like the radio is wired up correctly (All colors match) but the radio displays "Call" and is muted. Does anyone have any idea how to fix this issue? I really don't want to try to buy another radio.

EDIT: If anyone has this problem in the future, I have figured out the issue. The "Illumination" pin from the harness I ordered on ebay was in the "Phone" plug on the radio. This "phone" pin having power signaled the radio to be in "call" mode. I have since swapped the illumination pin on the harness to the correct spot on the explorer radio plug and the issue is resolved. Noticed this morning that my radio was not illuminating when the light were on and this prompted me to pull the radio and trace the wires back. Just for future reference should anyone order a factory wiring harness from ebay and have thsio same issue.

Last edited by MustangLouver; 09-30-2014 at 11:34 AM.
Reply With Quote
  #2  
Old 09-29-2014, 04:46 AM
Logan03CO Logan03CO is offline
No wire hangers, ever!

 
Join Date: Jun 2010
Posts: 10,335
Default Re: "Call" Displayed on Radio

Quote:
Originally Posted by MustangLouver View Post
I recently installed an explorer radio in my ranger....
Do you know if the Explorer radio even worked prior to install?
__________________
Curent 2003 Ford Mustang Mach 1 owner - Build Thread for her: Logan's 2003 Mach 1

Former 2003 Ford Ranger owner - Build Thread for her: Project Budget Buster
Reply With Quote
  #3  
Old 09-29-2014, 06:03 AM
MustangLouver MustangLouver is offline
Learning to use the forums
 
Join Date: Sep 2014
Posts: 5
Default Re: "Call" Displayed on Radio

I was told the radio was working fine when it was pulled by a family member, but I never saw it working the moment it was pulled.
Reply With Quote
  #4  
Old 09-29-2014, 06:41 AM
MustangLouver MustangLouver is offline
Learning to use the forums
 
Join Date: Sep 2014
Posts: 5
Default Re: "Call" Displayed on Radio

The only thing I can figure is there is something in the wiring harness that has the radio in "CALL" feature that mutes the radio when youre on a phone call. I just cannot find what is causing this in the radio. The radio powers on its just in mute due to the phone call feature that was in the explorers (1997 explorer).
Reply With Quote
  #5  
Old 09-29-2014, 11:27 AM
kronk kronk is offline
phdts
 
Join Date: Dec 2012
Posts: 268
Default Re: "Call" Displayed on Radio

Antitheft? I doubt fords this crafty, but every honda since the dawn of options has had a radio code. Radio loses power, changing a battery for ex, assumes its been stolen and locks its self. Radio will power on but nothing beyond that will happen till you enter the correct 6 digit code.

Edit: google says ford is as crafty as everyone else in the 90's.
http://www.explorerforum.com/forums/...d.php?t=345233
__________________
Quote:
Originally Posted by djfllmn View Post
Maybe he will shit in his mouth and taste his own bullshit

Last edited by kronk; 09-29-2014 at 11:35 AM.
Reply With Quote
  #6  
Old 09-30-2014, 04:24 AM
MustangLouver MustangLouver is offline
Learning to use the forums
 
Join Date: Sep 2014
Posts: 5
Default Re: "Call" Displayed on Radio

Left radio in and in the "on" position while driving home from work (30 minute drive) and the radio went past the call screen and started functioning correctly. Somehow it reset itself. I almost called and ordered an unlock code or called to see if there was an unlock code on the ford explorer radios, but seems all is well now.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: CB/Ham Radio "Booster" IL RNGR Misc Items 10 12-09-2012 07:29 PM
Want to Buy: "Thunderbolt" AKA "Roush" Front valance Aftermath Exterior Parts 0 03-18-2012 11:49 AM
Do Stock radio outputs "00" Ranger albert flasher Audio / Video 2 03-14-2012 02:51 AM
How do you replace the Engine coolant overflow "hose." With air conditioning "2.3l" rholder001 4-Cylinder Tech 1 08-02-2011 06:37 AM
2WD Tire "Cables" Or "Chains" Any Good In Snow? spudkilla224 Wheels and Tires 23 07-18-2011 12:55 AM