Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-24-2010, 01:05 PM
wtwest wtwest is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 17
Default Aftermarket radio help

I'm trying to put in a aftermarket in my 1987 ford ranger. I got a kit that hooks up the old wiring to the new. I got everything hooked up and the sound doesn't work. I re-hooked everything back up and it still doesn't work. I ended up hooking the stock radio back up and it works fine. The speakers don't seem to work with the new radio. I'm stumped on this. Any help is greatly appreciated.
Reply With Quote
  #2  
Old 04-24-2010, 01:09 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Aftermarket radio help

Did u set up the new radio.

The speakers may not be "turned on" Had that happen once on a radio I installed. The speakers were set to all 0 so no sound came out
__________________
2005 Edge

Reply With Quote
  #3  
Old 04-24-2010, 02:20 PM
geezmo2001 geezmo2001 is offline
My rangexplodeneer.
 
Join Date: Aug 2009
Posts: 247
Default Re: Aftermarket radio help

Also check speaker wires to make sure they are +to+ and -to-. Sometimes there are differences between manufacturers and the plugs (outputs) don't match up even though the colors do.
__________________
2001 Extended cab Edge, 4x4, 4.0, 4.10 gears, 3" PA body lift, Heartthrob dual exhaust, Roush Thunderbolt signal mirrors, 8000k hid head/foglights, Mountaineer leather buckets, Xplorer shorty console, Alpine 9856 receiver, 10" type r sub in ported box, air box mod, throttle cable mod, Rancho R5000 shox, Scangauge II, plus many other things...
Reply With Quote
  #4  
Old 04-24-2010, 02:35 PM
wtwest wtwest is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 17
Default Re: Aftermarket radio help

The radio worked in another vehicle, just not the ranger. The old wires are different colors than the aftermarket. I noticed that on the aftermarket plug packaging it says to use an adapter if you have preminum sound. Not sure if I have that or not? Not quite sure what audio options the STX came with. The stock radio is am/fm with cassette. There's no control for the speaker volume on the aftermarket radio. I just wanted to be able to listen to my ipod through the aux line on the new radio. Guess I might be putting the radio back in my kit car.
Reply With Quote
  #5  
Old 04-24-2010, 02:53 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Aftermarket radio help

87 rangers didnt come with premium radio option 1990 was the first time they had that
__________________
2005 Edge

Reply With Quote
  #6  
Old 04-24-2010, 04:20 PM
geezmo2001 geezmo2001 is offline
My rangexplodeneer.
 
Join Date: Aug 2009
Posts: 247
Default Re: Aftermarket radio help

Are you running 2 or 4 speakers? If 2 try adjusting the fader front to rear or vise versa. I trust it powers up, just no sound?
__________________
2001 Extended cab Edge, 4x4, 4.0, 4.10 gears, 3" PA body lift, Heartthrob dual exhaust, Roush Thunderbolt signal mirrors, 8000k hid head/foglights, Mountaineer leather buckets, Xplorer shorty console, Alpine 9856 receiver, 10" type r sub in ported box, air box mod, throttle cable mod, Rancho R5000 shox, Scangauge II, plus many other things...
Reply With Quote
  #7  
Old 04-24-2010, 08:01 PM
wtwest wtwest is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 17
Default Re: Aftermarket radio help

Yes, everything except sound. Fade and balance nothing happens. Has me puzzled that's for sure. I'm a little nervous about trying to do a direct wire splice. Don't want to be without any radio. LOL
__________________
1987 Ford Ranger STX
2.9L 4X4
AKA "The Beast"

Last edited by wtwest; 04-24-2010 at 08:05 PM.
Reply With Quote
  #8  
Old 04-27-2010, 04:16 PM
wtwest wtwest is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 17
Default Re: Aftermarket radio help

Thanks for all the advice. I ended up running some new wire and spliced into the front speakers. Everything working good.
__________________
1987 Ford Ranger STX
2.9L 4X4
AKA "The Beast"
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aftermarket Wheels 02BlueRanger Wheels and Tires 17 06-08-2011 05:19 PM
Help with aftermarket radio! johnson17k Audio / Video 5 04-05-2010 11:07 PM
aftermarket ignition mad hatter 4.0 SOHC / 4.0 OHV Tech 2 03-17-2010 06:49 PM
aftermarket lights shawn 4-Cylinder Tech 5 10-02-2009 04:16 PM
Aftermarket stereo 02BlueRanger Electrical Tech 3 07-27-2009 07:10 AM