PDA

View Full Version : Computer Module


ray_vtx_1800c
10-29-2009, 04:02 PM
My speedometer say 50 and my GPS say 61. The dealer recommend checking the connection to the computer. Anybody know where the Computer Module is located in a 2004 Ford Ranger XL 2x4?

Ray

Johnbaum13
10-29-2009, 04:59 PM
What size tire are you running? A larger than stock tire will cause this kind of discrepancy.

ray_vtx_1800c
10-29-2009, 05:19 PM
Suppose to be 225/70R15 and I have 225/75R15. Is that enough to cause 11 mph difference? Plus the needle drops like 11 mph below zero.

Johnbaum13
10-29-2009, 05:31 PM
Well then it sound like the needle is what needs to be adjusted doesn't it?

Pull the cluster out and fix it.

ray_vtx_1800c
10-29-2009, 06:35 PM
Just got back from Walmart. Got 4 tires 225/70R15 and still have same problem. I tried adjusting the needle and problem returns when truck sit turned off for a couple minutes. I just disconnected the battery and now I going to take it for a test ride.

STL
10-29-2009, 06:46 PM
Are you talking about the PCM (power control module) if so it is on the passenger side under the hood up on the fire wall.
Disconnect neg. battery cable
Loosen center bolt disconnect PCM connection
Remove 2 nuts that hold the PCM to the firewall and remove PCM

http://i952.photobucket.com/albums/ae1/Mykhael_Hayes/Random%20Ranger%20Pictures/49d512e1.jpg

ray_vtx_1800c
10-30-2009, 07:34 AM
Fixed

Cleaned PCM connector using MAF Sensor cleaning. Did not have to completely remove PCM. It's been 2 hours with NO problems. Actually, truck sounds and run better. Will post message if problem returns.