View Single Post
Old 01-20-2012, 10:38 PM
DNGRNGR89 DNGRNGR89 is offline
Like the Forums
Join Date: Jan 2012
Posts: 34
Exclamation 89 2.3l cranks but no fire! What gives?

I have a 1989 2.3L 4x4 5-speed Ranger. The other day I parked the truck to fix the drum brakes, when I was finished with the brakes I went to drive the truck and it would crank hard but would never fire. I've done a little diagnosing so far but am starting this thread because tomorrow I'm really going to try and tackle this issue, I really need my truck back!

So far I have turned the key to run and can not hear the fuel pump humm.
I checked all my fuses and all were okay.
I pressed on the schrader valve and a small amount of fuel came out the first time but the first time only.
I removed the inertia switch and am unsure if it needed reset or not. I'm going to temporarily bypass it.

Tomorrow I am going to check for spark, pull codes, and remove my distributorless ignition system pack & my fuel pump relay and have Oreilly's test them.

What else should I check? OR in what order would you attempt solving this problem?

I bought this truck about half a year ago and have had to replace just about everything on it. So I wouldn't be surprised if it's just a bad fuel pump especially since it will be the hardest part to replace and the tank is full of gas. It's got new spark plugs, plug wires, and coil packs. The battery and alternator are brand new. I'm just hoping it's not a short somewhere.. I just think it's weird cause it was running fine when I parked it two days ago!
1989 RANGER XLT 2.3L 4X4 (Build Thread)
1991 MUSTANG 5.0 GT

FORD because bowties are for pussies.
Reply With Quote