Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-06-2010, 03:40 PM
lildevjkoch1977 lildevjkoch1977 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 10
Default 2000 2.5l ranger runs like crap

Hi i have a 2.5L ranger that i cant get to run right. If i just let it sit after i start it it will run fine but if i give it any gas it starts to run like crap and stall. After its warm up it runs ok. I was told that the code was a p0302. That a miss fire in cylinder 2. I tried a number of things. New wires, spark plugs ,new coil pack ,fuel filter and idol control valve. I just cant figure the damn thing out does anyone have any ideas that might help. THANKS JOE
Reply With Quote
  #2  
Old 03-07-2010, 06:02 PM
macfan71 macfan71 is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 14
Default Re: 2000 2.5l ranger runs like crap

I'm currently getting the same code and rough idle/performance with my Ranger of the same year and engine. I have done everything you have done, except replacing the idle control valve. I just disconnected it and it ran worse so I guess its ok.

I also just swapped the coils around figuring the odds of both being bad was pretty small.

I ended up taking it to a local mechanic and will post the results when I get them.
__________________
2000 Ranger XLT, reg. cab, flare-side
2.5L gas, 2wd, automatic, A/C
200k
Iowa
Reply With Quote
  #3  
Old 03-08-2010, 06:46 PM
lildevjkoch1977 lildevjkoch1977 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 10
Default Re: 2000 2.5l ranger runs like crap

that would be great. anything you could tell me would be very helpfull. at least i got good news i had a compression test done and the motor is fine. thats a pluse
Reply With Quote
  #4  
Old 03-15-2010, 07:17 AM
macfan71 macfan71 is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 14
Default Re: 2000 2.5l ranger runs like crap

Well, this is what I know so far...

The mechanic is still trying to figure out what is wrong. He has tried new coils which didn't solve it, luckily he was able to return them.

He says the compression is good, which should mean the head gasket is ok.

The fuel injector seems to be ok, too. He did replace the timing belt, which needed done badly anyway.

I am going to give him a couple more days and then I guess I'll have to take it to a dealership.
__________________
2000 Ranger XLT, reg. cab, flare-side
2.5L gas, 2wd, automatic, A/C
200k
Iowa
Reply With Quote
  #5  
Old 04-07-2010, 09:15 AM
philidopolus philidopolus is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 24
Default Re: 2000 2.5l ranger runs like crap

could be a maf sensor or dpfe sensor. Had the same problem, and had both those replaced. 99 2.5 runs fine now. been about a year since this happened. if you can, this would be cheaper to do yourself, but I had a mechanic do it because I dont have a scanner. w/a mechanic it costs about 500 bucks. ugh. I hope this helps.
__________________
1999 2wd 2.5 4 banger reg cab
Just a few mods. Pioneer head unit, upgraded to 15 inch explorer wheels, diamond plate tool box.
Reply With Quote
  #6  
Old 04-08-2010, 05:34 PM
JimW JimW is offline
Learning to use the forums
 
Join Date: Mar 2010
Posts: 6
Default Re: 2000 2.5l ranger runs like crap

What is the dpfe sensor? Or can you say where it located on the engine? I have the same issues transpiring with my '00 2.5. How many miles do you guys have on yours? I'm at 231k.
Reply With Quote
  #7  
Old 04-08-2010, 07:26 PM
lildevjkoch1977 lildevjkoch1977 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 10
Default Re: 2000 2.5l ranger runs like crap

the dpfe sensor is located on the passenger side near the fire wall it has two vacuum lines going in to is from the bottom and a plug from the side. good luck i found out that mine has a bent valve I'm having the head replaced this weekend. 231k that's great mine only has 118k
Reply With Quote
  #8  
Old 04-09-2010, 07:03 AM
philidopolus philidopolus is offline
Liking the Ford Ranger Forum
 
Join Date: Apr 2010
Posts: 24
Default Re: 2000 2.5l ranger runs like crap

Jim: He's right about where the sensor is located. I hope you get the problem fixed. Mine happened about around 155k. I have 177k now, and everythings good. Good luck.
__________________
1999 2wd 2.5 4 banger reg cab
Just a few mods. Pioneer head unit, upgraded to 15 inch explorer wheels, diamond plate tool box.
Reply With Quote
  #9  
Old 04-13-2010, 06:32 PM
JimW JimW is offline
Learning to use the forums
 
Join Date: Mar 2010
Posts: 6
Default Re: 2000 2.5l ranger runs like crap

I did a second compression test with the engine at operating temp and found #1 cylinder40 psi low. I pulled the head and found #1 exhaust valve had worn into the head about an 1/8" causing my dilemma. My machine shop guy, Lou, is installing new valves and seats on all the exhaust valves and doing a valve job on intakes. , Finally, problem solved!
Also, I found two lifters on seperate cylinders that appear to be bad - they have no spring tension on the last 3/8" or so of travel - I was wondering if anyone esle has encounted this. I'm replacing all the lifters anyway due to concern that this is no good.

p.s. - what exactly does the dpfe sensor do?
Reply With Quote
  #10  
Old 04-14-2010, 07:31 PM
macfan71 macfan71 is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 14
Default Re: 2000 2.5l ranger runs like crap

Well, the mechanic I had working on my Ranger has not been able to figure out the problem. He has replaced the timing belt, spark plugs, egr tube, and tried used coils. He also took off the head and cleaned what he described as a lot of carbon off the valves. I asked him if the valves themselves were ok, and he said they were. He also thought the cam lobes looked ok. He put in a new fuel injector on #2 cylinder as well.

I also asked him about the dfpe sensor mentioned earlier. He said it wouldn't make it do what it is doing. My family goes to this guy a lot and trust his work. I think this is the first time he has been stumped.

He suggested that I take it to a dealership which is what I plan to do in the next couple days. Maybe they have seen this before.

I'll let you guys know when I do. It's gonna be expensive I am sure.
__________________
2000 Ranger XLT, reg. cab, flare-side
2.5L gas, 2wd, automatic, A/C
200k
Iowa
Reply With Quote
  #11  
Old 04-19-2010, 07:34 PM
JimW JimW is offline
Learning to use the forums
 
Join Date: Mar 2010
Posts: 6
Default Re: 2000 2.5l ranger runs like crap

Looking at the cam and valves is not the ideal inspection. He should check to see if the injector is being told to fire via an injector harness tester (plugs into the injector plug and lights uop as the injector signal is sent to the injector). A compression check and leak down test with the engine hot should be done and if he had the head off then he3 should have removed the cam and measured the lobes with a micrometer - the book says .005 of wear is allowable. Do yourself a favor and stop with the parts replacement. Did he use new head bolts and head gasket when head was reinstalled? If not, then you probably have more problems nows than you started with. Also should have the head checked for being flat when it is removed.
Good luck.
I got mine back together this weekend and it runs great - thank God! It had been low on power for so long that I didn't remember how well it could run. I replaced the timing belt, front crank seal, oil punmp seal, water pump, plugs and wires (again). Parts and machine shop bill total $425. Seems like alot of money, it's less thank one month's payment on a new truck.
Reply With Quote
  #12  
Old 04-20-2010, 04:39 AM
92 coupe 92 coupe is offline
Learning to use the forums
 
Join Date: Mar 2010
Posts: 13
Default Re: 2000 2.5l ranger runs like crap

let the intake suck in a can of seafoam. Stuff works wonders for worn engines. Mine was getting 17mpg before i did mine , and it now gets 23mpg on the freeway doing 60-70 mph everday.
__________________
98 ford ranger 2.5 w/ warrior wheels, and K&n filter. 120hp/110 torque

92 coupe mustang w/AFR heads,trick flow stage 1 cam , 650 holley carb, on top of eldebrock air gap intake.C-4 tranny w/4200 stall. 408hp/342 torque.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
crap, hit something large smakes Off Topic 33 02-12-2010 08:57 PM
For sale: 1986 ford ranger 130k runs great Ride_Sally_Ride Trucks 1 11-23-2009 12:06 PM
90 ranger 4cyl auto, starts and runs but have to hold key.. 90ranger Electrical Tech 3 11-15-2009 02:10 PM
holy crap Superlifted06FX4 Off Topic 7 09-27-2009 08:11 AM
1998 Ford Ranger runs rough with sulfur smell? Michael K General Ford Ranger Discussion 1 01-01-2009 01:57 PM