Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-11-2013, 06:44 PM
computersoc computersoc is offline
Ford Ranger Driver
 
Join Date: May 2012
Posts: 516
Default Tachometer stopped working

Today I started my truck and the tachometer went from its normal 1200RPM when it gets started to jumping all around (from 0 to 1500). Then it went to 0 and stayed on 0 for a bit while I let the engine warm up. Then when I started driving, it was fine and showed me the correct RPMs. The other day I saw the tacometer jump around a little while I was driving but thought I was just seeing things.

Could it be related to this thread:
http://www.fordrangerforum.com/4-cyl...eedometer.html

No CEL right now and other than the speedometer only working when it wants to (it's been fine for a few days now), everything is working fine.

EDIT: Just to make it clear, when the RPM on the tach shows 0RPM, the engine itself is really running fine. Only reason the RPM should be 0 is if the engine is off...
__________________
2001 Ford Ranger XLT, 2.5L engine, single cab, manual transmission, RWD

Last edited by computersoc; 03-11-2013 at 07:59 PM.
Reply With Quote
  #2  
Old 03-12-2013, 11:27 AM
Shero Shero is offline
kickabucket
 
Join Date: Mar 2013
Posts: 20
Default Re: Tachometer stopped working

i've never experienced something like that before, but when I have a problem like that and no clue of where to start looking, I start at the part that isnt working and follow the trail, what I mean by that is if it were me and i'm sure there are easier ways then this that someone else on here will probably recommend doing, but I would take the dash off and follow whatever the tach is driven by to whatever drives that or makes it work and etc. till i found the problem it sounds like whatever makes the needle move isnt functioning correctly either by its self or whatever makes it work, but anyways thats what I would do.
__________________
1996 Ford Ranger 2.3, 4 on the floor with OD on stand by.
Reply With Quote
  #3  
Old 03-12-2013, 11:36 AM
patrickposton92 patrickposton92 is offline
Ford Tough
 
Join Date: Mar 2013
Posts: 314
Default

Quote:
Originally Posted by Shero View Post
i've never experienced something like that before, but when I have a problem like that and no clue of where to start looking, I start at the part that isnt working and follow the trail, what I mean by that is if it were me and i'm sure there are easier ways then this that someone else on here will probably recommend doing, but I would take the dash off and follow whatever the tach is driven by to whatever drives that or makes it work and etc. till i found the problem it sounds like whatever makes the needle move isnt functioning correctly either by its self or whatever makes it work, but anyways thats what I would do.
Agree whole heartedley. Ive seen this happen in my friends 4.0 explorer, i think it was an 01.
__________________
Patrick Poston 1990 ford ranger 4cyl 5spd 4wd & 1984 ford ranger 2.0 4spd 2wd. Love em' both
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter stopped working ludgate124 4.0 SOHC / 4.0 OHV Tech 2 11-23-2012 09:14 PM
speakers stopped working ctw2349 Audio / Video 10 04-22-2012 07:34 PM
Tachometer not working kylejackson74 Interior Tech 2 03-26-2012 07:41 PM
Wipers stopped working Jstaab1 Exterior Tech 0 10-10-2011 01:17 PM
Whole sterio stopped working.. Cstalls Audio / Video 2 08-01-2010 09:36 AM