Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 03-03-2013, 10:23 AM
fieldsleah fieldsleah is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 10
Default Re: ignition cuts out on 94 2.3 liter

You can get this tool at this link: http://www.toolsource.com/ford-crank...-p-124602.html. Also go to:http://www.rockauto.com/catalog/more...190&cc=1137967 this shows how the tool mounts to the sensor.
Reply With Quote
  #17  
Old 03-03-2013, 10:41 AM
fieldsleah fieldsleah is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 10
Default Re: ignition cuts out on 94 2.3 liter

The part number for this tool is T89P-6316-A. You can get this tool at http://www.toolsource.com/ford-crank...-p-124602.html . Go to http://www.rockauto.com/catalog/more...190&cc=1137967 to see how the tool mounts to the sensor. It's easy to use. Mount the tool to the sensor, leave the sensor loose, rotate the crankshaft till the vane passes through the tool. Tighten down the sensor, then rotate the crankshaft till the vane clears the tool then remove it. Hope this helps.
Reply With Quote
  #18  
Old 03-03-2013, 11:03 AM
frustranger frustranger is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2013
Posts: 25
Default Re: ignition cuts out on 94 2.3 liter

I'm going to try exactly this. Of the 50 or so things I've tried, fiddling with the crack position sensor is the only thing that has had even the slightest effect on the problem. It's not clear to me why the cutting out seems to be mostly at low rpm high throttle if its the crank sensor but I don't care. As long as I make it better... Thanks for the help.
__________________
94 ranger, 2wd, 2.3 liter engine
Reply With Quote
  #19  
Old 03-03-2013, 11:29 AM
fieldsleah fieldsleah is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 10
Default Re: ignition cuts out on 94 2.3 liter

I copied this from my Ford manual :Crankshaft Position Sensor (CKP)

The crankshaft position sensor (CKP sensor) (6C315) is a dual Hall effect magnetic switch, which is actuated by the dual vane armature on the crankshaft pulley hub (6C337). The crankshaft position sensor generates two separate signals, PIP (profile ignition pick-up) and CID (cylinder identification). The PIP signal provides base timing and rpm information, while the CID signal is used to synchronize the ignition coils. Initial timing (base timing) is set at 10 2 degrees BTDC and is not adjustable.

Failure Mode Effects Management:

During some faults of the ignition control module, the Failure Mode Effects Management (FMEM) portion of the ignition control module will maintain vehicle operation. If the ignition control module does not receive the SPOUT input, it will automatically turn the ignition coils on and off using the PIP signal. However, this will result in fixed spark timing (ten degrees BTDC) and a fixed dwell time (no CCD). If the ignition control module does not receive the CID input, random coil synchronization will be attempted by the ignition control module. Therefore, several start attempts may be required to start the engine.

I would also double check the timing marks to. Key way on the crankshaft is at the 12:00 O'clock position.
Good Luck
Attached Images
File Type: jpg 2008-07-31_170445_Timing_2.5.jpg (58.3 KB, 17 views)
Reply With Quote
  #20  
Old 03-03-2013, 12:27 PM
frustranger frustranger is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2013
Posts: 25
Default Re: ignition cuts out on 94 2.3 liter

Since I will be in there anyway, I'm going to change the timing belt too. I'll double check the timing marks but, it runs fine right up until I give it too much gas at low rpm. The timing marks really couldn't be off it it runs fine most of the time. I go about 20 miles to work on way and most days, it dies once or twice on the way there, once or twice on the way back. The rest of the time it runs fine. I get about 20 mpg so I figure that's about right in town.
__________________
94 ranger, 2wd, 2.3 liter engine
Reply With Quote
  #21  
Old 03-04-2013, 07:22 PM
southerncali626 southerncali626 is offline
Learning to use the forums
 
Join Date: Mar 2013
Posts: 10
Default

Hey man had the same problem just like you! I would be driving an came to a quick stop or any sudden stop of sort it would die out felt like the alternator or something..told a mechanic an they said too change the spark plugs so I did an the wires that go too it an bam! Problem fixed try it out man
Reply With Quote
  #22  
Old 03-23-2013, 01:46 PM
frustranger frustranger is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2013
Posts: 25
Default Re: ignition cuts out on 94 2.3 liter

ok, I have adjusted the crank sensor and changed the timing belt. It made no difference whatsoever. So now I've restarted again on the fault codes. I get the following codes: 218, 222, 224, 332. The 218 and 222 aren't even in my manual. Does anyone have any ideas on those? Code 224 interests me though, spout circuit open. To me, that means the computed timing is not being transferred to the ignition control module and on to the coils. That seems to fit with the symptom of cutting out whenever I use throttle beyond a certain point. I found the spout connector and disconnected it. I drove around the block on base timing which made it a little slower than usual and it still cuts out every once in awhile so I figure that's not the problem. Any ideas out there?
__________________
94 ranger, 2wd, 2.3 liter engine
Reply With Quote
  #23  
Old 03-25-2013, 11:29 PM
4Banger5speed 4Banger5speed is offline
F T P !
 
Join Date: Oct 2012
Posts: 155
Default Re: ignition cuts out on 94 2.3 liter

The 218 code is: IDM signal or high or open or left coil pack failure- Ignition Systems The 222 code is: IDM signal too high or open or right coil pack failure. Try replacing the Ignition Control Module. My truck had all the same codes. Except I knew about the 332 cause I blocked off/disabled my EGR. Took forever for me to figure out. No one on this forum had a clue. Or didnt post if they did. I replaced it with a junkyard ICM (paid 15 bucks I think) Thats what it ended up being. It was like I put a new motor in the truck. Make sure you get all the screws back in because they are grounding points too. Let us know if you get it fixed. Good luck with your repair.
__________________
Red 1994 Mazda B2300 Base Model With A/C--2.3L--140cid-100hp--4Cyl--D.I.S. Engine Code [A]--Bosch (4505) Fusion Iradium Spark Plugs-- "Cheap" 8mm Silicone Plug Wires--Gatorback Belt--Blocked Off/Disabled EGR Valve--Coil Mod--Throttle Cable Mod--Magnaflow Muffler/No CAT--5 Speed M5R1-RWD--3.45 Non Limited Slip Rear End---Lowered 5" Rear 3 1/2" Front---269,000 Miles as of 11/1/2013---If its a Ford you will need to keep a lot of tools and a good fire extinguisher handy.
Reply With Quote
  #24  
Old 03-26-2013, 09:00 AM
frustranger frustranger is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2013
Posts: 25
Default Re: ignition cuts out on 94 2.3 liter

Had the ICM tested and it was fine. changed it anyway, no difference whatsoever...
__________________
94 ranger, 2wd, 2.3 liter engine
Reply With Quote
  #25  
Old 03-26-2013, 10:11 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: Re: ignition cuts out on 94 2.3 liter

Quote:
Originally Posted by frustranger View Post
Had the ICM tested and it was fine. changed it anyway, no difference whatsoever...
I did not read the entire thread but I have a thought. When you are in WOT the system switches to open loop and only uses few sensors. Does it start OK when cold?

SFDROIDBIONICUT2

----------

When you disconnect the maf the truck should not run. A few of the sensors that work in open loop are the maf and ect

SFDROIDBIONICUT2

----------

Another thought and I admit a long shot is the ignition switch.

SFDROIDBIONICUT2
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).

Last edited by modelageek; 03-26-2013 at 10:33 AM.
Reply With Quote
  #26  
Old 03-27-2013, 09:33 AM
frustranger frustranger is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2013
Posts: 25
Default Re: ignition cuts out on 94 2.3 liter

Starts fine when cold, runs fine with MAF, o2, DPFE disconnected but still dies like always. That's why I've ruled out those sensors. I've resorted to hooking up a voltmeter to each pin coming of the ECC one at a time and monitoring voltage as I drive. When it dies, I quickly look down to see if the behavior of the voltmeter changes. Not the safest way to drive I guess...anyway, I haven't come across anything that changes. When you turn the key off, the power to the ECC and many other things stops and I see that on the voltmeter but when the engine dies, the power is constant so I thought I had ruled out the ignition switch. I can even still see the TPS response with the throttle as I'm coasting with the motor dead.

Keep thinking about this though, you might get it yet and save me from a stroke. Thanks for the help.
__________________
94 ranger, 2wd, 2.3 liter engine
Reply With Quote
  #27  
Old 03-27-2013, 09:41 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: ignition cuts out on 94 2.3 liter

The truck should die pretty quickly with the maf disconnected. If it does not I wonder if it reverts to a preprogrammed setting? I would not eliminate the maf yet.

SFDROIDBIONICUT2
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #28  
Old 03-27-2013, 09:56 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: ignition cuts out on 94 2.3 liter

I like the way you think. I will let it ruminate. I wonder if you could setup your multi meter to the injectors, the ect or to the fuel pump, etc. Or else identify those pins and go right to them?

SFDROIDBIONICUT2
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).

Last edited by modelageek; 03-27-2013 at 10:05 AM.
Reply With Quote
  #29  
Old 03-27-2013, 04:40 PM
fieldsleah fieldsleah is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 10
Default Re: ignition cuts out on 94 2.3 liter

Since you have changed the Crankshaft sensor make sure the connector is pinned correctly. If one pin is not right it will go into the Failure Mode Effects Management and you will get those codes.

Reply With Quote
  #30  
Old 03-28-2013, 04:44 PM
frustranger frustranger is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2013
Posts: 25
Default Re: ignition cuts out on 94 2.3 liter

Am I right in thinking that if I had rewired it incorrectly, it wouldn't run very well? It hadn't been changed since it left the factory, I hooked it up exactly as before and it doesn't behave differently in the slightest. Either I made a mistake in rewiring that had absolutely no effect, or the factory did. Either way, it doesn't explain why it runs fine 99% of the time and then dies (and drove fine from 94 to about 2010). I've checked the signals coming from the sensor, one of them is far easier to see than the other (I think the signal that says which coil to fire is the one that is hard to see), and they don't change when it dies. We have to be getting close to figuring this out, there's not that much left...Keep trying!
__________________
94 ranger, 2wd, 2.3 liter engine
Reply With Quote
Reply

Tags
cuts out, ignition

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stereo Audio cuts-out when in gear or Ignition in Aux DJBaar Audio / Video 0 06-09-2012 11:19 PM
A/C Cuts in and out ricbaxter Interior Tech 8 03-31-2012 08:20 AM
92 ranger 2.9 liter to 4.0 liter conversion greener12 4.0 SOHC / 4.0 OHV Tech 0 11-07-2011 08:02 PM
94 2.3 cuts out chance08 4-Cylinder Tech 2 02-23-2010 07:35 PM
A/C Cuts Out DQuinn Electrical Tech 2 07-15-2009 12:33 PM