Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-22-2010, 07:56 PM
chance08 chance08 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Default 94 2.3 cuts out

yes i have a 94 ranger that runs fine till it warms up then it starts cutting out and backfiring any help with this problem if you pull over and shut it off it clears up for awhile some times its hard to get it to restart i was told it might be cam sensor but from what i can tell from where they say it is my dont have any wires ran to it help me plz thanks for the time
Reply With Quote
  #2  
Old 02-22-2010, 08:06 PM
mtwong50 mtwong50 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 4
Default Try the distributor

On a lot of the ford v6 distributor is on the rear of the engine after a while it gets fried from all the engine heat. Try replacing the distributor...
Reply With Quote
  #3  
Old 02-23-2010, 07:35 PM
chance08 chance08 is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Default

it dont have a distributer it has crank sensor with dis box

Last edited by chance08; 02-23-2010 at 07:36 PM. Reason: spelling
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
engine cuts out while driving? lowr 4-Cylinder Tech 5 10-06-2016 05:57 AM
'97 Ranger Wiper Cuts Out stdprm11 Electrical Tech 12 09-08-2016 01:54 PM
2005 ranger cuts out only when it snows wideglide 4-Cylinder Tech 2 01-30-2010 04:30 PM
Runs for about 30 mins and cuts off Nameless891 2.9 Liter Tech 13 10-01-2009 06:45 PM
A/C Cuts Out DQuinn Electrical Tech 2 07-15-2009 12:33 PM